2 Replies Latest reply on Dec 7, 2018 5:59 AM by AlmightyJu

    VCSA 6.7 install failing due to LDAP error

    AlmightyJu Lurker

      So I've gotten a trial version of esxi 6.7 and running inside a virtual machine in workstation and it's up and running fine on the ip 192.168.0.241.

       

      I've ran the setup for vCenter and it's done the stage 1 without an issue but stage 2 is failing with "Could not connect to VMware Directory Service via LDAP. Verify VMware Directory Service is running on the appropriate system and is reachable from this host."

       

      From reading it seemed like a DNS issue, so I added vcenter.vsphere.local as 192.168.0.240 and esxi1.vsphere.local as 192.168.0.241 which didn't make any difference, I added the PTR records just in case and still failed. Doing a dig for both DNS records worked fine from the console on the vCenter machine so it doesn't appear to be that from what I can tell.

       

      The relevant firstboot logs seems to be:

       

      2018-12-06T21:23:51.783Z  Running command: ['/usr/lib/vmware-vmafd/bin/vdcpromo', '-u', 'Administrator', '-s', 'default-site', '-h', 'vcenter.vsphere.local', '-d', 'vsphere.local']

      2018-12-06T21:26:23.088Z  password:

      2018-12-06T21:26:23.090Z  Initializing Directory server instance ...

      Vdcpromo failed. Error[9127]

      Could not connect to VMware Directory Service via LDAP.

      Verify VMware Directory Service is running on the appropriate system and is reachable from this host.

       

       

      2018-12-06T21:26:23.091Z  <class 'cis.baseCISException.BaseInstallException'>

      2018-12-06T21:26:23.096Z  Exception: Traceback (most recent call last):

        File "/usr/lib/vmware-vmafd/firstboot/vmafd-firstboot.py", line 177, in main

          controller.firstboot()

        File "/usr/lib/vmware-vmafd/firstboot/vmafd-firstboot.py", line 53, in firstboot

          self.init()

        File "/usr/lib/vmware-vmafd/firstboot/vmafd-firstboot.py", line 59, in init

          service.init()

        File "/usr/lib/vmware-vmafd/firstboot/identityinstall/vmdirInstall.py", line 404, in init

          self.setup_domain()

        File "/usr/lib/vmware-vmafd/firstboot/identityinstall/vmdirInstall.py", line 259, in setup_domain

          problemId = problem)

      cis.baseCISException.BaseInstallException: {

          "problemId": "install.vmafd.vmdir_vdcpromo_error_23",

          "detail": [

              {

                  "id": "install.vmafd.vmdir_vdcpromo_error_23",

                  "translatable": "Could not connect to VMware Directory Service via LDAP. Verify VMware Directory Service is running on the appropriate system and is reachable from this host.",

                  "localized": "Could not connect to VMware Directory Service via LDAP. Verify VMware Directory Service is running on the appropriate system and is reachable from this host."

              }

          ],

          "resolution": {

              "id": "install.vmafd.vmdir_vdcpromo_error_23.resolution",

              "translatable": "Please search of these symptoms in the VMware Knowledge Base for any known issues and possible workarounds. If none can be found, please collect a support bundle and open a support request.",

              "localized": "Please search of these symptoms in the VMware Knowledge Base for any known issues and possible workarounds. If none can be found, please collect a support bundle and open a support request."

          },

          "componentKey": "vmafd"

      }

       

      2018-12-06T21:26:23.091Z  VMAFD Boot failed

       

      I honestly have no idea where to go from here since I've never installed this myself so any help would be fab. I've attached all the logs if it's of any help