0 Replies Latest reply on Dec 6, 2018 3:43 AM by MenezesAlvaro

    Timestamp Parsing -  IBM Websphere log files

    MenezesAlvaro Lurker

      We are currently loading IBM Websphere log files but we are having trouble parsing the timestamp format in the logs.

      We tried to use several different formats, but none is creating a valid timestamp. This is very important because 90% of our logs are from Websphere and all of them are using the same timestamp format.

      The main issue is related with the fraction of seconds, they are using ':' instead of '.' or ',' meaning I can't use %f


      Hope you can help



      Content example:


      [06-12-2018 11:02:05:621 WAT] 00021b4d NodeSyncTask A ADMS0003I: The configuration synchronization completed successfully.

      [06-12-2018 10:58:17:839 WAT] 00000062 InputStreamCa W json rpc temp folder /usr/IBM/WebSphere85/AppServer/profiles/adremdbpm1/temp/jsonstreams/server deleted.


      parser configuration example (I tried so many different ):




      format=[%{%d-%m-%Y %H:%M:%S}t:%i %i] %i %{tipoEvento}i %{severityEvento}i



      kind regards,


      Álvaro Menezes