9 Replies Latest reply on Dec 4, 2018 1:20 AM by cegjd

    Win 10 - No IP Address after succesful provision

    cegjd Novice

      ESXi 5.5

      vRA
      7.3

      Multi Tenant

       

      I have an issue with Win 10 v1803 in vRA. It is not assigning an IP and is instead picking up APIPA 169.x.x.x address.

       

      We use VMWare Guest customisation scripts to set the hostname and IP.

       

      I have had this issue previously and normally do the following:

       

      Delete the NIC and regkeys.

      Upgrade VMTools

      Turn down the aggressiveness of DRS

      Sysprep – check Win10 isn’t failing on a package

       

      These have all resolved in the past.

       

      Previously the VM would never finish provisioning, it would eventually fail and delete. These VMs are completing as successful – they just don’t have the IP.

       

      We have Win 7 images and W10v1607 images creating fine. The VMWare guest customisation script is an old one and works fine for other templates. It is set
      to prompt for IP. vRA should then pass the next IP at provisioning.

       

      I have tried all of the usual tricks above plus:

       

      New VMWare Cust scripts.

      Testing network profiles from other tenants

      Testing the same template in other tenants

      Recreating the Win10 template

      Rebooting IAAS and Appliance

      Set a static IP in the blueprint – this works

      Set a static IP in the cust script and provision a VM direct in VMWare – this works.

       

      It seems that the script is working. The VM is provisioned. My only issue is that it will not pick up an IP via DHCP (direct from vRA – there is no DHCP server).

       

      I have on/off issues with v1709 too however that works in some tenants. V1803 I cannot get too work anywhere.

       

      Help!

       

       

       

       

      Couple of things to add......

       

      We have an old instance that we are migrating from. VRA 6.3.4. I have created blueprints for v1803 and it worked on there.

       

      I have also tested Win10 v1709 on vRA 7.2 - worked on one tenant, failed on another tenant (Same blueprint, only difference is the network profiles)

       

      So as it stands. Win10 (any version) fails on some tenants but v1709 works on one tenant.