2 Replies Latest reply on Jul 12, 2019 10:56 PM by oppej

    Windows 10 & Windows Defender Credential Guard

    KenGrant79 Lurker

      I've had significant battle with the errors that come up when Hyper-V is running in Win10-Pro.  The links to "Manage Windows Defender Credential Guard" in the error message do not lead to the solution, it just wastes everyone's time.  We found this answer through pure luck...

       

      Just run cmd as Admin and type

      bcdedit /set hypervisorlaunchtype off

      and REBOOT

       

      this will fix

      and if you need hypervisor for something like windows emulator tools in visual studio just re-enable when you need by typing

      bcdedit /set hypervisorlaunchtype auto

      and REBOOT

       

      Credential Guard is enabled by hypervisor, and when you disable hypervisorlaunchtype, it disables it. No there is no way to use VMWARE Workstation 14 with this enabled, because they don't support the use of stubs to access hardware through their VMs yet. Anyway, microsoft virtualization sucks so, disable it and keep using VMWARE as it is the fastest one on the market.

       

      Credit goes to Kiwitech62 which was found in another post on this site.

       

      Windows 10 Pro v 10.0.17134 & Player 15.0.2 build 10952284

        • 1. Re: Windows 10 & Windows Defender Credential Guard
          MikeKell Lurker

          WOW, this is so much easier than the process outlined in the Microsoft article that the VMWare error in 14.5 refers to - it has you manually deleting registry keys, etc.

           

          This worked for me - note that I got an error on reboot from Docker which apparently DOES require MSFT virtualization to be enabled - or maybe there's a config setting in Docker to fix this - but for being able to use VMWare this works fine.

           

          Thanks.

          • 2. Re: Windows 10 & Windows Defender Credential Guard
            oppej Lurker

            Many thanks KenGrant79 & Kiwitech62,

            The Credential Guard error happened to me out of the blue on Player 15 and Win 10 Pro. I did nothing to change or implement Credential Guard. I was running Player one day and had the fault the next.

            Your fix worked instantly, and I appreciate your post.

            Cheers