4 Replies Latest reply on Nov 28, 2018 10:14 PM by magicspeller

    VT-x Error

    magicspeller Lurker

      Hi,

       

      I just installed VMware Workstation Player and am trying to set up a Linux VM. When I try to run it, it tells me "This host supports Intel VT-x, but Intel VT-x is disabled," and that I need to enable it to start the VM.

       

      I contacted the manufacturer of my laptop (HP), and they told me I have to have Windows Pro to enable VT-x.

       

      Does that mean I cannot use VMware?

       

      Thanks for your help.

       

      P.S. I'm new and have no idea what "Place" to post this to. Sorry if I made a bad choice.

        • 1. Re: VT-x Error
          a.p. Guru
          User ModeratorsvExpertCommunity Warriors

          Welcome to the Community,

           

          VT-x is a BIOS setting, and should not depend on the installed operating system.

          Did you check whether you can find this setting in the BIOS?

          What type/model of notebook is it, what built-in CPU, and which BIOS version?

           

          André

          • 2. Re: VT-x Error
            magicspeller Lurker

            Thank you, André.

             

            You were right; it does NOT depend on the installed OS. I thought it was very strange when he told me that, and it was.

             

            I didn't find anything in the BIOS specifically referring to VT-x, but I did find a Virtualization Technology setting. And guess what, it was disabled! I enabled it and I am now able to play the virtual machine.

             

            However, I'm now encountering the same issue I had with VirtualBox. I was hopeful that I could avoid it by using VMware, but no such luck. The text on the VM screen is so tiny that I can barely read it. I can make it out with effort, but it's pretty much unusable. Do you have a solution for that?

             

            Thanks again!

            Warren

            • 3. Re: VT-x Error
              a.p. Guru
              Community WarriorsUser ModeratorsvExpert

              Do you have a solution for that?

              This sounds as if you are using a large screen resolution on the host. There's unfortunately no option to stretch the VM's screen, which would be very helpful in such situations. The only option I can think of is that - in case your's using a graphical console window within Linux - there's an option to change the font size in that window.

               

              André

              • 4. Re: VT-x Error
                magicspeller Lurker

                Yes, my screen resolution is 3840 x 2160, which seems pretty amazing for a 15-inch screen, but that's what's recommended by the manufacturer.

                 

                Thanks for your reply. Wish there were a better solution.