1 Reply Latest reply on Nov 10, 2018 6:32 AM by daphnissov

    An error occurred while starting service 'content-library'

    Trivor_OZ Lurker

      Hi everyone,

       

      Hopefully, someone will help me with this issue. I was trying to deploy VCSA 6.7 on my lab, but when the installation reached 67% I got a mistake related to the content-library. After carrying out some researches, I found that my content library is not working at all. You can find the code of the error below:

       

      C:\Program Files\VMware\vCenter Server\bin>service-control --status vmware-content-library

      Failed to get service vmware-content-library status. Err {

          "componentKey": null,

          "detail": [

              {

                  "id": "install.ciscommon.service.notfound",

                  "translatable": "Unable to locate service '%(0)s'",

                  "args": [

                      "vmware-content-library"

                  ],

                  "localized": "Unable to locate service 'vmware-content-library'"

              }

          ],

          "resolution": {

              "id": "install.ciscommon.cmlookup.resolution",

              "translatable": "Please refer to component manager documentation to troubleshoot.",

              "localized": "Please refer to component manager documentation to troubleshoot."

          },

          "problemId": null

      }

      Service-control failed. Error: {

          "componentKey": null,

          "detail": [

              {

                  "id": "install.ciscommon.service.notfound",

                  "translatable": "Unable to locate service '%(0)s'",

                  "args": [

                      "vmware-content-library"

                  ],

                  "localized": "Unable to locate service 'vmware-content-library'"

              }

          ],

          "resolution": {

              "id": "install.ciscommon.cmlookup.resolution",

              "translatable": "Please refer to component manager documentation to troubleshoot.",

              "localized": "Please refer to component manager documentation to troubleshoot."

          },

          "problemId": null

      }

       

      Thank you!