6 Replies Latest reply on Nov 15, 2018 11:58 AM by padi7777

    VMware Tools Does Not Install

    padi7777 Lurker

      I have VMware Workstation Pro 14.  I am attempting to load VMware Tools on Ubuntu.  Every time I do this, I go to the menu tabs at the top, click VM>Install VMware Tools and it begins (I assume.  No prompt says so).  From there, I can see "cancel VMware tools installation" in the menu.  It sits there in that state for hours.  I have tried multiple VMs, all Ubuntu based and the same result occurs.  It can be fixed via command line, but it takes FOREVER.  Any idea why it won't just install from the menu as designed?

      Ultimately, i am trying to get a full screen version of Ubuntu and be able to create a shared folder.  I use the VM to perform incident response duties. 

      Thank you in advance for your attention. 

        • 1. Re: VMware Tools Does Not Install
          a.p. Guru
          Community WarriorsvExpertUser Moderators

          Please take a look at https://kb.vmware.com/s/article/1022525 for how to install VMware Tools in Ubuntu.

           

          André

          • 2. Re: VMware Tools Does Not Install
            padi7777 Lurker

            I following this guide prior to submitting my question.  It does not address my issue. 

            • 3. Re: VMware Tools Does Not Install
              RDPetruska Guru
              vExpertUser Moderators

              Not sure what you are asking.  The Player menu VM-->Install VMware Tools merely mounts the appropriate Tools installation ISO image file to the Guest VM's CD-ROM drive.  Most Windows VMs are set to Auto-Run from CDs, but most Linux distros are NOT.  You must follow the instructions to RUN the Tools setup/installation inside your guest.  Note that if your Windows VM has auto-run disabled, you need to do the same thing (in that case, browse to the CD drive and run setup.exe)!

              • 4. Re: VMware Tools Does Not Install
                padi7777 Lurker

                Roger.  Probably my unfamiliarity contributing to the issue.  When I go to the Virtual Machine settings, and go to the menu option for "CD/DVD (SATA), it has two options under "Connection".  One is "Use Physical Drive>Auto detect"and the other is "Use ISO image file".  I have tried the "Use Physical Drive> auto detect route and it says the CD ROM is locked.  When I try the "use ISO image file" it lists an ISO for the DEFT VM.  If I point it that direction, start the virtual machine, and then install VM tools from the VM tab, it then displays "Cancel VMware Tools installation" as a display option under the VM tab but never completes the install. 

                I believe that the VMware tools should have an ISO attached to the software but I do not see it as an option.  I do get an note at the bottom of the screen that says "make sure that you are logged in to the guest operating system.  Mount the virtual CD drive in the guest, launch a terminal, and use tar to uncompress the installer.  Then, execute vmware-install.pl to install VMware tools.".

                 

                I am confused by the directions (i.e. I do not know how to mount the virtual CD, nor how to acquire said CD. 

                Hope that makes sense. 

                • 5. Re: VMware Tools Does Not Install
                  RDPetruska Guru
                  User ModeratorsvExpert

                  The virtual CD (*.ISO image files) for the VMware Tools installations should already be part of the Workstation/Player installation.  When you pick the menu VM-->Install VMware Tools, Player should unmount any CD already being used (unless it is locked by the guest OS), and mount "Linux.iso" to the virtual CD-ROM drive.  Then click the mouse into the guest, and open a terminal window, and follow the instructions in the link Andre shared originally - this has step-by-step instructions for the commands to install the Tools.  Once complete, you can unmount the ISO (VM-->Cancel tools installation) if it is not automatically done.

                  Note that it's possible the Tools iso files are not included in the Player installer, but will be downloaded when necessary.

                  • 6. Re: VMware Tools Does Not Install
                    padi7777 Lurker

                    Issue is resolved.  Thank you for your patience.