3 Replies Latest reply on Oct 31, 2018 8:34 AM by sjesse

    Can't see info in Dashboard Desktop Usage

    Ray_handels Master
    vExpertCommunity Warriors

      Hey Guys,

       

      I'm fairly new to vRops but we are trying to set it up for our Horizon enviornment.

      I'm using the 6.7 vRops versions. I installed the agent in the Golden Image, installed the broker on a connection server, see all kinds of stuff on my dashboards, so far so good.

       

      When I try to find info of the actual Pool Desktop Sessions the info is clean. I does say I have X amount of sessions, I simply don;t get any info on it.

      When I look into the broker log I get a lot of these messages.

       

      WARNING Could not find connection info for AGENT_CONNECTED event 23509120, maybe it is out of time sync, or possibly a console or direct RDP connection: User %username% has logged in to a new session on machine %MACHINENAME%, let's cache it in case. S-1-<Some_funvky_guid>:<POOL_NAME>

       

      I then also see this error message just below it

      Cannot get timingProfiler status from AD: Object reference not set to an instance of an object.

       

      Anyone of you ever seen an error like this and better yet have a solution for it?

      We are using a centralized timeserver which is set on all servers and because looking at the error it seems as if we are having timing issues which, for as far as I can see, is not the case. Any help would be greatly appreciated.

        • 1. Re: Can't see info in Dashboard Desktop Usage
          sjesse Expert

          For the horizon agent, did you have the vrealize agent component selected in the parent image. From my experience when you install the horizon agent don't check the vrealize agent during the horizon agent install. Then always use the same vrealize agent version as the ops manager. Also they don't specify it in the documentation, but support suggested you should have a separate vrealize collector just for the horizon data. Once I did that for almost all my desktops I get most metrics now, the other issue which I hope was fixed in the 6.7 instance, was there used to be firewall ports that needed to be opened on the appliance, if it wasn't in the documentation I don't think you need it then.

          • 2. Re: Can't see info in Dashboard Desktop Usage
            Ray_handels Master
            vExpertCommunity Warriors

            Hey,

             

            Thanks for your reply. Here are the answers

            For the horizon agent, did you have the vrealize agent component selected in the parent image. From my experience when you install the horizon agent don't check the vrealize agent during the horizon agent install.

            No we did not select it during installation of the agent. We installed in manually afterwards. I thought it would be best to install it with the agent but you say it is best to install  apart form the agent? In this case we did so but still no go.

             

            Then always use the same vrealize agent version as the ops manager.

            For as far as I can see now I use the same versions all around. VMWare Horizon adapter, Agent and broker agent are all 6.6.0.9844216. That should do the trick right?

             

            Also they don't specify it in the documentation, but support suggested you should have a separate vrealize collector just for the horizon data.

            Okay so you mean I should dedicate 1 connection server for just the broker? Or am I misreading this?

             

            I did receive info when I first installed it and I did not need to change the firewall (could pair it correctly). Strange thing is that I do get info, I can see the amount of users logged in. I get info regarding desktop resource trends and stuff. It seems as if it can't process the info that is related to an AD account.Or better yet is does give session info but can't relate it correctly to a user.

             

             

            I also keep on getting this error but no idea which credentials it wants me to add. I can't add any AD ldap account into the broker configuration.

            Cannot get timingProfiler status from AD: The supplied credential is invalid.

            • 3. Re: Can't see info in Dashboard Desktop Usage
              sjesse Expert

              No we did not select it during installation of the agent. We installed in manually afterwards. I thought it would be best to install it with the agent but you say it is best to install  apart form the agent? In this case we did so but still no go.    

               

              • Look the the image below, there is a component that is part of the standard agent install at the bottom of the image., it was present in the 7.4 agent installers and has been since 6.2 at least I think. I would make sure that is not installed. I had many tickets opened in the past that told me to reinstall the agent and then install the vrealize agent afterwords. Something about the one that is included with the agent installer not being up to date.

               

               

              Okay so you mean I should dedicate 1 connection server for just the broker? Or am I misreading this?

               

              • no its a separate vrealize appliance, when you run the setup, its a different option if I remember right. Its a separate node dedicated to collecting data from something, then it ships it back to the master node. Support told me that the view adapter can be very intensive and running on the same node as the vcenter collection can cause issues. If you go the horizon adapter solution in the administration setting you can look at the vcenter adapter and the horizon adapter. If you click advanced you can see the collector its currently on, right now you probably have one, my understanding the horizon adapter should be moved to another one.

               

              These were the two suggestions along with making sure all firewall ports were open to make sure I get all the metrics from vrealize. I also find the broker agent breaks somehow over time, which is why I restart it on a daily basis now.

               

              The timer part I'm not sure but one of the steps to enabling the helpdesk tool in 7.4 and above I think is running this command on every connection server

               

              vdmadmin -I -timingProfiler -enable

               

              even if you haven't used this I'm wondering if the updated horizon adapter and vrealize ops appliance collects that information now. I'm currently on 6.6.1 so I'm a version behind currently, so there may be an issue in the newer ones.