5 Replies Latest reply on Nov 28, 2019 7:10 AM by Ankit_Chouksey

    vSAN Observer Offline Bundle - NO Graphs

    winsolo Novice

      vSAN_version.png

       

      vSAN_Observer_No_graphs.png

      I came across this thread but just didn't do it as it was 4 years old. Has anyone ever encountered this issue? If yes, is there a solution or a workaround?

        • 1. Re: vSAN Observer Offline Bundle - NO Graphs
          TheBobkin Virtuoso
          vExpertVMware Employees

          Hello winsolo,

           

           

          Welcome to Communities.

           

          In general I have seen such issues when there is a firewall or proxy preventing some of the data through - check that port 8010 (default and can be changed) is whitelisted (between hosts and vCenter and between vCenter and where you are accessing the GUI).

           

          Check if same when not using https (-n switch)

          Check if offline bundle generates correctly (-g switch and specify a different save location if don't want to use default)

          VMware Knowledge Base

           

           

          Bob

          • 2. Re: vSAN Observer Offline Bundle - NO Graphs
            winsolo Novice

            Thanks for your response, Bob.

             

            The live mode indeed displays all the graphs. Hence, there's no problem with the firewall or proxy.

            vSAN_Observer_GUI.png

             

             

            Here's what I performed in order to generate the offline bundle,

            vSAN_Observer_offline_bundle.png

             

            vSAN_Observer_offline_bundle_HTML.png

             

            By the way, I followed the same KB article you referred.

            • 3. Re: vSAN Observer Offline Bundle - NO Graphs
              TheBobkin Virtuoso
              vExpertVMware Employees

              Hello winsolo

               

               

              Apologies, your question was in the topic header and I assumed it was web-access that was the issue.

              Are you waiting until the run completes or using ctrl+C to end the session? Try the former and check that the file is of size.

              Try opening the stats.html in another browser (with Admin rights) - I get the same in current Chrome but it works in Firefox.

               

               

              Bob

              1 person found this helpful
              • 4. Re: vSAN Observer Offline Bundle - NO Graphs
                winsolo Novice

                Thanks Bob. It works with Firefox.

                 

                By the way, I waited until it finished writing the HTML bundle and i didn't interrupt the session.

                vSAN_Observer_offline_bundle_HTML_dump.png

                 

                Now the only problem is that, all the graphs have populated except the "VMs" tab. Neither "search" nor "Expand/Collapse all VMs" returns anything. Launching the stats.html in Firefox with Admin rights didn't make a difference either. I have to mention that this is the important part I was hoping I could have a deep insight. But unfortunately this doesn't work. I just don't know if it's by design or a bug with the offline bundle. How about in your system? Are you able to search a VM in this tab?

                vSAN_Observer_offline_bundle_HTML_dump_NO_VMs.png

                • 5. Re: vSAN Observer Offline Bundle - NO Graphs
                  Ankit_Chouksey Lurker

                  Experienced the same, firefox didn't help either.

                   

                  Finally, worked with microsoft EDGE browser, except VM tab data all other graphs are visible.