1 Reply Latest reply on Feb 14, 2019 1:43 AM by JoBiNGeOrG

    Setting environment for vsphere-automation-sdk-python on Red Hat 7.3

    14kosta Lurker

      Hi,

      I tried to setup environment for python3.5 according to https://github.com/vmware/vsphere-automation-sdk-python. When I run

      pip install --upgrade --force-reinstall -r requirements.txt --extra-index-url file:///root/vsphere-automation-sdk-python/lib

      I get the following error in both general python environment and in virtual  defined in /root/vsphere-automation-sdk-python/:

      Collecting twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5))
        Url 'file:///root/vsphere-automation-sdk-python/lib/twisted/' is ignored: it is neither a file nor a directory.
        Could not find a version that satisfies the requirement twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5)) (from versions: )
      No matching distribution found for twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5)

      I downloaded twisted tarball and installed it using "python setup.py install" in both general  and virtual envoironment in lib/python3.5/site_packages/Twisted-18.9.0-py3.5-linux-x86_64.egg.

      But this didn't help because is searched lib/twisted. Can somebody advice please what to do? Thanks in advance

      Collecting twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5))
        Url 'file:///root/vsphere-automation-sdk-python/lib/twisted/' is ignored: it is neither a file nor a directory.
        Could not find a version that satisfies the requirement twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5)) (from versions: )
      No matching distribution found for twisted>=16.0.0 (from vapi-runtime==2.9.0->vapi-client-bindings==1.4.0->-r requirements.txt (line 5)