9 Replies Latest reply on Aug 26, 2019 3:42 AM by davrm004

    VMTOOLS Core Service has stopped working

    lennyk Lurker

      Just upgraded to Fusion 11.0 and I get a message that the VMTOOLS Core Services has stopped working.  THe message details indicate that vmtoolsd.exe has crashed.  Any suggestions on how to resolve?

        • 1. Re: VMTOOLS Core Service has stopped working
          wila Guru
          Community WarriorsUser ModeratorsvExpert

          Hi,

           

          What Windows version are you running?

          --

          Wil

          | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
          | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
          | More info at https://www.vimalin.com
          | Twitter @wilva
          | VMware Wiki at http://www.vi-toolkit.com
          • 2. Re: VMTOOLS Core Service has stopped working
            lennyk Lurker

            I am running Windows 7 Service Pack 1.  The problem started after I upgraded to VMWARE Version 11.  Everything worked fine with VMWARE Version 10.

            • 3. Re: VMTOOLS Core Service has stopped working
              pmh Lurker

              Have you tried reinstalling VMWare tools on the client?

               

              I had a problem recently that was resolved by reinstalling VMWare tools*.

               

              * I had to completely un/re-install VMWare Tools becasue "Repairing" the installation stopped halfway throughleaving me with no mouse, then uninstalling VMWare tools borked the explorer because VMWare tools didn't remove the registry customizations it installs to put Documents, Pictures, etc on the \\VMWare-Host drive that I had to fix by editing the registry, but once I was able to completely remove VMWare Tools, reinstalling it fixed a number of Issues I was seeing among them "VMTOOLS Core Service has stopped working"

              • 4. Re: VMTOOLS Core Service has stopped working
                wila Guru
                User ModeratorsCommunity WarriorsvExpert

                Hi,

                 

                That's what I expected you would say.

                 

                I remember reading that somebody else had a problem with the thinprint drivers in the VMware Tools that are installed on Windows 7 on Fusion 11.

                In that past it was suggested to re-install VMware tools, use advanced settings and not install the thinprint drivers then it should work OK.

                Of course this means that Windows 7 will not work with the shared printer feature.

                 

                Another thing which I would first try is  to shut down the VM.

                Then under settings, remove the virtual printer port and add it back again. Then boot your VM and see if you still have the problem.

                If that's still the case then follow the earlier mentioned steps where you customize the VMware Tools setup.

                 

                Hope this helps,

                --

                Wil

                | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                | More info at https://www.vimalin.com
                | Twitter @wilva
                | VMware Wiki at http://www.vi-toolkit.com
                • 5. Re: VMTOOLS Core Service has stopped working
                  lennyk Lurker

                  Tried all of the above without success. Than uninstalled VMTools and noticed that the VMWare/VMTools directory still existed and containd files.  Deleted this directory and files and reinstalled VMTools.  Everything now works.

                  • 6. Re: VMTOOLS Core Service has stopped working
                    wila Guru
                    User ModeratorsCommunity WarriorsvExpert

                    Hi,

                     

                    Looks like the VMware Tools thinprint story I read about for Windows 7 is a red herring.

                     

                    Glad to hear it now works.

                     

                    A tad bit worried about the "noticed that the VMWare/VMTools directory still existed and containd files".

                    Have you already rebooted the VM and does VMware Tools still work as expected?

                     

                    The reason I'm saying this is because if you uninstall VMware Tools and it leaves files behind then that usually is because those files had been in use and could not be deleted at the time of uninstall. As a result they are scheduled to be deleted on restart.

                    If you didn't reboot, those files are still marked as deleted and a fine working install can stop working.

                    Which is why I normally recommend "uninstall VMware Tools, reboot the guest OS, reinstall VMware Tools".

                     

                    --

                    Wil

                    | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                    | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                    | More info at https://www.vimalin.com
                    | Twitter @wilva
                    | VMware Wiki at http://www.vi-toolkit.com
                    • 7. Re: VMTOOLS Core Service has stopped working
                      lennyk Lurker

                      Yes, I did an uninstall and a reboot before deleting the files.  After I deleted the files I rebooted and than installed VMTools.  I have restarted this Windows virtual image a few times and have not had any problem.  Since I backed up before doing any of this I can try something else or provide additional details if that would help in diagnosing what went wrong.

                      • 8. Re: VMTOOLS Core Service has stopped working
                        wila Guru
                        Community WarriorsUser ModeratorsvExpert

                        Hi,

                         

                        It's OK, I don't work for VMware so can't help in making VMware Fusion better (fwiw, my product is in my sig )

                        Something went wrong with the vmware tools upgrade and that sometimes just happens.

                         

                        The fresh install as you did is the best cure for most vmware tools issues on Windows guests.

                        I was distracted by the "windows 7" part and what I recently read about thinprint.

                         

                        However I do appreciate your feedback as it will help me in helping others that bump into this as I'm sure will happen again.

                        --

                        Wil

                        | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                        | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
                        | More info at https://www.vimalin.com
                        | Twitter @wilva
                        | VMware Wiki at http://www.vi-toolkit.com
                        • 9. Re: VMTOOLS Core Service has stopped working
                          davrm004 Lurker

                          Same deal. Uninstall tools reboot and directory with files still present. Remove directory and reinstall reboot and all good. Windows 7 SP1 with Fusion PV 11.1.1