3 Replies Latest reply on Oct 22, 2018 2:29 AM by ShaneB50

    Printing in VMware Fusion 11

    EMR Enthusiast

      Somehow, I seem to have messed up printing in Windows 10 after upgrading to Fusion 11. Much to my surprise, now there is an "Install Virtual Printer" option in the Virtual Machine menu, which I selected and ran. I've also installed the new Tools, and done so twice. However, when I try to print something, my print jobs get queued to the (thin?) printer device, which, in my case, is identified as a Brother HL-3150DW series Printer, which is my default macOS printer, but the jobs themselves never leave the queue, and the printer never sees them. Have I done something wrong? How can I solve the problem? Should I, perhaps, share my Brother printer on the network using the Mojave Printers & Scanners System Preferences?

        • 1. Re: Printing in VMware Fusion 11
          RickShu Expert
          VMware Employees

          Hi EMR,

           

          I would suggest you try the following steps and see if it helps:

           

          1) Remove VMware Virtual Printer driver in Windows 10 guest via 'Applications and Features' panel.

          2) If you have ever installed the driver for Brother HL-3150DW inside the guest, remove it.

          3) Remove the VMware Tools.

          4) Install the VMWare Tools again.

          5) Click "Install Virtual Printer" option in the Virtual Machine menu and install the virtual printer driver in Windows guest.

          6) Reboot the Windows guest.

           

          Regards,

          -Rick

          • 2. Re: Printing in VMware Fusion 11
            EMR Enthusiast

            No, that didn't work in my case, but I'll share something that I've just done and which works as expected. I shut down my Windows 10 virtual machine and removed the Virtual Printer Port. Then I re-created the Virtual Printer Port, restarted Windows and, voilà, it works.

            • 3. Re: Printing in VMware Fusion 11
              ShaneB50 Lurker

              I had the same experience.

               

              I don't know how much time I wasted on this, but deleting the port did the trick.

               

              Many thanks

               

              Shane