6 Replies Latest reply on Aug 5, 2019 4:25 AM by Ray_handels

    AppStacks not removed from list after deleting in 2.14

    khamilton2 Lurker

      After updating AppVolumes from 2.13 to 2.14 we have an issue where deleted appstacks are being deleted from the vsan datastore, but the appvolumes manager gives a "server error" and the appstack stays in the list.  At 1st it shows up as disabled, after a while it will show as missing.  If you check the datastore it has been successfully deleted.  I tried rescan and deleting them again but they still remain in the list.

       

      Not a show stopper but this list is going to fill up with junk quick.  Anyone else seen this or have an idea where to look to correct?

       

      5 enabled 3 deleted.

      only the 5 enabled still in datastore

        • 1. Re: AppStacks not removed from list after deleting in 2.14
          Ray_handels Master
          Community WarriorsvExpert

          We see the same thing happening. I believe that if you look at release notes 2.14.2 (yes, a newer version , see below) the issue is fixed.

          My guess is that it happens with very large appstacks that timeout during deletion. But just a guess to be honest.

           

          Resolved Issues

          • When multiple domains (two-way trust) are configured with LDAP Base, duplicate user entries are listed.
          • Unable to disable and enable McAfee Anti-Virus Scan when an AppStack is assigned.
          • Under certain circumstances, the message The system needs to be rebooted. Please reboot or contact your system administrator is displayed after an initial user login.
          • PDFs cannot be signed with smart card-based certificate using Adobe Acrobat DC.
          • ODBC lock request timeout errors resulting in server error.
          • Cannot delete AppStacks from App Volumes Manager after all AppStacks and related files have been removed from the datastore.
          • Replicated AppStacks are missing when VMs are deleted.
          • Extended log in time when App Volumes agent is installed on a non-domain joined VM and the message Virtualization Disabled error 500 is displayed.
          • Server error is displayed when configuring machine managers and then navigating to the “Storage” tab.
          • 2. Re: AppStacks not removed from list after deleting in 2.14
            AlexLSx7 Enthusiast

            It is a bug in 2.14 confirmed by VMware when i raised a support call about it a while back. If you dont want to upgrade at the moment you can remove the entries from the SQL table.

             

            Instructions from VMware -

             

            As a workaround for the time being, you can perform the following steps:

            - Stop the App Volumes manager service (svmanager). This won't detach appstacks from users currently logged in, but users trying to login while the service is stopped won't get attachments
            - Take a full backup of your App Volumes Manager SQL database
            - View the dbo.snapvols table as this contains the entries for the appstacks
            - Before deleting anything from the database, please make a query first so you make sure you aren't deleting anything important
            - Here is an example of a query you'd make:
            SELECT * FROM [YourAppVolumesSQL].[dbo].[snapvols] WHERE name = 'AppstackName'

            Replace YourAppVolumesSQL with the name of you App Volumes SQL database, and replace AppstackName with the name of the appstack you are looking to delete

            - After you confirm that this is the correct appstack to remove, run the following query:
            DELETE FROM [YourAppVolumesSQL].[dbo].[snapvols] WHERE name = 'AppstackName'

            Replace YourAppVolumesSQL with the name of you App Volumes SQL database, and replace AppstackName with the name of the appstack you are looking to delete

            - Restart the App Volumes manager service, and log back into the manager UI

            This will resolve the issue.

            • 3. Re: AppStacks not removed from list after deleting in 2.14
              Ray_handels Master
              vExpertCommunity Warriors

              Although I know that this is an option I would not suggest tinkering around in the database to be honest.

              It could well be that this is attached to another table in some way and you end up with inconsistencies within the database, and yes we found out the hard way.

               

              I would wait for 2.14.2 to be honest but eventually it is up to you.

              You could also check for the table missing and if this value is 1 the appstack (or writable) is missing.

              • 4. Re: AppStacks not removed from list after deleting in 2.14
                thgreyprnc Novice

                the problem is still present in 2.14.3.14, meaning that updates to that release, at least, didn't solve the bug.

                now who are you for saying this ? someone who took part in the development of the product ?

                do you have a real example for this specific case ? or is it just trying to instigate fear to people who want to move on rather than the good old option B "do nothing and reject the fault on someone else" ?

                 

                my way of doing always has been

                1) leave the time to people to solve issues.

                2) if, for whatever reason they are unable to do so, I do whatever I can to fix by myself.

                so either vmware fixes this issue, either people have to work out their own solutions.

                 

                now we are one year later and still status quo on this issue. so what remains ? the good old way.

                 

                at some point you have to try by yourself and figure out. that's the reality of how life works man.

                • 5. Re: AppStacks not removed from list after deleting in 2.14
                  thgreyprnc Novice

                  in addition to VMware's workaround, I also found reference to those ghost appstack in other tables :

                   

                  [dbo].[snapvol_operating_systems]

                  [dbo].[snapvol_apps]

                  [dbo].[snapvol_files]

                   

                  My suggestion :

                   

                   

                  1) SELECT * FROM [APPVOLUMES-DBNAME].[dbo].[snapvols] WHERE name = 'AppStack Name'

                  and take note of 'id' field. this is the id of the appstack you are trying to remove

                   

                  2) Deleting all references to the ghost appstack :

                   

                  DELETE FROM [APPVOLUMES-DBNAME].[dbo].[snapvols] WHERE name = 'AppStack Name'

                  DELETE FROM [APPVOLUMES-DBNAME].[dbo].[snapvol_operating_systems] WHERE snapvol_id = 'id number you took note of'

                  DELETE FROM [APPVOLUMES-DBNAME].[dbo].[snapvol_apps] WHERE snapvol_id = 'id number you took note of'

                  DELETE FROM [APPVOLUMES-DBNAME].[dbo].[snapvol_files] WHERE snapvol_id = 'id number you took note of'

                   

                   

                   

                  In your specific case it may be worth taking a look in each [dbo].[snapvol_xxxx] table if the id of the ghost appstack isn't showing up.

                  For this simply right click each table then "Select Top 1000 Rows"

                   

                  Hope this helps

                  • 6. Re: AppStacks not removed from list after deleting in 2.14
                    Ray_handels Master
                    Community WarriorsvExpert

                    the problem is still present in 2.14.3.14, meaning that updates to that release, at least, didn't solve the bug.

                    now who are you for saying this ? someone who took part in the development of the product ?

                    do you have a real example for this specific case ? or is it just trying to instigate fear to people who want to move on rather than the good old option B "do nothing and reject the fault on someone else" ?

                     

                    Just out of curiosity, who are you angry with???

                    If you pointed that reaction towards me I will try and enlighten you on how the forum works .

                     

                    No, I am not a VMware employee, and no I am not a part of development. I am just a user like you who tries to work with a product and tries to help other people on their way with Appvolumes. If you are looking for help on a community I would suggest toning down a bit, otherwise I am not willing to help you anymore.

                    If you want to discuss the development path I'd suggest raising a ticket with VMware so you can get the info you need from them.

                     

                    Last but not least, try and have a look at the icons below someones name. If someone is a VMware employee he or she has the vm icon beneath it's name. That way you know is someone is formally answering your question..

                     

                    Good to see that you did find some extra info though, thumbs up for that.