2 Replies Latest reply on Jan 31, 2019 2:25 PM by hockeyguyin714

    Laundry List of App Volumes issues

    rdonohue Novice

      Hey guys,

       

      We have started rolling out app volumes to some test users, and have gotten back a laundry list of issues. Any help or recommendations are appreciated. We are using writable volumes (UIA+Profile) and a few appstacks on instant clones. We're on relatively current versions of everything (either current or one version behind). We are not using UEM, though I've seen several people saying that we should. I don't entirely understand why we need it, since we don't push a lot of settings out to our users. We have a very small IT team so the fewer tools we have to manage the better, which is why we went without UEM. If UEM is actually required for a stable environment that would definitely make us look at using it again though.

       

      So here's a rundown of the issues we're running into.

       

      1. Users are unable to delete folders using the recycle bin. Bypassing the recycle bin works, but isn't really a good solution. From what I've found this seems to be an issue with the recycle bin when mountpoints are being used. Has anyone found a way around this?

      2. The default web browser reverts back to the default set on the golden image at each login. The default on our golden image is chrome. If a user changes it to firefox it is lost the next time they log in. I've tried adding some includes for registry keys I found on the snapvol.cfg but no luck.

      3. Default printer keeps getting lost. A user changes the default printer and the next time they login it has reverted back to the default on the golden image.

      4. Lots of application settings get lost. Things like view settings, that stick on persistent desktops are lost on each login.

      5. Addons for office are getting disabled at each login. Users have to reenable them every day.

      6. Evernote has loads of issues. The desktop  and start menu shortcuts created when it is captured in an appstack are all screwed up, so users have to launch the executable from program files. For some users it just won't work at all and throws an error about a "missing entry point".

      7. We've had a couple of instances where a users writable vmdk was deleted when their instant clone reset. It seems like there should be some safegaurds to prevent this but I've seen it happen twice and we had to recover the vmdk from a snapshot on our SAN.

      8. We periodically have an issue where writables and appstacks will stop attaching. It typically starts with one or two users having failures, but they're able to logoff and back in and everything attaches. It will then progressively get worse until they stop attaching for everyone. After a few hours of this everything starts working again. No errors in the app volumes console. When this is happening I am able to see that the reason it's failing is because of the known issue with the "Manager1" registry key getting deleted. The strange thing is that we have a gpo in place that support had us set up that is supposed to add the key back if it's missing. When these failures start to happen though it doesn't have any effect, even though all other gpo's seem to be working, and running gpresult shows that it is being applied. This isn't from any type of boot or login storm. We've only got about 20 users testing these desktops out at the moment.

       

      I don't suspect issues in our view or vsphere environments in general, primarily because we've been running horizon view for several years, just using full clones. Until we started using app volumes everything was very stable.

        • 1. Re: Laundry List of App Volumes issues
          Wimp777 Enthusiast

          All of those items that are user setting related are solved with UEM. Most of the default configs from VMware for MS Office/Windows Settings etc.. will cover the majority of it. I can't speak to why the writable drives you are using are not capturing that since I do not use writable drives in my environment. I capture everything my users need with UEM to give them the persistent feel on a nonpersistent instant clone pool.

           

          #1. Not sure. I do not have that problem

           

          #2 -5. UEM would easily solve this

           

          #6. I don't use Evernote, but there are applications out there that will not work like Slack for example due to how it installs and runs within the user profile. Evernote may be one of those applications. Others may be able to answer that one.

           

          #7. I have had that happen to me with writable drives when I have used them. VMware support couldn't explain what or why, but my best guess was the vm received a hard power off so AV didn't receive the proper logoff task to detach the disk and it got deleted with the vm.

           

          #8. I had a similar problem relating to the instant clones not being able to auth to my domain controller during subsequent creations through the day. This was fixed by MS hotfixes and later versions of Horizon/Appvolumes and I haven't had any issues since.

           

          Hope some of this info helps in some way.

          1 person found this helpful
          • 2. Re: Laundry List of App Volumes issues
            hockeyguyin714 Enthusiast
            VMware Employees

            What version of App Volumes are you using?

             

            Is your template for Writable Volumes the same version?

             

            Are you only using Instant Clones?

             

            In regards to deletion if you manually delete the VM it will always delete all VMDKs as vCenter is designed to look at the VMX file and delete anything attached to the VM.  Page 71 shows AVM_PROTECT_VOLUMES  with a value of 1 which is designed to protect the volumes from being deleted when using Instant Clones or any time the pools are set to delete on logoff..  https://docs.vmware.com/en/VMware-App-Volumes/2.15/App-Volumes-Admin-Guide-215.pdf