4 Replies Latest reply on Aug 26, 2018 2:37 PM by aenagy

    vra catalog request submit  --inputfile <catalog item JSON file> results in request with custom machine properties created but not populated. (CloudClient 4.5)

    aenagy Hot Shot

      First I create a JSON file for my catalog request like so:

       

      vra catalog request generate template --groupid <businessGroupName> --id RHEL --reason "" --export d:\myVraRequest.json
      

       

      Then I edit this file to populate the various machine properties with the necessary values just the same as if submitting using the web console. Next I submit the edited JSON file:

       

      vra catalog request submit --groupid <businessGroupName> --inputfile 'd:\myVraRequest_modified.json'
      

       

      The request is successfully submitted and vRA does its thing. The problem is that the first EBS subscription reveals that that the majority of the custom machine properties do not have values populated. The only custom machine values with values populated are those that came from the request template above plus a couple more. There doesn't seem to be a pattern on which are getting values and those that are not.

       

      What is even more strange is if I look at the request in the web console I see the same values for the corresponding input fields as I entered in the JSON file. If I submit the same catalog item and populate the input fields with the same values in the JSON file the request completes successfully, i.e. the custom machine property values are populated correctly. I have triple-checked the spelling and syntax.

       

      Any ideas on what to try next or why this is happening?

       

      Thanks in advance.