2 Replies Latest reply on Jun 12, 2019 4:36 AM by MtheG92

    Trouble uploading app templates

    jmunky78 Lurker

      I'm trying to upload the app volumes templates to our vSAN datastore after a fresh install.  I get the following error.   I'm using AppVolumes version 2.14.

       

      Failed to upload file "template_workstation_80e705721f.vmdk": https://https://<servername removed>/folder/cloudvolumes/apps_templates/template_workstation_80e705721f.vmdk?dcPath=Staff+Student+Datacenter&dsName=vsanDatastore

       

      Unexpected HTTP 400 Bad Request

       

      Anyone seen this before?

        • 1. Re: Trouble uploading app templates
          MtheG92 Lurker

          Hi jmunky78

           

          Did you get a solution for this issue?

           

          Kind regards,

          MtheG92

          • 2. Re: Trouble uploading app templates
            MtheG92 Lurker

            I had the same issue after I tried to update the templates after upgrading App Volumes to 2.16.0.

             

            As in the logs stated the path to the datastore browser over the web URL was corrupted due the second “https” entry at the beginning of the URL so that AVM tried to resolve https://https://vcenter.domain.tld. I tried to change to URL in the App Volumes Manager interface under “Configuration > Machine Managers” without success so I tried to change the configuration in the SQL database.

             

            The following workaround resolved the issue:

             

            Notice: Take a full backup of the App Volumes Manager database

             

            1. Stop the App Volumes Manager service on all instances
            2. Login to the SQL database via SQL Server Management Studio
            3. Open the dbo.machine_managers table in the App Volumes database
            4. Edit the column “host” from the designated vCenter server instance and remove the “https://” entry from the URL string so that only the FQDN of the vCenter is left
            5. Start the first App Volumes Manager service and verify the Template upload mechanism
            6. Start the other App Volumes Manager services

             

            @VMware: please verify if this is an appropriate workaround for this problem and why is it possible to insert an URL as Machine Manager address?

             

            Kind regards,

            MtheG92