4 Replies Latest reply on Jul 13, 2019 11:47 PM by rbryant1212

    Big problem with enahnced keyboard driver on Windows 7 host

    hutorny Lurker

      After installing VMWare's enhanced keyboard driver on Windows 7 the host keyboard is no longer functional.

      A workaround suggested in this post  does not work because when I click on the Properties key I am getting error "Error opening key - Access is denied".

      When I run RegEdit as Administrator I observe same symptoms. Permissions for Properties fails to apply permissions with the same  "Access is denied"

      Device Manager lists two failed HID devices of USB keyboard type corresponding to my keyboard and mouse (the latter has extra keys).

      Device status says "its configuration in the registry is incomplete or damaged"

      Rebooting with last known good configuration has not fixed the issue.

      I suspect that uninstalling the VMWare's enhanced keyboard driver will not solve the broken registry problem.

       

      How do I get my keyboard working?

        • 1. Re: Big problem with enahnced keyboard driver on Windows 7 host
          AnaximanderThales Novice

          I had the same issue just now.  I understand that this is more than 6 months old and this person probably has either resolved the issue or done what ever else was necessary to get around the issue.  Hopefully someone else who has this issue will find this.  Additionally, hopefully VMWare will see this answer and make some changes to the vmkdb for future iterations.

           

          You were lucky in that you could actually log into the machine, I was completely locked out of my host machine and had to boot into a linux live usb.  The 'enhanced keyboard' passes key combinations such as 'ctl-alt-del' to VMs in Workstation.  That's a great feature, unless you happen to be on a domain that requires you to login.  It becomes an issue because your host machine will never receive the 'ctl-alt-del' to allow you to login.  From anything.  No RDP, no enter-pssession, no invoke-command from powershell can be used even if they were all able to be used before.  This is what I'm hoping VMWare can address in future iterations.  Perhaps load the driver only when with VMWare Workstation pro is running, then unloading on shutdown.  Not sure what you'd need to do, but that's a show stopper.  I'm about to run through the install again, and see if you actual warn about it (you might, and I just didn't pay attention).

           

          I used arch, so I'll run through the actual steps I used.  Make necessary adjustments as needed.

           

          root@arch> pacman -S chntpw, ntfs-3g

          -- this installed change nt password, which has an interactive registry hive editor, and ntfs-3g, which had ntfsfix.  You may not need the ntfs-3g, but I was forcing a read-only mount of my drive because ntfs issues.   In addition to the post you linked to (which gives me the hive location), I used this document to determine how to interactively edit:

          Using chntpw in Ubuntu to Hacking the Windows Registry

           

          ONLY DO THIS IF YOU FEEL CONFIDENT IN WORKING ON THIS.  PLEASE USE CAUTION.  REVIEW EVERYTHING.  I HAD NOTHING TO LOSE DOING THIS BECAUSE MY NEXT STEP WAS REBUILDING MY MACHINE.

          root@arch> chntpw -i system

          > 9

          >cd ControlSet001

          ControletSet001>cd Control

          Control> cd Class

          Class> cd {4d36e6b

          -- the cd, apparently, will choose the best location to go to.  If you have an additional key that starts with that first group, you may need to continue adding characters from the specific class listed in the initially linked post.

           

          (...)> ck Class

          -- Check this, you should now see Keyboard

           

          (...)>ed UpperFilters

          -- You should now see a list of items along the lines of:

          [0] kbdclass

          [1]vmkbd

          followed by instructions, and ending with a blank prompt.

           

          > kbdclass

          >--q

          -- the --q will save your string (kbdclass) and then abandon all the other strings.

           

          (...)>q

           

          You choose the quit option from the menu, and make sure to use a lower y to write the data in the hive.  Reboot, and your keyboard shouldn't hijack the special keys (ctrl-alt-del).

          1 person found this helpful
          • 2. Re: Big problem with enahnced keyboard driver on Windows 7 host
            manniongeo Novice

            I just encountered the same, or a similar, problem when upgrading from VMware Workstation 12.something to 15.0.4 on my Windows 7 laptop.

             

            During the installation/upgrade, I elected to install the VMware Enhanced Keyboard Driver. After rebooting, I could not use any keyboard once Windows was booted. Specifically:

            • I tested using the internal laptop keyboard, an external USB keyboard connected via a docking station, and a different external USB keyboard connected directly to the laptop
            • All three of the keyboards worked before Windows booted (e.g. BIOS configuration screen, boot selection screen)
            • None of the keyboards worked once the Windows login screen appeared

            Additionally, once the Windows login screen appeared:

            • The internal laptop touchpad did not work
            • An external USB mouse was able to move the mouse cursor

            Note that I have a group policy set to require pressing CTRL+ALT+DEL to login.

             

            To solve the problem, I did the following:

            • Booted the affected Windows 7 host to the Windows login screen
            • Installed RD Client Remote Desktop app on my Android phone (thanks to the developer!)
            • Connected to affected Windows 7 host using RD Client Android app

            At this point, I was able to use a keyboard connected to the phone to control the Windows 7 host. (Note that I was using Samsung DeX station with my phone, and had an external keyboard/mouse, monitor, local ethernet connected. I'm sure this isn't required, but sure made it easier - thanks Samsung!). Next:

            • Opened Control Panel > Programs > Programs and Features
            • Clicked VMware Workstation to highlight it
            • Clicked Change
            • In the VMware Workstation Pro Setup app, used the Change option to uncheck Enhanced Keyboard Driver
            • Rebooted Windows

            After rebooting, I was able to use my keyboards / touchpad normally again.

             

            Holy heart attack, Batman. I'm glad I was in my office with some extra hardware and my DeX station for testing.

             

            VMware, please fix this debilitating issue - and, ideally, provide more timely support for installation-related category 1 issues for new purchases.This doesn't engender confidence as I embark on my journey with this "upgraded" product.

            1 person found this helpful
            • 3. Re: Big problem with enahnced keyboard driver on Windows 7 host
              manniongeo Novice

              I'm writing with some additional information: I upgraded to 15.1 from my 15.0.4 instance, including re-installing the Enhanced Keyboard Driver, and did not encounter the problem.

               

              I have not tested beyond installing the upgrade, itself. Therefore, I can't state with certainty whether 15.1 lacks the issue, or it just happened to work in my particular environment. Note that the VMware Support analyst who was helping me said that he was unable to reproduce the original issue on his end. So, there's probably something something specific to my environment, anyway.

               

              The takeaway: consider 15.1 as a potential solution if you happen to experience the aforementioned keyboard issue. Good luck.

              • 4. Re: Big problem with enahnced keyboard driver on Windows 7 host
                rbryant1212 Lurker

                Thanks manniongeo,

                 

                Your solution worked for me.