0 Replies Latest reply on Aug 3, 2018 6:29 AM by dhirajgm

    A general system error occurred: internal error

    dhirajgm Lurker

      I am using RegisterVM_Task API to register Virtual Machines on VCenter 6.5 (managed ESXs are also 6.5).

      However, at times, the RegisterVM_Task fails with SystemError and the message is: "A general system error occurred: internal error"

      Following is a log snippet from vpxd log for one such failure:

       

      2018-07-26T08:23:16.173Z error vpxd[7FDDBBA66700] [Originator@6876 sub=VmProv opID=14f2e116-01] Get exception while executing action vpx.vmprov.RegisterDestinationVm: N5Vmomi5Fault11SystemError9ExceptionE(vmodl.fault.SystemError)

      --> [context]zKq7AVECAAAAAAHCfgAddnB4ZAAAJGcrbGlidm1hY29yZS5zbwAA9B4bAD5vGAHI5VR2cHhkAAHd51QBYRzLAR4C0AFza9EBqqTOATDHzgF9zM4BFdBzAYrFcwFB6nMBoLJzAQVQygH7UMoBiNl4ggZeBgFsaWJ2aW0tdHlwZXMuc28AAfzYdAEV0HMBisVzAUHqcwGCPXQAo7QjAIq3IwDbvysDRHQA

       

      2018-07-26T08:23:16.233Z info vpxd[7FDDBBA66700] [Originator@6876 sub=Default opID=14f2e116-01] [VpxLRO] -- ERROR lro-549516 --  -- VmprovWorkflow: vmodl.fault.SystemError:

      --> Result:

      --> (vmodl.fault.SystemError) {

      -->    faultCause = (vmodl.MethodFault) null,

      -->    faultMessage = <unset>,

      -->    reason = "internal error"

      -->    msg = ""

      --> }

      --> Args:

      -->

      2018-07-26T08:23:16.233Z info vpxd[7FDDBBA66700] [Originator@6876 sub=vpxLro opID=14f2e116] [VpxLRO] -- FINISH task-2654

      2018-07-26T08:23:16.233Z info vpxd[7FDDBBA66700] [Originator@6876 sub=Default opID=14f2e116] [VpxLRO] -- ERROR task-2654 -- group-v3 -- vim.Folder.registerVm: vmodl.fault.SystemError:

      --> Result:

      --> (vmodl.fault.SystemError) {

      -->    faultCause = (vmodl.MethodFault) null,

      -->    faultMessage = <unset>,

      -->    reason = "internal error"

      -->    msg = ""

      --> }

      --> Args:

      -->

      --> Arg path:

      --> "[vsanDatastore] vsan-scale-vm9/vsan-scale-vm9.vmx"

      --> Arg name:

      --> "vsan-scale-vm9"

      --> Arg asTemplate:

      --> false

      --> Arg pool:

      --> 'vim.ResourcePool:resgroup-23'

      --> Arg host:

      -->

       

      Please let me know if anybody else has seen this behavior and if there was any resolution.

      Also let me know if looking at some other logs might help.