4 Replies Latest reply on Aug 9, 2018 12:29 AM by Marino_S

    Problems with getting the Service Discovery Management Pack up and running

    Marino_S Lurker

      Hello

      For a number of days I've been trying to get this pack to work.   I followed the user guide, and some deployment instructions I've found on the internet.   As I understand it I need to configure a rarely used autohentication method (VGauth) to make it work.   I've configured the default windows user and password (on the service discover adapter, (together with the vcenter credentials), Linux is not important for the moment.       When I check the results in vRealize I see in the "virtual machine relationships" dashboard, I see as status for my test VM the following:

      Service discover: succes,  service discovery method: common username, etc..   (these are the most important for debugging).  But there are no services in the view: "list of services running in the selected VM".    When I check the VM I find that in the folder c:\temp a directory called  "VMware-SDMP-Scripts-3597-s_vrealize".   In that folder there are a number of files (*.bat,stderr,stdout,).  

      The file script_-6951322665996061208_0.stdout, contains a list of the services.

      When I take a look in vCenter I see underneath the events of the VM, the following  :

      Guest operation Start Program performed

      Guest operation List Processes performed

      Guest operation Initiate File Transfer From Guest performed

      Guest operation Initiate File Tranfer From Guest performed

      Guest operation Start Program performed

      ...

      So one could think that it actually works, but I dont get any results in vRealise.   My questions where do I look on my vRealize appliance to see what is going wrong?   (I know there is something in "administration\support\logs\collector\adapters\ServiceDiscoveryAdapter" but it doesn't tell me what I need to know

      Where are the result files of a VM stored on the vrops appliance? I'd like to verify if something actually does get copied or not..   

      I also configued the guest user mapping, but doesn't return anything, and the release of the SDMP 2.1 tell me that guest user mapping doesnt work with vrops 6.7..

      Any help will be much  appreciated.   (Too be honest, the SDMP has very poor documentation)

       

      Kind regards

      Marino

        • 1. Re: Problems with getting the Service Discovery Management Pack up and running
          RickVerstegen Hot Shot

          Did you configured the Guest User mapping manually or automatically?

          • 2. Re: Problems with getting the Service Discovery Management Pack up and running
            Marino_S Lurker

            Hi, Rick,

            Thank you for your reaction.  I tried everything, define common user name, do the guest user mapping from the webclient, use the csv file from within vRealize..  Only to end up with different errors.

            When I read the release notes (I know,  I should have started with reading these); I saw that it wont work with vRealize 6.7.    So I deployed a new vRealize 6.61 instance, and installed the management pack again. 

            What I found was this:  if I defined the common user name on the service discovery adapter, and I dont do the guest user mapping,  I get a "Success" result but nothing gets reported. (didnt try this one with uac disabled).    The scripts and the results were present on the target VM

            If I don't define the common user name, but use the guest user mapping without disabling uac I get "Success" as result but services still don't get detected

            If I use the guest user mapping and disable UAC  (or use the local security policy, and disable uac for the local admin) it detects services.

            To be honest, I am disappointed that in this day and age , I am forced to disable uac.... (this limits the usability of the product in our environment).  It's a security risc

            But it's a test setup to see if SDMP could help us.   So I get to the point that it finds services:  IIS and MSSQL.    But it doesnt detect that the IIS server is using the SQL server for its web application?  I thought SDMP would see these relations automatically, not?

             

            Again, there is very little documentation about SDMP available: tried the vmware doc site, tried Mastering Vrops book, tried google, blogs and fora,  with little to no result...  Is there something I am missing?   Is the common user name required to map the relations between VMs?

             

            Thank you

            Kind regards

            Marino

            • 3. Re: Problems with getting the Service Discovery Management Pack up and running
              RickVerstegen Hot Shot

              I also tried to setup the management pack and did not get it work with 6.7. I haven't tried 6.6.1 yet. I also noticed that there is not a lot documentation available for this. You mentioned that in the release notes it will not work with 6.7. But I don't know why it is mentioned as supported then on the download link of the management pack for 6.7. See VMware Solution Exchange.

               

              Did you enabled Dynamic Application Group? By enabling Dynamic Application Group the management pack can automatically create dynamic applications based on the network communication between the services. To see the Application Groups, go to Environment. In the left menu under Groups and Applications select Applications.The group gets created as “Application” with a UUID. Do you see any Application Groups created?

               

              The virtual machine relationship dashboard gives you a list with VM’s including Service Discovery details. By selecting a VM, the dashboard shows you a list of discovered services on this VM, relationships and a topology overview to display relationships of the VM with other VM’s based on discovered service relationships.

               

              Maybe you can contact GSS to assist you with properly setup the management pack for vROps? If you do that, I'm curious about the solution they will provide.

              • 4. Re: Problems with getting the Service Discovery Management Pack up and running
                Marino_S Lurker

                Hi Rick,

                 

                It looks like you're in the same place as I am.    I am very close to the point where I'll write that this Service Discovery Management Pack is a piece of sh*t.

                Yes, I enabled the Dynamic Application Group, but I don't see much dynamic activity.

                No application groups got created.    The thing doesnt realize that IIS has something to do with Web..  So I've created manually an application group but it doesnt map anything to the discovered services.

                Maybe if we turn all security, and grant everything and everyone full local and domain rights the thing will work....    (no, we're not going to do that )

                 

                If you look at the release notes for SDPM version 2.1 (https://marketplace-download.vmware.com/resources/9e418d7555ee11e78024005056a107c6/doc/ec17c645987e4254a2e184a8a045bdc1/…

                           you'll find this : Known Issues

                               • Services Discovery is not working on vRealize Operations Manager 6.7 when guest mapping is used. When you log in to the vCenter Server using the Java version 1.8u141 or later, an                   error occurs. Current vRealize Operations Manager that use this Java version have this issue and as a result, service discovery is not able to support guest mapping on vRealize                    Operations Manager 6.7.

                 

                Workaround: None

                 

                I tried downgrading the java version in 6.7 but that didn't help.  If you use 6.61 it seems to work a bit better, but it is still not working as the marketing material would have you believe.  I suppose I'll try to contact VMware support.

                I'll post the results (if any) over here.