1 Reply Latest reply on Jul 25, 2018 5:38 AM by asdfchiun

    Vmotion and Autodeploy 6.7

    asdfchiun Lurker

      This is for any other vmware shop that may have an issue with 6.7. We are a cisco UCS and netapp shop, all fiber-channel connected. I upgrade with the migration wizard our vcenter appliance from 6.5 to 6.7 with out error and all seemed well. Once I started updating my esxi from 6.5 to 6.7 (we use the cisco image ) I found that i could not vmotion more than one vm at a time. I opened a ticket with vmware and provide copious amounts of logs but as yet they have not provided a solution. But I've satisfied my self that its an issue with a host deployed with autodeploy image as the root cause. My test all last night were to try various version of our auto deploy image (there are presently 2 in the vmware online repo, and only the 1 cisco image) I went so far as to build a custom repo with the latest vmware image and the cisco drivers injected. No mater the combination i found that if the target was to a host that was provisioned with our autodeploy image it failed to vmotion more than one vm. I stumbled upon the work around when I applied drs recommendations and several vm's actually migrated, but soon realized it was my san boot host that I run the vcenter appliance and dhcp server for autodeploy from. Making note of this I took an autodeploy host and built it with the cisco GA image as a boot from san, with no patches this worked as expected and all vmotion worked fine. Questioning if my configs were a possible problem, i redeployed the same server as an autdeploy host, made a host profile from its settings, tested that vmotion was still failing (it was). I then re-imaged the system as a san boot host and applied the host profile. with the san boot esxi host vmotion worked as expected. I am now eating a fair bit of crow here at my current job since I've always been a big proponent of autodeploy, but I'm now replacing it with traditional san boot host.

       

      Quick and dirty there is some bug as I can see it with autodeployed host and vmotion working with vds switching for esxi 6.7.

       

       

      I'm really not one to use a forum often, but I'm generally curious how may people actually use auto-deploy as a feature?

      What version did you roll it out in?