4 Replies Latest reply on Jul 14, 2018 6:26 AM by VMgwbaby

    500 Internal Server Error while I tried to run POST API against NSX controllers

    VMgwbaby Novice

      I have "500 internal server error" when I do POST command for controllers. Would you explain why it happened?

       

       

      1. I retrieved the controller ID (controller-1) by using below command meaning that my authorization is correct (nsx-mgr can communicate with postman)

      Retrieve available controller IDs with GET /api/2.0/vdn/controller

       

      2. I am able to run GET to get the status of controller, for example

       

      GET /api/2.0/vdn/controller/controller-1/syslog

       

      The return value said that "Syslog serer is not configured for controller.."

       

      3. Then I tried to run POST commands with below syntax, I got 500 error.

       

      <controllerSyslogServer>

      <syslogServer>1.2.3.4</syslogServer>

      <port>12345</port>

      <protocol>tcp</protocol>

      <level></level>

      </controllerSyslogServer>

       

       

      Does anyone know why I am getting this? I test it from HOL and my homelab, the results were same. By the way, return value said "400 Bad Request"

       

      FYI I added "Content-type with application/xml"