4 Replies Latest reply on Jul 16, 2018 2:12 AM by ncekic

    vRO Powershell Host Plugin Error

    ncekic Novice

      Hello Community,

       

      i had a working powerhsell host connection from my vRO 7.3.1 to the W2K12R2 server where i have configured WinRM. Now i wanted to do some tests and saw in the Inventory of the vRO that the Powershell Host SnapIns (Microsoft.Powershell.Core) has a problem: Error in plugin.

      • ch.dunes.util.DunesServerException: Unable to execute 'fetchRelation' for type : PowerShellSnapIn : com.vmware.o11n.plugin.powershell.model.PowerShellException: Unable to resolve Cmdlet definitions. connect timed out

       

      The funny thing is that it was working before - so that i can say the WinRM Config should be ok?! Also there were no changes on the vRO. Any idea how i should start to troubleshoot?

       

      My first steps:

      1. curl from vro (vm appliance) to powershell host (w2k12r2) on port 5986 - result: accepted

      2. Checking the Firewall on Powershell Host - result: WinRM HTTPS/HTTP ruel is created

      3. Checking winrm configs and certificate - result: looks good

      4. On vRO: Removed the Powershell Host and executed the workflow "add a powershell host" - result: succesfully added

      5. In vRO: checked the Powershell host plugin in the inventory - result: still the same issue Error in plugin"

      6. in vRO: Executed update a powershell host workflow - result: succesfully but still same issue error in plugin

      7. Some minutes later tried again to execute the wf "update a powershell host": result: failed,

      [2018-07-11 08:50:38.316] [E] Workflow execution stack:

      ***

      item: 'Update a PowerShell host/item12', state: 'failed', business state: 'null', exception: 'connect timed out (Dynamic Script Module name : updatePowerShellHost#23)'

      workflow: 'Update a PowerShell host' (EF8180808080808080808080808080804980808001270557368849c62c352aa82)

      ....

       

      It looks really weired sometimes adding or updating the powershell host works and sometimes it´s failing with the error postet in point 7.

      Firewall cannot be the problem, also the host firewall on the powershell host is not activated. and the winrm has been configured like described in the vmware or technet guides.

       

      Any idea how to fix that?

        • 1. Re: vRO Powershell Host Plugin Error
          WinStime Novice

          Did you try restarting vRO server ? (not only service)

           

          Do you update default realm to match AD authentification of your 2012 winRM Host ?

           

          Do you configure correctly WinRM on PShost ? (to accept connection from your vro / domaincomputer...)

           

          Try to remove and add the latest version of the plugin also in vRO controlcenter

           

          and which way you connect ? PSC authentification or Domain ?

          • 2. Re: vRO Powershell Host Plugin Error
            ncekic Novice

            Hey WinsTime.

             

            a restart of the appliance didn´t acceft this issue. The Default realm has been updated as documented in the WinRM Papers of VMware.The WinRM Host has been configured correctly with all Special configs needed like accept Connection from vor etc. The latest powershell plugin is v1.0.13.7028871 and the vRO Version is 7.3.1. I connect via Domain.

             

            I want also to mention that adding a powershell host works, also validating the powershell host and invoking scripts. That means that the Connection to the powershell host can be established without Problems - only in the vRO inventory the Snapins cannot be Show. I only see "Error in Plugin" with the following error message:

            • 3. Re: vRO Powershell Host Plugin Error
              ncekic Novice

              ch.dunes.util.DunesServerException: Unable to execute fetchRelation for type: PowershellSnapInRoot:com.vmware.011n.plugin.powersehll.model.PowershellException: Connection timeout

              • 4. Re: vRO Powershell Host Plugin Error
                ncekic Novice

                The really strange Thing is that i only sporadically can add/update a powershell host or validateing it or invoking scripts. Means sometimes the Workflows are executed succesfully and sometimes it Fails with Connection timeout. From the root console a Connection can be established to the powershell host without Problems - means Firewall Problem should be excluded.