9 Replies Latest reply on Feb 4, 2019 6:15 AM by Ray_handels

    Creating an AppCapture VM

    hermanc01 Novice

      I'm getting a weird behavior with Windows 10 1803 64-bit and AppVolumes 2.14.0 when trying to capture applications.

       

      I can capture applications as expected except when the VM needs rebooted to complete the installation of the desired applications.  Example, Office 2013 updates. 

       

      If I create a brand new AppStack and install an application, I can reboot the session as many times as needed without any issues.

       

      As soon as I "update" the provisioned AppStack, install either an updated version of the application or Office updates and need to reboot to complete the installation, upon re-logging into the provisioning VM, I get the Windows error "sihost.exe - Unknown Hard Error".  Once that error is thrown the entire user profile is corrupt and my AppStack session is ruined.

       

      I've tried this on Windows 10 1709 64-bit and can reproduce it on there as well.  I can replicate this with multiple applications (not just Microsoft products).

       

      How are other people building their AppCapture VMs? Do you build them almost identical to your golden template?  Or are you using a plain vanilla VM with no changes made?

       

      I have a case open with VMware about this issue but so haven't made any progress.

        • 1. Re: Creating an AppCapture VM
          VDINinja311 Enthusiast

          For every Master Image (Golden) we build a VM template for which that Master was built from. We also build our Capture and Build (AppCapture) VM from that same template for consistency. Otherwise the AppCapture never gets Windows Updates or even Office Updates, only real changes are things listed below.

           

          Things we install on our AppCapture VM:

          Office (To match the Master, as we build it into the Master rather than use an AppStack for Office)

          AppVolumes Agent

          UEM Application Profiler

           

           

          We are currently running AppVolumes 2.13.2 on Windows 10 1703 64bit, and previously to those we ran 2.12, 2.11, and 2.10 on Windows 10 1607 64bit. We haven't ran into those issues you are experiencing. We are currently testing AppVolumes 2.14.0 and are running into unrelated issues with AppStacks being surprised removes randomly from desktops. We have a support case in.

           

          We have not however updated our AppCapture VM to the 2.14.0 agent yet.

          • 2. Re: Creating an AppCapture VM
            dylomc Novice

            I was also running into this with App Volumes (2.14.0.184) and 1803 as well, but I think it is due to the something the Optimization Tool is disabling. I reverted to a snapshot prior to optimization and it seems ok now.

            • 3. Re: Creating an AppCapture VM
              Barker2015 Novice

              I had the same issue with Windows 10 1709....and same results as you, so you aren't alone.  After reverting the optimizations done by the VMware OS Tool back to Windows original it resolved it.

               

              I need to go through all the optimizations in that tool, as it seems it's a bit heavy handed and often appears to disable things that Windows actually needs to operate normally.  This isn't the first time I've had strange issues after running that tool.

              • 4. Re: Creating an AppCapture VM
                ZellOr Enthusiast

                Hello everybody,

                 

                I think I ran into the same problem. I got every time the "sihost.exe - Unknown Hard Error" error message if an installer installs a Visual C++ Redistributable Package as a component.

                For me the solution was to add the following exclude to the snapvol.cfg.

                 

                exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileService

                1 person found this helpful
                • 5. Re: Creating an AppCapture VM
                  hermanc01 Novice

                  This fix is working for me too. 

                   

                  Thank you for finding this.  Two support tickets and hours of WebEx sessions with support got me nowhere.

                   

                  I ended up giving up on working with support and started re-creating the AppStack every time I was getting this issue. 

                  • 6. Re: Creating an AppCapture VM
                    sjesse Master
                    vExpert

                    Does anyone know if this is fixed in a newer version?

                    • 7. Re: Creating an AppCapture VM
                      Ray_handels Master
                      Community WarriorsvExpert

                      As far as I can tell it is not an issue with Appvolumes but more of an issue with OSOT (which causes more havoc if you look at some of the fora). There seem to be a few settings that cause things to be screwed up like start menu's and stuff.

                      I would suggest trying to be a little bit more conservative with the OSOT tool instead of lurking around in the snapvol .

                       

                      That being said. We just take a clone of our golden image and remove View Agents from it, that's our packaging machine then.

                      • 8. Re: Creating an AppCapture VM
                        sjesse Master
                        vExpert

                        We do that too, and never had an issue out side of app volumes specific bugs for windows 7. Windows 10 has been a mess for me, I'm thinking of just making my own template from the start, the login vsi one was causing problems along with the normal one. I wonder what testing is done for these, technically its still  a fling, but all VMware documentation says use it now.

                        • 9. Re: Creating an AppCapture VM
                          Ray_handels Master
                          Community WarriorsvExpert

                          It's not just VMWare documentation stating that to be honest. The idea behind the tool is still pretty awesome but it seems as if you would need to rebuild the damn thing because Microsoft thought it would be a nice idea to rebuild the entire kernel, start menu, whatever craps suits their needs. Windows 7 was just a stable Windows version. Windows 10 seems to be the crappiest system ever build by Windows (and YES I'm looking at you Windows ME... ).

                           

                          That being said. Trying to create appstacks is easy to learn hard to master. There's more to it than just hitting next, next finish. Try to clean out your GI as much as possible with regards to tasks, services and processes, anything that happens during packaging can possibly get into the apstack.