1 Reply Latest reply on Jun 25, 2018 12:48 AM by AlexHautequest

    Intel NIC not detected after reboot

    AlexHautequest Novice

      Hello all.

       

      One of my lab devices decided to dislike the Intel dual port NIC out of the blue after it was restarted. The card is listed on the HCG, supported via both e1000e and ne1000 VM modules, and is listed under lspci. And yet, ESXi 6.7 tells me no supported NIC cards are available. The NIC works on another system, so it is not a hardware fault. Both ports are connected and green, with their matching switch ports up.

       

      VMWare ESXi 6.7.0 (VMKernel Release Build 8169922)

      My NIC is exactly this - VMware Compatibility Guide - I/O Device Search

       

      [root@vhost01:~] lspci -v | grep -A1 -i ethernet

      0000:01:00.0 Ethernet controller Network controller: Intel Corporation 82571EB Gigabit Ethernet Controller [vmnic0]

      Class 0200: 8086:105e

      --

      0000:01:00.1 Ethernet controller Network controller: Intel Corporation 82571EB Gigabit Ethernet Controller [vmnic1]

      Class 0200: 8086:105e

      [root@vhost01:~] vmkload_mod e1000e

      Module e1000e loaded successfully

      [root@vhost01:~] dmesg | grep -i e1000

      2018-06-25T07:00:30:841Z cpu1:2100918)Loading module e1000e ...

      2018-06-25T07:00:30:841Z cpu1:2100918)Elf: 2101: module e1000e has license GPL

      2018-06-25T07:00:30:843Z cpu1:2100918)module heap vmklnx_e1000e: Initial heap size = 102400, max heap size = 9666560

      2018-06-25T07:00:30:843Z cpu1:2100918)module mempool vmklnx_e1000e_skb: creation succeeded. initial size = 524288, max size = 23068672

      2018-06-25T07:00:30:843Z cpu1:2100918)module heap vmklnx_e1000e: using memType 0

      2018-06-25T07:00:30:843Z cpu1:2100918)module heap vmklnx_e1000e: creation succeeded. id = 0x4304aa6a0000

      2018-06-25T07:00:30:843Z cpu1:2100918)PCI: driver e1000e is looking for devices

      2018-06-25T07:00:30:843Z cpu1:2100918)PCIL driver e1000e claimed 0 device

      2018-06-25T07:00:30:843Z cpu1:2100918)Mod: 4962: Initialization of e1000e succeeded with module ID 4193.

      2018-06-25T07:00:30:843Z cpu1:2100918)e1000e loaded successfully

      [root@vhost01:~] esxcfg-nics -l

      Name PCI Driver Link Speed Duplex MAC Address MTU Description

      [root@vhost01:~] _

       

      Any hints? Thanks!