1 Reply Latest reply on May 14, 2018 11:20 AM by paulc1

    Installing vRA with vSLCM

    paulc1 Novice

      Hi, I'm trying to install just vRA 7.4.0 using the Suite Lifecycle Manager and it is erroring out right at the end when it gets to Creating AD on vIDM.

      I have a preconfigured vIDM server using an external MS SQL server. I'm able to login to vSLCM from vIDM just fine. Not sure why it needs to create anything, it has already been configured.

      The other problem is I'm using AD with IWA and the error is complaining about LDAP being the wrong directory type. I didn't configure LDAP anywhere so I don't know where it is even getting this from. It also says the host is the vRA server, but it should be using the separate vIDM server. Any help would be appreciated, I've started the whole thing over a couple times and it keeps stopping there.

      Here is the error:

      com.vmware.vrealize.lcm.common.exception.LcmException: Failed to create AD over LDAP, on vIDMServer{host=vra_server.fakedomain.corp.com, tenant=vsphere.local}: {"errors":[{"code":"directory.config.invalidType","message":"Invalid directory type.","parameters":{}}]}

      com.vmware.vrealize.lcm.common.exception.LcmException: Failed to create AD over LDAP, on vIDMServer{host=tstltchvra01.mc.uky.edu, tenant=vsphere.local}: {"errors":[{"code":"directory.config.invalidType","message":"Invalid directory type.","parameters":{}}]}
        • 1. Re:Installing vRA with vSLCM
          paulc1 Novice

          Well, I just logged into vRA as the configuration admin and added my domain with LDAP and then hit retry in vSLCM and it completed finally. The app is in my vIDM. 

          Still confused where it got the LDAP authentication instead of LDAP w/IWA though.