5 Replies Latest reply on Sep 19, 2020 7:10 AM by AndrewKV

    VMWare Esxi 6 Unable to Find Controller Adaptec 5805

    bayubk Novice

      Hi All,

       

      I have a PC installed VMWare 6.0.0 build 2494585

      Adaptec ASR-5805 512 MB with latest firmware No BBU.

       

      Below are VIB that I have installed to the machine.

       

      esxcli software vib list | grep aacraid

      scsi-aacraid                   6.0.6.2.1.41024-1OEM.600.0.0.2494585  Adaptec_Inc  VMwareCertified     2018-05-01

       

      esxcli software vib list | grep arcconf

      arcconf                        1.00-1                                Adaptec      unknown             2018-04-30

       

      I run ARCCONF on a guest OS Windows 2008 R2 x64.

      Installed the ARCCONF from the software download for 5805.

       

      C:\Program Files (x86)\Adaptec\RemoteArcconf>arcconf setvmcredential 192.168.6.55 5989 root password

       

      Command completed successfully.

       

      C:\Program Files (x86)\Adaptec\RemoteArcconf>arcconf getstatus 1

      Controllers found: 0

      Invalid controller number.

       

      C:\Program Files (x86)\Adaptec\RemoteArcconf>

       

      Why it couldn't find the controller? Is the ARCCONF not compatible on Esxi 6?

      Do I have to install CLI and CIM from Adaptec 6805 msm_vmware_v1_08_21375 ?

       

      Thank you.

      -Bayu

        • 1. Re: VMWare Esxi 6 Unable to Find Controller Adaptec 5805
          daphnissov Guru
          Community WarriorsvExpert

          Because what the guest OS sees is an abstracted view of the host's hardware. It's virtualized, not physical, so the guest doesn't have access to the controller, only ESXi does. You will either have to pass that controller through to the VM (which may not be possible) or find and run that CLI tool from within an ESXi shell session.

          • 2. Re: VMWare Esxi 6 Unable to Find Controller Adaptec 5805
            bayubk Novice

            Hi daphnissov,

             

            Thanks.

            Actually I just followed the instruction inside the software download.

            I will find the CLI to run using esxcli.

             

            Thank you.

            • 3. Re: VMWare Esxi 6 Unable to Find Controller Adaptec 5805
              bayubk Novice

              Now I got the cmdline working on Guest OS.

               

              Since Esxi 6 uses the same driver for Adaptec 5, 6,7,and 8 series (aacraid-6.0.6.2.1.41024-2915492.zip), so that I treated my 5805 as 6805.

              I donwnload software from 6805 download section msm_vmware_v1_08_21375.zip

              Extract the zip file.

              Install vmware-esx-provider-arcconf.vib and vmware-esx-provider-arc-cim-provider.vib inside cim folder.

              Removal and installation guide is here

              https://storage.microsemi.com/en-us/support/infocenter/release-2015-1/index.jsp?topic=/adaptec_cli.xml/Topics/Installing…

               

              Restart.

              Then copy the cmdline arcconf on to Guest OS.

               

              Now, it found the controller.

              2 people found this helpful
              • 4. Re: VMWare Esxi 6 Unable to Find Controller Adaptec 5805
                bwchuah Lurker

                Hi All,

                 

                i have 6.5.0 Update 1 (Build 5969303) installed.

                adaptec with latest firmware.

                 

                esxcli software vib list | grep aacraid

                scsi-aacraid                   1.1.5.1-9vmw.650.0.0.4564106          VMW     VMwareCertified   2019-09-20

                 

                esxcli software vib list | grep arcconf

                arcconf                    2.05-22932                        Adaptec  PartnerSupported  2019-09-20

                 

                when i ran this C:\Program Files (x86)\Adaptec\RemoteArcconf>arcconf getstatus 1

                Got CIM Exception while trying to connect to the host(192.168.1.2): "Cannot connect to 192.168.1.2:5989. Connection failed."

                Please check whether ESX server address/port/credentials are properly set or not.

                 

                I have unload the firewall

                esxcli network firewall get

                   Default Action: PASS

                   Enabled: false

                   Loaded: false

                 

                Also firewall at the guest Window 2008 r2 also disabled.

                 

                Can you guys help me ?bayubk

                 

                Thank

                Chuah

                • 5. Re: VMWare Esxi 6 Unable to Find Controller Adaptec 5805
                  AndrewKV Novice

                  bayubk, thank you so so much for sharing this input!

                   

                  I just was able to make Adaptec 5805 discoverable and accessible from Win7 x64 guest OS on ESXi 6.5 (Update 3).

                   

                  For those who are also looking for making Adaptec 5xxx working on ESXi 6.x I am posting below some updates to the original post, as not everything worked well in my case from the beginning.

                   

                  1. After executing “esxcli software vib install --no-sig-check -v /tmp/vmware-esx-provider-arc-cim-provider.vib” and rebooting the ESXi host - it displayed error for a second like: “failed to verify signatures of the following vib(s) [arc-cim-provider]” on start.

                  2. Also “esxcli software vib signature verify | grep arc-cim-provider” showed status something like “...error verifying signature. Could not find a trusted signer

                    To my understanding that was because “vmware-esx-provider-arc-cim-provider.vib” has <acceptance-level>accepted</acceptance-level>  (set in descriptor.xml inside vib) what means this VIB has VMwareAccepted level and also seems ESXi host was not able to verify its signature, even though host’s acceptance level was set to CommunitySupported.

                  3. As I was not able to find any solution on how to force ESXi 6.5 host to resolve issue related to VIB’s signature verification issue – I decided to convert “arc-cim-provider.vib” into CommunitySupported VIB. ;-)

                    For this to the great help came this post http://www.yellow-bricks.com/2011/11/29/how-to-create-your-own-vib-files/ [How to create your own .vib files].

                    So I did the following adjustments to the original arc-cim-provider VIB:
                    3.1) I cleared content of the the “sig.pkcs7” file
                    3.2) I changed acceptance level from <acceptance-level>accepted</acceptance-level> into <acceptance-level>community</acceptance-level>
                    And packed it back into VIB after that.

                    In case you are going to repeat these steps – make sure you execute packaging exactly in the following order “ar -r arc-cim-provider-comm.vib descriptor.xml sig.pkcs7 arc-cim-provide” as otherwise during installation ESXi will give you message like "This VIB has an unsupported format.  The first member found was arc-cim-provide, but descriptor.xml was expected".

                  4. After that I installed the new VIB on ESXi, rebooted it and vu a lia – everything worked out fine! Storage Manager installed on the guest OS was able to identify, connect and manager Adaptec 5805 RAID controller!

                   

                   

                  Some screenshots below for ref:

                  1) list of installed versions on ESXi 6.5 for Adaptec:

                  screen1.jpg

                   

                  2) screenshot of the Storage Manager running on the guestOS (Win7 x64) on the ESXi 6.5U3

                  screen2.jpg