1 2 Previous Next 17 Replies Latest reply on Jun 16, 2019 9:02 PM by chendemo

    Error upgrade to VCSA 6.7

    vm7user Enthusiast

      Hello,

       

      I try upgrade VCSA 6.5 to 6.7, but on final stage get error:

       

      Error setting network. Details : 23/04/2018 14:08:46 [ERROR] Cannot run /sbin/ifup eth0 command. Unknown error. Return code : 256 output: Make sure the interface is down or not assigned any IP eth0 is DOWN or not assigned an IP. Bringnig eth0 up... Can not find the manual filename, let us search for the auto filename Performing duplicate address check for IPv4 address a.b.c.d  [1;31mError: IP already exists in the network [0;39m Unable to set the network parameters

      Failed to set network

       

      -------------------

       

       

      a.b.c.d is IP of old VCSA (6.5)

        • 1. Re: Error upgrade to VCSA 6.7
          IT_pilot Expert
          vExpert

          How does the vCenter deployed by you get a temporary IP address? Keep in mind that if you are not using DHCP then manually you need to assign a free address (after the setup is complete, this temporary address will be freed and the new vCenter will accept the address of the previous one).

          • 2. Re: Error upgrade to VCSA 6.7
            vm7user Enthusiast

            >>How does the vCenter deployed by you get a temporary IP address?

             

            static IP

            • 3. Re: Error upgrade to VCSA 6.7
              IT_pilot Expert
              vExpert

              Try setting a different address

              • 4. Re: Error upgrade to VCSA 6.7
                vm7user Enthusiast

                Why i should use different address? VCSA 6.7 successfully obtains a temporary address.

                • 5. Re: Error upgrade to VCSA 6.7
                  ashwin_prakash Expert
                  Skyline Community 2/2VMware EmployeesGS Skyline Support

                  Any IP Address assigned to vCenter servers, should be a unique IP.

                  It should not be assigned to any other system.

                  Since the upgrade path requires a Temporary IP.

                  Make sure the temporary IP's obtained is unused in the environment.

                   

                  If the IP Address which is being option is having a duplicate entry, then the upgrade would not complete as the installer would not be able to communicate to the machine once deployed.

                  • 6. Re: Error upgrade to VCSA 6.7
                    vm7user Enthusiast

                    temporary IP is free and is unique

                    • 7. Re: Error upgrade to VCSA 6.7
                      ashwin_prakash Expert
                      VMware EmployeesGS Skyline Support Skyline Community 2/2

                      As per the error that you have received, it happens because of a IP Conflict.

                      Either you could use a different IP Address or You could try to track the IP Address using the Article below.

                       

                      VMware Knowledge Base

                      • 8. Re: Error upgrade to VCSA 6.7
                        dikkelul3bier Lurker

                        I have this exact problem.

                        The so called 'conflicting' IPv4 address is that of the OLD VCSA. No way it could be conflicting, since during the installation the old VCSA is shut down.

                        I tried all kinds of things, even logging in to the NEW VCSA, cleaning the ARP-cache, manually trying to bring up the new IP address, which succeeds, but the installation won't proceed.

                         

                        I'm pulling my hair out and am thinking of skipping the whole update program since it seems to be just broken.

                         

                        Downloaded the logs; the installer tries to check for conflicting IPv4 addresses with ARP or so it seems. In the cache my OLD VCSA is found:

                         

                        vcsa.mydomain (a.b.c.d) at <incomplete> on eth0

                         

                        Needless to say; my OLD VCSA will always have the 'conflicting' IPv4 address.

                         

                        Please, can someone help me out?

                         

                        Update: I logged in to the OLD VCSA on port 5480 and it seems there was an update available for VCSA. Now updating from:

                        6.5.0.14000 Build Number 7515524

                        to

                        6.5.0.21000 Build Number 8815520

                         

                        Will try the upgrade to 6.7.0a after that.

                         

                        Update: Exactly the same. Upgrade seems to be just broken.

                        Update: 6.7.0b gives the same results.

                         

                        Could someone please help me out here?

                        • 9. Re: Error upgrade to VCSA 6.7
                          sanstey Lurker

                          I had this exact same issue last night. On my first attempt I set a static IP for the temporary vCSA and I got this error. The second upgrade attempt I let DHCP handle it and it was successful. No idea why it would matter, but nevertheless, this was my experience.

                          • 10. Re: Error upgrade to VCSA 6.7
                            scongdon Lurker

                            Just ran into this issue as well, seems like a bug for sure.

                             

                            Old VCSA is offline, cannot ping it, does not show up in MAC table. Funny thing is when I SSH'd into the temporary DHCP address of the 6.7 upgrade partially failed box and rebooted it via CLI, it actually came up with the correct static address of the old 6.5 VCSA but was inoperable because the upgrade/migration process died.

                             

                            Will just do it again... maybe I'll get lucky.

                             

                            QC seems like a thing of the past unfortunately.

                            • 11. Re: Error upgrade to VCSA 6.7
                              John Stankiewicz Lurker

                              I'm having the same problem, have a case open with support.  Seems like the old windows vcenter isn't shutting down fast enough before the migration process tries to transfer the IP address. Any ideas on how to delay the IP migration?

                              • 12. Re: Error upgrade to VCSA 6.7
                                scongdon Lurker

                                Hi John-

                                 

                                Oddly enough, I ran the exact same process again as the first time and it was successful the second. I wish I had a better answer than that... Just for grins I left a continuous ping going during the second migration and it (the old vCenter) shut down well before the new one attempted to start up.

                                 

                                If I remember correctly, I did login to our core switch and clear the ARP cache once the old machine powered down, just in case it was an ARP timeout issue was causing the new vCenter to think the IP was still active.

                                 

                                Hopefully they can get it sorted out for you!

                                 

                                Thanks!

                                • 13. Re: Error upgrade to VCSA 6.7
                                  Vijay2027 Expert
                                  vExpert

                                  This error appears when the source VCSA is still shutting down (holding the IP address) and at the same time the target is setting the network.

                                   

                                  VMware identified this bug and the fix is available in 6.7 U1 release.

                                   

                                  Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered. Thank you.

                                  1 person found this helpful
                                  • 14. Re: Error upgrade to VCSA 6.7
                                    aventre Lurker

                                    I updated my VCSA from 6.5 to 6.7 as fallows:

                                     

                                    Used the 6.7.0d (Release Date: 14.08.2018) binaries.

                                     

                                    1. Deploy 6.7 Appliance with the installer using "Upgrade" (Stage 1) and give temporary IP

                                    2. Take Snapshot of the source VCSA and the newly deployed and clean VCSA 6.7

                                    3. Initiate Stage 2 of the Upgrade

                                        - if the installer was closed you can continue by navigating to the Appliance Management Interface of the new VCSA https://[IP OF NEW VCSA]:5480/

                                    4. Wait until the data of the source VCSA is exportet

                                    5. At the step "Shutting down source appliance" connect to the source appliance via console direct on the ESXi Host and force power off

                                    6. The wizard continues and successfully upgraded to 6.7 in my case

                                    1 2 Previous Next