2 Replies Latest reply on Apr 17, 2018 2:44 AM by niceguy001

    Could not Collect all Results for the following Wklds & Error : WeathervaneElastic*.wrf does not exist, exiting

    niceguy001 Enthusiast

      my SUT is a 4-node cluster(using vSAN as primary storage), i used it to execute VMmark3 7-tile test(not turbo mode)

      the STAX job monitor showed that the "VMmark Results Collection" failed; other stages are passed and good

       

      the problem is, same errors has occurred for so many times:

      1. on the STAX monitor there are somes errors showed up:

      Error: Tile 0 Weathervane results number not correctly identified

      Error: Tile 4 Weathervane results number not correctly identified

      Error: Tile 5 Weathervane results number not correctly identified

      Error: Tile 6 Weathervane results number not correctly identified

      Could not Collect all Results for the following 4 Wklds: ['AuctionLB Tile0 failed results collection', 'AuctionLB Tile4 failed results collection', 'AuctionLB Tile6 failed results collection', 'AuctionLB Tile5 failed results collection']

      Warning: VMmark may not have completed successfully. Check for results manually, see documentation for instructions.

       

      to deal with this, i use tilescore.pl to generate scores but the parameters seemed not work, same errors showed up:

      A. tried the command: perl ../../tools/tilescore.pl -t 7 -E

      VMmark 3.0 TileScore : v1.0 05222017

      Computing_results_for_test_with_tile_count: 7 ...

       

      Error : WeathervaneAuction0.wrf does not exist, exiting

      B. tried the command: perl ../../tools/tilescore.pl -t 7 -D

      VMmark 3.0 TileScore : v1.0 05222017

      Computing_results_for_test_with_tile_count: 7 ...

       

      Error : WeathervaneElastic0.wrf does not exist, exiting

      C. tried the command: perl ../../tools/tilescore.pl -t 7 -E -W

      VMmark 3.0 TileScore : v1.0 05222017

      Computing_results_for_test_with_tile_count: 7 ...

      First Sample: 1523843640 Mon Apr 16 01:54:00 2018

      Use of uninitialized value in concatenation (.) or string at  ../../tools/tilescore.pl line 2622.

      Info: 186 : : 7 : 4

      Undefined times at 186

      Error : could not resolve start-time. Results data missing from one or more *.wrf files or time on clients not synchronized

       

      basically, the scores and graph.html could not be generated, i've read the user guide and hope did not miss any paragraph.

       

      i've checked the journalctl_SYSTEMD_UNIT=startstaf.service file and...

      there are only two errors:

      ERROR ST84 : DeployVM0 : All pings failed at 10.101.6.240 : Try increasing ProvisionPingMaxTries in VMmark3.properties

      ERROR MAIN : VMmark3 Service Thread Pool not shutdown cleanly : Exceed maximum timeframe : Creating Stop File

       

      i didn't see "deploy remediation warning", "error verylow-disk-space" or "get guest info did not run correctly"...

      any ideas?

      i could only imagine that these problems were due to the client VMs' hosts have insufficient computing resources?

      or due to second or third shared storage space too small?

      or vmmark3-template at wrong storage?

       

      thanks for reading my article, hope i can also solve others' problems.

       

      related files are attached.

        • 1. Re: Could not Collect all Results for the following Wklds & Error : WeathervaneElastic*.wrf does not exist, exiting
          jpschnee Expert
          VMware Employees

          From what I can see in the STAX user log, weathervane failed very early in the process.

          20180416-01:53:21 Info  Error: tile 0 AuctionLB run too short, elapsed time = 21, expected time = 11040

          This will cause the results number to be fail.

           

          You can't run tilescore.pl as the required files are likely missing/bad.

           

          I would suggest that you review the provisioning output and/or reprovision your environment after making corrections.  Odds are something went wrong there and it didn't complete successfully. 

          • 2. Re: Could not Collect all Results for the following Wklds & Error : WeathervaneElastic*.wrf does not exist, exiting
            niceguy001 Enthusiast

            alright, this is weird...

            i deleted 4 VMs: AuctionLB0, AuctionLB4, AuctionLB5 and AuctionLB6

            then provisioned the AuctionLB0 from vmmark3-template in a provision run, and AuctionLB4, AuctionLB5, AuctionLB6 three VMs in another provision run

            to re-create them.

             

            in these two provisionings, no any errors can be found in the "VMmark3-ProvisioningService.log"

            so i guess the VMs themselves have no cfg. problems.

            (btw, i didn't edit the /etc/hosts file cause the VM-IP mapping already exist and match in it)

             

            then, i performed another 7 tiles formal mode test and still failed at "VMmark Results Collection" stage with similar errors on the STAX monitor:

            Error: Tile 5 Weathervane results number not correctly identified

            Error: Tile 6 Weathervane results number not correctly identified

            Could not Collect all Results for the following 2 Wklds: ['AuctionLB Tile6 failed results collection', 'AuctionLB Tile5 failed results collection']

             

            there are only 2 error of weathervane this time, the weathervane auctionlb of tile0 and tile4 seemed normal.

            log of this test run is attached.(maybe still no help)

             

            i guess only i can help myself

            jpschnee thank you so much for your help