14 Replies Latest reply on Jun 20, 2019 9:30 AM by jmatz135

    App Volumes Agent Fails to Connect to Managers

    jmatz135 Hot Shot

      About 5% of the time we have app volumes agents on machines just fail to connect to the app volumes manager.  I get the following error, but it doesn't make sense because it clearly has network access seeing as it becomes available in Horizon View just fine and users can log into the machine via View just fine, but they don't get appstacks because the App Volumes agent has decided not to connect to the manager for whatever reason.  Once in the desktop you can even go to the app volumes manager website just fine with no errors so it isn't like there is just an issue to the app volumes manager.  The funny thing is it says it waits 5 minutes, but I'm almost positive that it doesn't actually do that and it fails out in far less than that.  Even more interesting is now that the app volumes agent can have computer and user assigned appstacks we have one appstack that is assigned to the computer and the computer will still actually get that appstack AND STILL FAIL to connect to the manager.  How is that even possible?  How can an agent that claims to have failed to connect to the manager still get an appstack applied to it?  Of course when a user logs in though they don't get their user assigned appstacks,so...

       

      [2018-04-07 00:05:11.390 UTC] [svservice:P868:T964] [0] Connecting to appvols.manager.local:443 using HTTPS (attempt 1)

      [2018-04-07 00:05:11.390 UTC] [svservice:P868:T964] WinHttpSendRequestWithSSLCertValidation: SSL certificate validation is disabled.

      [2018-04-07 00:05:11.390 UTC] [svservice:P868:T964] WinHttpSendRequestWithSSLCertValidation: WinHttpSetOption(WINHTTP_OPTION_SECURITY_FLAGS) succeeded.

      [2018-04-07 00:10:11.386 UTC] [svservice:P868:T964] WinHttpSendRequestWithSSLCertValidation: WinHttpSendRequest succeeded.

      [2018-04-07 00:10:11.386 UTC] [svservice:P868:T964] WinHttpReceiveResponse timed out waiting for response

      [2018-04-07 00:10:11.386 UTC] [svservice:P868:T964] Retrying in 5 seconds (waited 300 seconds out of 120 max)

      [2018-04-07 00:10:16.386 UTC] [svservice:P868:T964] Aborting HTTP request after exceeding time limit (120 seconds)

      [2018-04-07 00:10:16.386 UTC] [svservice:P868:T964] HttpComputerStartupThread Pre-startup over HTTP failed: error 1000

      [2018-04-07 00:10:16.386 UTC] [svservice:P868:T964] HttpComputerStartupThread: failed (computer startup)

      [2018-04-07 00:10:43.730 UTC] [svservice:P868:T872] Received SERVICE_CONTROL_INTERROGATE

       

      Anyone have any ideas as to a fix?  As you can see in the logs certificate validation is already off since that causes all kinds of issues too, just apparently not this one.  I have also made sure the network cards can't be put to sleep via power management.  Our desktops are instant clone desktops that are refreshed every log off.