0 Replies Latest reply on Apr 10, 2018 2:00 PM by BluiWulf

    Captured EXE cannot write to virtual registry

    BluiWulf Lurker

      This appears to be a bit of a unique situation.  I have captured a collection of software and dependencies into one virtual package and one of the EXE has to write values to the registry when exiting.  I was told by the original developers that the original software would have problems on Win7 or newer OS(s) performing this action unless the software was started with administrator privileges.

       

      I have tried running the virtual application as administrator, but the registry values are still not written and it forces an infinite loop as it tries to keep writting the values.  Just a special note here, I am testing the virtual application on the virtual machine used to capture it so it is not performing as intended on Windows XP 32-bit like the original software does and we are using ThinApp 5.2.2.

       

      I was thinking of making the registry key have a merged isolation and then running the application as an administrator to see if it would attempt to write to the host registry, but not sure how well that will work.

       

      Has anyone experienced this before?  It seems weird that the virtual application doesn't have the ability to write to its own virtual registry.

       

      UPDATE:

      Just to add some more information...

       

      I added entry points for regedit, cmd and added sysinternals that work with WinXP and found that even though I updated the permissions for th registry key in question, the virtual application package apparently has only read permissions and I cannot make any change to it.  I cannot change ownership or change permissions to anything in the virtual registry.

       

      Message was edited by: Lance Walker