5 Replies Latest reply on Jun 8, 2019 4:52 AM by ShahidRaza9

    horizon doesn't work on ios

    HrcoCro Lurker

      Hi everyone.

      We have installed Horizon 7.3.1 and identity manager 3.1.

      We have to log on to our computers using smart cards.

      On a computer, when I enter the adress of my idm server, true sso works and I get my idm portal with all the published applications. When I launch any application it works without a problem.

      But when I connect to vpn on my iPhone and enter the idm server address in a idm application, it asks me for a username and password. If I enter idm server address in Safari, it asks me for a certificate (because I have a few diferent certificates), I select it, it logs me in and gives me all my published apps. But when I try to start any app, nothing happens, I just get progress circle for a second and that's it.

      Any ideas?

        • 1. Re: horizon doesn't work on ios
          Li_Huang Lurker
          VMware Employees

          Hi HrcoCro,

           

          Thanks for telling us this issue.

          Could you please tell us whether the Horizon App on your iPhone has been launched or not after you clicked the App icons in IDM? so that we can know whether it maybe Horizon App issue or IDM issue.

          • 2. Re: horizon doesn't work on ios
            HrcoCro Lurker

            No, horizon app doesn't launch when I click on any app inside safari. If I try IDM app on iPhone, it asks me for username and password.

            We got it to work for like 2 minutes but we're not sure how. We were setting up bind server for ios authentication inside idm and for a brief moment, sso worked, apps worked (when I started the app, horizon launced and app worked).

            If I login to IDM app with username and password, then everything works, it launches app with no problem. So the problem in authentication somewhere.

            Can you explain me a bit more how bind server (and that authentication between idm app,ad nad horizon server) works and how should that be set up? What information and where on bind server should I replace with my idm server. We think that the problem is here somewhere, probably idm app cant authenticate with domain controller or it doesn't know how to forward credentials to horizon server.

            • 3. Re: horizon doesn't work on ios
              Sabrina_Hou Lurker

              Would you mind try to launch the app from Chrome on iOS?

              It can work on my iOS deivce if I launch it from Chrome.

              w

              • 4. Re: horizon doesn't work on ios
                HrcoCro Lurker

                No, it doesn't work in chrome. When I enter address of my IDM server, it asks me for username and password. I enter credentials and it logs me in. when I try to launch any app, I get access denied with "kerberos negotiate failed or was canceled by user" error.

                • 5. Re: horizon doesn't work on ios
                  ShahidRaza9 Lurker

                  I also faced this issue when I installed the application of professional assignment writers , I think you should update the iOS versions then you may easily run horizon