5 Replies Latest reply on Sep 6, 2018 2:17 AM by Wanly

    Upgrading VCSA 6.0 U1 to 6.5 U1

    DaIceMan Enthusiast

      I am trying to upgrade a VCSA 6.0 U1 to VCSA 6.5 U1 (latest current). However the upgrade fails at importing the config at 21% with a 'common_upgrade:Import' failed error and the various logs break down to just this part in the Import_com.vmware.common_upgrade_2018_03_19_18_32.log :

       

      2018-03-19T18:33:03.700Z INFO extensions Found upgrade phase <module 'common_upgrade' from '/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/common_upgrade/__init__.py'>:Import'

      2018-03-19T18:33:03.700Z INFO extensions Executing upgrade phase '<module 'common_upgrade' from '/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/common_upgrade/__init__.py'>:Import' with context {u'resourceDir': u'/usr/lib/vmware/cis_upgrade_runner/upgrade_working_directory', u'infrastructureUsername': u'Administrator@....', u'sourceSsoPassword': 'CENSORED', u'exportDir': u'/storage/seat/cis-export-folder/common_upgrade', u'locale': u'en', u'destinationPlatform': u'Linux', u'destinationVcVersion': u'6.1', u'sourceVcVersion': u'6.0', u'sourceSsoUsername': None, u'sourcePlatform': u'Linux', 'logDir': u'/var/log/vmware/upgrade', u'infrastructureHost': u'172.22.22.20', u'sourceSsoVersion': u'6.0', u'vcdb.migrateSet': u'core', u'infrastructureHttpsPort': u'443', u'infrastructurePassword': 'CENSORED', u'systemExportDir': u'/storage/seat/cis-export-folder/system-data', u'destinationSsoVersion': u'6.1'}.

      2018-03-19T18:33:03.700Z ERROR __main__ Upgrade Phase 'common_upgrade:Import' failed. Exception:

      Traceback (most recent call last):

        File "/usr/lib/vmware/cis_upgrade_runner/payload/componentPhaseLauncher.py", line 438, in main

          executionResult = systemExtension(exeContext)

        File "/usr/lib/vmware/cis_upgrade_runner/libs/sdk/extensions.py", line 94, in __call__

          result = self.extension(*args)

        File "/usr/lib/vmware/cis_upgrade_runner/libs/sdk/extensions.py", line 110, in _func

          return func(*args)

        File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/common_upgrade/__init__.py", line 45, in importData

          importHostsFile(context["exportDir"])

        File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/common_upgrade/persist_hosts_file.py", line 235, in importHostsFile

          targetVamiEntries = _getHostsVamiSection()

        File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/common_upgrade/persist_hosts_file.py", line 164, in _getHostsVamiSection

          fromI = next(i for i, e in enumerate(lines) if "VAMI_EDIT_BEGIN" in e)

      StopIteration

       

         I just tried to import the config data without any other task history. I have no other clue on what could be the problem. I might try upgrading to 6.0 U2a first then to 6.5 to see if the same error persists. Any heads up would be appreciated!