1 2 Previous Next 25 Replies Latest reply on Feb 16, 2019 2:30 AM by JVNK

    VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails

    GregUK Novice

      Hey,

       

      I'd love some help with this please!

       

      I have 2 VCSA, an External PSC that I have updated to 6.0.0.30400, updated from 6.0.0.200 last night, and a vCenter running 6.0.0.5110 which I am trying to upgrade to 6.0.0.30400

      The patches stage ok but I get the errors shown below when I install them.

       

      The PSC had been on 6.0.0.200 for a while. My colleague had previously been battling with the vCenter which was on 6.0.0. I managed to get the vCenter up to 6.0.0.5110 last night. I tried more recent updates but it always fails.

       

      df -h shows good space

      Filesystem                            Size  Used Avail Use% Mounted on

      /dev/sda3                              11G  5.2G  5.1G  51% /

      udev                                  7.9G  168K  7.9G   1% /dev

      tmpfs                                 7.9G   36K  7.9G   1% /dev/shm

      /dev/sda1                             128M   38M   84M  31% /boot

      /dev/mapper/core_vg-core               50G   36G   12G  76% /storage/core

      /dev/mapper/log_vg-log                 15G  7.6G  6.5G  55% /storage/log

      /dev/mapper/db_vg-db                  9.9G  294M  9.1G   4% /storage/db

      /dev/mapper/dblog_vg-dblog            5.0G  587M  4.1G  13% /storage/dblog

      /dev/mapper/seat_vg-seat               25G  1.5G   22G   7% /storage/seat

      /dev/mapper/netdump_vg-netdump       1001M   18M  932M   2% /storage/netdump

      /dev/mapper/autodeploy_vg-autodeploy  9.9G  151M  9.2G   2% /storage/autodeploy

      /dev/mapper/invsvc_vg-invsvc          9.9G  213M  9.2G   3% /storage/invsvc

      I've rotated the log files '/etc/logrotate.d/logrotate -f /etc/logrotate.conf'

      The only other solutions I have integrated are vRealize Operations Manager which is running 6.0.5571310

      I've got the VMware-vCenter-Server-Appliance-6.0.0.30400-7464101-patch-FP.iso mounted

       

      These are the commands I'm running:

      Command> software-packages stage --iso --acceptEulas

      [2018-03-06T11:20:32.065] : Staging software update packages from ISO

      [2018-03-06T11:20:32.065] : ISO mounted successfully

      [2018-03-06 11:20:32,287] : Running pre-stage script.....

      [2018-03-06T11:20:33.065] : Verifying staging area

      [2018-03-06T11:20:33.065] : Validating software update payload

      [2018-03-06T11:20:33.065] : Validation successful

      [2018-03-06 11:20:33,828] : Processing software packages in update payload 231/231

      [2018-03-06T11:21:52.065] : ISO unmounted successfully

      [2018-03-06T11:21:52.065] : (212) packages staged successfully

      [2018-03-06T11:21:52.065] : Staging process completed successfully

      Command> software-packages install --staged

      [2018-03-06 11:25:16,264] : Running test transaction ....

      [2018-03-06T11:25:19.065] : Installation process failed

       

       

      I have another SSH session to the vCenter so that I can tail the /var/log/vmware/applmgmt/software-packages.log

       

      Here is the end of /var/log/vmware/applmgmt/software-packages.log

      ~#~

      2018-03-06T11:21:52.065:root:Staging process completed successfully

      2018-03-06T11:25:16.065:root:Installing software update packages {args = Namespace(acceptEulas=False, func=<function install at 0x7f71155c8b90>, iso=False, staged=True)}

      2018-03-06T11:25:16.065:vmware.vherd.base.software_update:Iniitialized software update state

        Staged status = True

      Staged packages:

      {}

      Installed packages:

      {}

      Payload packages:

      {} MetaData:

      {}

       

       

      2018-03-06T11:25:16.065:vmware.vherd.base.software_update:Extracting information about packages in /var/software-packages/

      2018-03-06T11:25:19.065:vmware.vherd.base.software_update:Test transaction failed to update package

      out=Preparing...                ##################################################

       

       

      error=warning: /var/software-packages/ruby2.1-rubygem-backports-3.6.6-1.3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 0e9af123

      warning: /var/software-packages/vmware-tools-core-10.1.10-1.sles11.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949

              package libcom_err2-1.41.9-2.10.11.1.x86_64 is already installed

              package net-tools-1.60-725.35.1.x86_64 is already installed

              package popt-1.7-37.63.64.1.x86_64 is already installed

              package rpm-4.4.2.3-37.63.64.1.x86_64 is already installed

              package libdw1-0.152-4.9.17.x86_64 is already installed

              package sg3_utils-1.35-0.19.1.x86_64 is already installed

              package udev-147-0.107.1.x86_64 is already installed

       

       

      rc=254

       

       

      2018-03-06T11:25:19.065:root:Installation process failed

      2018-03-06T11:25:19.065:root:Test transaction failed to update packages

      Exception:

      Traceback (most recent call last):

        File "/usr/lib/applmgmt/support/scripts/software-packages.py", line 143, in install

          installPackagesEP(staged=args.staged, iso=args.iso, acceptEulas=args.acceptEulas)

        File "/usr/lib/applmgmt/base/py/vmware/vherd/base/software_update.py", line 1093, in installPackagesEP

          _runTestTransaction(pkgType)

        File "/usr/lib/applmgmt/base/py/vmware/vherd/base/software_update.py", line 770, in _runTestTransaction

          raise GenericException("Test transaction failed to update packages")

      GenericException: Test transaction failed to update packages

       

       

      2018-03-06T11:25:19.065:vmware.vherd.base.software_update:Destroyed software update state

      ~#~

       

      Many thanks,

      Gerg

        • 1. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
          Wonlliv Enthusiast
          vExpert

          Hi Gerg,

           

          is it possible that the root account expired at the vCSA?

          By default it is set to 90 days.

          VMware Knowledge Base

          VMware Knowledge Base

           

          Best regards,

          Chris

          • 2. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
            GregUK Novice

            Hi Chris,

             

            The root password is working fine as I can SSH to both VCSA and login :-)

             

            Thanks anyway.

             

            Cheers,

            Gerg

            • 3. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
              Wonlliv Enthusiast
              vExpert

              Yeah, login still is possible but using it during the update process could be a problem.

              Would suggest to try change it once for troubleshooting checks.

               

              had a similar problem and after changing it, it worked like a charm :-)

               

              best regards,

              chris

              • 4. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                GregUK Novice

                Hi Chris,

                 

                I'll give that a whirl and let you know.

                 

                Cheers,

                Gerg

                • 5. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                  GregUK Novice

                  I changed the root password on both VCSAs, via the Console.

                  Unfortunately I get the same error.

                   

                  It's these errors that I'm thrown by!

                  ~#~

                  error=warning: /var/software-packages/ruby2.1-rubygem-backports-3.6.6-1.3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 0e9af123

                  warning: /var/software-packages/vmware-tools-core-10.1.10-1.sles11.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949

                          package libcom_err2-1.41.9-2.10.11.1.x86_64 is already installed

                          package net-tools-1.60-725.35.1.x86_64 is already installed

                          package popt-1.7-37.63.64.1.x86_64 is already installed

                          package rpm-4.4.2.3-37.63.64.1.x86_64 is already installed

                          package libdw1-0.152-4.9.17.x86_64 is already installed

                          package sg3_utils-1.35-0.19.1.x86_64 is already installed

                          package udev-147-0.107.1.x86_64 is already installed

                  ~#~

                   

                  ~#~

                  Command> software-packages stage --iso --acceptEulas

                  [2018-03-07T10:56:27.066] : Staging software update packages from ISO

                  [2018-03-07T10:56:27.066] : ISO mounted successfully

                  [2018-03-07 10:56:27,789] : Running pre-stage script.....

                  [2018-03-07T10:56:28.066] : Verifying staging area

                  [2018-03-07T10:56:28.066] : Validating software update payload

                  [2018-03-07T10:56:28.066] : Validation successful

                  [2018-03-07 10:56:29,246] : Processing software packages in update payload 231/231

                  [2018-03-07T10:58:00.066] : ISO unmounted successfully

                  [2018-03-07T10:58:00.066] : (212) packages staged successfully

                  [2018-03-07T10:58:00.066] : Staging process completed successfully

                  Command> software-packages install --staged

                  [2018-03-07 10:58:44,679] : Running test transaction ....

                  [2018-03-07T10:58:48.066] : Installation process failed

                  Command>

                  ~#~

                   

                  ~#~

                  cat /var/log/vmware/applmgmt/software-packages.log

                   

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/cpio-lang-2.9-75.80.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libasm1-0.152-4.9.17.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/less-424b-10.24.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libopenssl1_0_1-1.0.2k-1.vmw.5312588.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libopenssl1_0_0-1.0.1g-0.57.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-rhttpproxy-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-plperl-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:30.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-vws-1.5.2.rpm to /var/software-packages/

                  2018-03-07T10:56:30.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/kbd-1.14.1-16.33.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:30.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/sysconfig-0.71.61-0.15.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ipxe-1.0.0-1.3987916.vmw.i686.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/gd-2.0.36.RC1-52.20.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-libs-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/popt-1.7-37.63.64.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-terminal-table-1.5.2-1.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:31.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libtiff3-3.8.2-141.160.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:32.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vpx-workflow-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:32.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/hal-0.5.12-23.76.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Package (coreutils-(none):8.12-6.25.32.33.1) is already installed or older than installed package (coreutils-None:8.12-6.25.32.33.1).

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/openssl1-1.0.1g-0.57.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-jmemtool-6.0.0-7002507.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-gss-support-11.3.0.0-6792996.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/apache2-2.2.29-10.24.1.vmw.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/PolicyKit-0.9-14.43.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vsock-kmp-trace-9.8.1.0_3.0.76_0.11-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/augeas-lenses-0.9.0-3.17.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:33.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vpxd-agents-eesx-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-snmp-1.0.10.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vmci-kmp-default-9.8.1.0_3.0.76_0.11-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dbus-1-1.2.10-3.33.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/unzip-6.00-11.13.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Package (python-(none):2.6.9-0.35.1) is already installed or older than installed package (python-None:2.6.9-0.35.1).

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-studio-vami-lighttpd_3.0.0.3-5491424.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Package (libuuid1-(none):2.19.1-6.62.7) is already installed or older than installed package (libuuid1-None:2.19.1-6.62.7).

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vmmemctl-common-10.1.10-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/cpio-2.9-75.80.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-timeSync-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/satsolver-tools-0.17.9-0.5.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dhcp-4.2.4.P2-0.27.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-pyvmomi-6.0.0-0.0.7002505.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/util-linux-2.19.1-6.62.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dhcpcd-3.2.3-45.5.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/glibc-32bit-2.11.3-17.109.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/glibc-locale-2.11.3-17.109.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-guestlib-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/aaa_base-11-6.99.100.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/openldap2-2.4.26-0.62.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/limal-ca-mgm-1.5.24-0.3.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vdcs-6.0.0-6085683.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/apache2-prefork-2.2.29-10.24.1.vmw.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dnsmasq-2.78-0.16.5.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgobject-2_0-0-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/net-tools-1.60-725.35.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/kernel-trace-base-3.0.101-0.47.106.5.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libopenssl0_9_8-0.9.8j-0.105.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/parted-2.3-10.42.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/rpcbind-0.1.6+git20080930-6.27.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-cloudvm-vimtop-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/apache2-utils-2.2.29-10.24.1.vmw.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libpng12-0-1.2.31-5.38.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/bind-libs-9.9.6P1-0.50.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-afd-6.0.0.3260-6683541.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/applmgmt-1.0.0-7461947.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:40.066:vmware.vherd.base.software_update:Package (libudev0-(none):147-0.107.1) is already installed or older than installed package (libudev0-None:147-0.107.1).

                  2018-03-07T10:56:41.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-server-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/pivotal-tc-server-standard-3.1.5-RELEASE.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/cron-4.1-194.211.213.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libzypp-9.40.5-19.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vmci-common-10.1.10-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:42.066:vmware.vherd.base.software_update:Package (sed-(none):4.1.5-85.32.1) is already installed or older than installed package (sed-None:4.1.5-85.32.1).

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-mbcs-6.0.0-7002507.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/PolicyKit-doc-0.9-14.43.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-autoUpgrade-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-OpenSSL-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/util-linux-lang-2.19.1-6.62.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:43.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-builder-3.2.2-24.15.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/python-lxml-3.8.0-1.vmw.6360951.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/tcsh-6.18.01-0.9.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vgauth-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/rpm-4.4.2.3-37.63.64.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/elfutils-0.152-4.9.17.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Package (device-mapper-(none):1.02.77-0.13.1) is already installed or older than installed package (device-mapper-None:1.02.77-0.13.1).

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-Socket6-0.22-1.24.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/mkinitrd-2.4.2-94.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libtirpc1-0.2.1-1.12.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-osslibs-server-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/openssl-certs-2.7-0.6.1.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libopenssl0_9_8-hmac-0.9.8j-0.105.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vc-support-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/irqbalance-1.0.4-0.13.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/zypper-log-1.6.335-29.9.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libebl1-0.152-4.9.17.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-cm-6.0.0-7002507.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/gpg2-2.0.9-25.33.41.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ntp-4.2.8p9-48.9.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/coreutils-lang-8.12-6.25.32.33.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-cis-visl-scripts-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/xorg-x11-libX11-7.4-5.11.15.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-studio-vami-tools_3.0.0.3-5491424.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-esx-kmods-default-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-powerOps-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vasecurity-6.0.0.0-6882057.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/wget-1.11.4-1.32.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vsock-common-10.1.10-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libext2fs2-1.41.9-2.10.11.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-pg_top-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-client-jdbc-9.3.17.0-5873103.noarch.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/openssh-6.2p2-0.40.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/openssl-0.9.8j-0.105.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/sysstat-8.1.5-7.49.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libcurl4-7.19.7-1.61.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/bind-utils-9.9.6P1-0.50.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-guestInfo-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/glib2-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/binutils-2.23.1-0.23.15.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/krb5-1.6.3-133.49.103.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:46.066:vmware.vherd.base.software_update:Package (libapr1-(none):1.5.2-70.1) is already installed or older than installed package (libapr1-None:1.5.2-70.1).

                  2018-03-07T10:56:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-commonjars-6.0.0-6732861.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libglib-2_0-0-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/python-curses-2.6.9-0.35.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-Module-Build-0.2808.01-0.72.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:55.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-vsm-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:55.066:vmware.vherd.base.software_update:Package (python-base-(none):2.6.9-0.35.1) is already installed or older than installed package (python-base-None:2.6.9-0.35.1).

                  2018-03-07T10:56:56.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/limal-ca-mgm-perl-1.5.24-0.3.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:56:56.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dhcp-server-4.2.4.P2-0.27.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby21-2.1.7-1.vmw.7081373.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-mini_portile-0.6.2-27.9.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vmci-kmp-trace-9.8.1.0_3.0.76_0.11-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Package (libgcrypt11-(none):1.5.0-0.19.1) is already installed or older than installed package (libgcrypt11-None:1.5.0-0.19.1).

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-esx-netdumper-6.0.0-0.0.6738756.i386.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Package (libgcc_s1-(none):4.7.2_20130108-0.19.3) is already installed or older than installed package (libgcc_s1-None:4.7.2_20130108-0.19.3).

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Package (libaugeas0-(none):0.9.0-3.17.2) is already installed or older than installed package (libaugeas0-None:0.9.0-3.17.2).

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-osslibs-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:01.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-services-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:02.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-5.10.0-64.72.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:02.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libcom_err2-1.41.9-2.10.11.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:04.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vpxd-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:04.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libdw1-0.152-4.9.17.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:04.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-studio-appliance-config_3.0.0.3-171013013341.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vpxd-client-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-trollop-2.1.2-2.4.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-Bootloader-0.4.89.72-9.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-backports-3.6.6-1.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vsanmgmt-6.2.0-0.1.6769860.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:18.066:vmware.vherd.base.software_update:Package (libpython2_6-1_0-(none):2.6.9-0.35.1) is already installed or older than installed package (libpython2_6-1_0-None:2.6.9-0.35.1).

                  2018-03-07T10:57:21.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vapi-6.0.0-6738758.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:24.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/python27-2.7.13-1.vmw.6276957.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:25.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/zypper-1.6.335-29.9.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:27.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vsan-health-6.2.0-6769860.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:27.066:vmware.vherd.base.software_update:Package (libapr-util1-(none):1.5.4-46.1) is already installed or older than installed package (libapr-util1-None:1.5.4-46.1).

                  2018-03-07T10:57:27.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/udev-147-0.107.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:29.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-syslog-1.0.0-7002507.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:30.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgcc43-32bit-4.6.9-0.13.22.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-eam-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vsock-kmp-default-9.8.1.0_3.0.76_0.11-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/freetype2-2.3.7-25.35.36.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Package (libelf1-(none):0.152-4.9.17) is already installed or older than installed package (libelf1-None:0.152-4.9.17).

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/applmgmt-cloudvm-1.0.0-7461947.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libnl-1.1-49.22.6.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Package (zlib-(none):1.2.7-0.12.3) is already installed or older than installed package (zlib-None:1.2.7-0.12.3).

                  2018-03-07T10:57:34.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-deployPkg-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:35.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/lvm2-2.02.98-0.37.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-virgo-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ConsoleKit-0.2.10-64.69.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgnutls26-2.4.1-24.39.60.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgmodule-2_0-0-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libxml2-python-2.9.4-1.vmw.4061983.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/sg3_utils-1.35-0.19.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:39.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgthread-2_0-0-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/rvc_1.4.0-4792130_x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:40.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-libxml-ruby-2.8.0-1.8.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-doc-5.10.0-64.72.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libxml2-2.9.4-1.vmw.4061983.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-nokogiri-1_5-1.5.11-1.8.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:42.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/sudo-1.7.6p2-0.23.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-sca-6.0.0-7002503.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:44.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/logrotate-3.7.7-10.30.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/dhcp-client-4.2.4.P2-0.27.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/perl-Test-Simple-0.72-0.72.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/timezone-2017b-0.51.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/curl-7.19.7-1.61.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:45.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-grabbitmqProxy-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-foundation-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-extras-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:46.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/nfs-client-1.2.3-18.38.43.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:48.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/kernel-default-3.0.101-0.47.106.5.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:48.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-perfcharts-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-libraries-nox-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-vpxd-vctop-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-esx-nox-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-plpython-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/zlib-32bit-1.2.7-0.12.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:49.066:vmware.vherd.base.software_update:Package (libstdc++6-(none):4.7.2_20130108-0.19.3) is already installed or older than installed package (libstdc++6-None:4.7.2_20130108-0.19.3).

                  2018-03-07T10:57:53.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vsphere-client-6.0.0-6855228.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:53.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/kernel-default-base-3.0.101-0.47.106.5.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:53.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-zip-2.0.2-2.14.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-lwis-6.2.0-6516714.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libgcc_s1-32bit-4.7.2_20130108-0.19.3.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/ruby2.1-rubygem-highline-1.7.0-42.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/glib2-lang-2.22.5-0.8.28.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-hgfsServer-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-contrib-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:54.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/rpm-python-4.4.2.3-37.63.64.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:55.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-invsvc-6.0.0-7002507.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:55.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-Postgres-odbc-9.3.17.0-5873103.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:56.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/python-xml-2.6.9-0.35.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:56.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/uuid-runtime-2.19.1-6.62.7.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:56.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libslp1-openssl1-1.2.0-172.26.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:57.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-jre-1.7.0_151-fcs.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:57.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-studio-vami-login_3.0.0.3-5491424.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:57.066:vmware.vherd.base.software_update:Package (libblkid1-(none):2.19.1-6.62.7) is already installed or older than installed package (libblkid1-None:2.19.1-6.62.7).

                  2018-03-07T10:57:57.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-visl-integration-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-core-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-vmxnet-common-10.1.10-5.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-vmbackup-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-tools-plugins-vix-10.1.10-1.sles11.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-studio-init_3.0.0.3-171013013341.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/gpg2-lang-2.0.9-25.33.41.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/e2fsprogs-1.41.9-2.10.11.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/release-notes-SLES-for-VMware-11.3.43-0.16.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Package (perl-base-(none):5.10.0-64.72.1) is already installed or older than installed package (perl-base-None:5.10.0-64.72.1).

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libldap-2_4-2-2.4.26-0.62.2.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/vmware-autodeploy-6.0.0-0.0.7002505.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Package (pciutils-(none):3.1.7-11.11.1) is already installed or older than installed package (pciutils-None:3.1.7-11.11.1).

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/iproute2-2.6.29.1-6.36.37.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/expat220-2.2.0-1.vmw.6160214.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/libksba-1.0.4-1.20.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:57:58.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/supportutils-1.20-115.2.noarch.rpm to /var/software-packages/

                  2018-03-07T10:57:59.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/glibc-2.11.3-17.109.1.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:58:00.066:vmware.vherd.base.software_update:Copied /mnt/iso-contents/VMware-sps-6.0.0-7462485.x86_64.rpm to /var/software-packages/

                  2018-03-07T10:58:00.066:vmware.vherd.base.software_update:ISO unmounted successfully

                  2018-03-07T10:58:00.066:vmware.vherd.base.software_update:/mnt/iso-contents directory deleted successfully

                  2018-03-07T10:58:00.066:vmware.vherd.base.software_update:(212) packages staged successfully

                  2018-03-07T10:58:00.066:vmware.vherd.base.software_update:Destroyed software update state

                   

                   

                  2018-03-07T10:58:00.066:root:Staging process completed successfully

                  2018-03-07T10:58:44.066:root:Installing software update packages {args = Namespace(acceptEulas=False, func=<function install at 0x7f97af8ffb90>, iso=False, staged=True)}

                  2018-03-07T10:58:44.066:vmware.vherd.base.software_update:Iniitialized software update state

                    Staged status = True

                  Staged packages:

                  {}

                  Installed packages:

                  {}

                  Payload packages:

                  {} MetaData:

                  {}

                   

                   

                  2018-03-07T10:58:44.066:vmware.vherd.base.software_update:Extracting information about packages in /var/software-packages/

                  2018-03-07T10:58:48.066:vmware.vherd.base.software_update:Test transaction failed to update package

                  out=Preparing...                ##################################################

                   

                   

                  error=warning: /var/software-packages/ruby2.1-rubygem-backports-3.6.6-1.3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 0e9af123

                  warning: /var/software-packages/vmware-tools-core-10.1.10-1.sles11.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949

                          package libcom_err2-1.41.9-2.10.11.1.x86_64 is already installed

                          package net-tools-1.60-725.35.1.x86_64 is already installed

                          package popt-1.7-37.63.64.1.x86_64 is already installed

                          package rpm-4.4.2.3-37.63.64.1.x86_64 is already installed

                          package libdw1-0.152-4.9.17.x86_64 is already installed

                          package sg3_utils-1.35-0.19.1.x86_64 is already installed

                          package udev-147-0.107.1.x86_64 is already installed

                   

                   

                  rc=254

                   

                   

                  2018-03-07T10:58:48.066:root:Installation process failed

                  2018-03-07T10:58:48.066:root:Test transaction failed to update packages

                  Exception:

                  Traceback (most recent call last):

                    File "/usr/lib/applmgmt/support/scripts/software-packages.py", line 143, in install

                      installPackagesEP(staged=args.staged, iso=args.iso, acceptEulas=args.acceptEulas)

                    File "/usr/lib/applmgmt/base/py/vmware/vherd/base/software_update.py", line 1093, in installPackagesEP

                      _runTestTransaction(pkgType)

                    File "/usr/lib/applmgmt/base/py/vmware/vherd/base/software_update.py", line 770, in _runTestTransaction

                      raise GenericException("Test transaction failed to update packages")

                  GenericException: Test transaction failed to update packages

                   

                   

                  2018-03-07T10:58:48.066:vmware.vherd.base.software_update:Destroyed software update state

                  ~#~

                   

                  Cheers,

                  Gerg

                  • 6. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                    Wonlliv Enthusiast
                    vExpert

                    mhhhh, I am wondering if the sda3 partition has enough free space (even if it says 51% free) cause of these two lines:

                     

                    2018-03-06T11:25:16.065:vmware.vherd.base.software_update:Extracting information about packages in /var/software-packages/

                    2018-03-06T11:25:19.065:vmware.vherd.base.software_update:Test transaction failed to update package

                     

                    Possible to expand the volume by a few GB, as it extract the files during this step. Just a thought...

                     

                    Best regards,

                    Chris

                    • 7. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                      GregUK Novice

                      I tried again but did a 'df -h' while the patches were staging and could see /dev/sda3 space usage increase but even with them staged it only went down to 62%.

                      While the 'Command> software-packages install --staged' was running I ran 'df -h' repeatedly and couldn't see any additional space being used.

                       

                      It feels like the dependencies are all mashed up. Probably from a failed update! Is there way to force the install or bypass the tests?

                       

                      For a laugh I tried going to VMware-vCenter-Server-Appliance-6.0.0.5120-2800573-patch-FP.iso but got an error!

                       

                      ~#~

                      2018-03-07T11:08:55.066:vmware.vherd.base.software_update:Test transaction failed to update package

                      out=

                      error=error: Failed dependencies:

                              libopenssl0_9_8 = 0.9.8j-0.68.1 is needed by libopenssl0_9_8-hmac-0.9.8j-0.68.1.x86_64

                       

                       

                      rc=39

                      ~#~

                       

                      I then tried VMware-vCenter-Server-Appliance-6.0.0.20000-3634791-patch-FP.iso but got this error!

                       

                      ~#~

                      2018-03-07T14:22:09.066:vmware.vherd.base.software_update:Extracting information about packages in /var/software-packages/

                      2018-03-07T14:22:11.066:vmware.vherd.base.software_update:Test transaction failed to update package

                      out=

                      error=warning: /var/software-packages/ruby2.1-rubygem-backports-3.6.6-1.3.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 0e9af123

                      warning: /var/software-packages/vmware-tools-core-10.0.0-1.sles11.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949

                      error: Failed dependencies:

                              VMware-Postgres = 9.3.5.2-2444648 is needed by (installed) VMware-Postgres-server-9.3.5.2-2444648.x86_64

                       

                       

                      rc=181

                       

                       

                      2018-03-07T14:22:11.066:root:Installation process failed

                      2018-03-07T14:22:11.066:root:Test transaction failed to update packages

                      ~#~

                       

                      Cheers,

                      Gerg

                      • 8. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                        Vijay2027 Expert
                        vExpert

                        I encountered similar issue:

                         

                        2018-08-15T15:33:19.227 [7985]DEBUG:vmware.vherd.base.software_update:Run command: ['/bin/cp', u'/mnt/iso-contents/vmware-autodeploy-6.0.0-0.0.7002505.noarch.rpm', '/var/software-packages']

                        2018-08-15T15:33:19.227 [7985]DEBUG:vmware.vherd.base.software_update:Run command: ['/bin/cp', u'/mnt/iso-contents/release-notes-SLES-for-VMware-11.3.43-0.16.1.x86_64.rpm', '/var/software-packages']

                        2018-08-15T15:33:19.227 [7985]DEBUG:vmware.vherd.base.software_update:Run command: ['/bin/rpm', '-Uhv', '--test', '/var/software-packages/*.rpm']

                        2018-08-15T15:33:21.227 [7985]DEBUG:vmware.vherd.base.software_update:STDOUT:

                        2018-08-15T15:33:21.227 [7985]DEBUG:vmware.vherd.base.software_update:STDERR: warning: /var/software-packages/vmware-tools-core-10.1.10-1.sles11.x86_64.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 66fd4949

                        error: Failed dependencies:

                                distribution-release is needed by kernel-default-3.0.101-0.47.106.5.1.x86_64

                         

                        I deployed a test vCSA compared the list of RPM's installed. There were 3 rpm's missing from my prod vCSA. Installed them manually post which I was ble to patch to latest build.

                         

                        Missing rpm's:

                         

                        release-notes-SLES-for-VMware-11.3.43-0.16.1

                        SLES-for-VMware-release-DVD-11.3-1.68

                        SLES-for-VMware-release-11.3-1.68

                        1 person found this helpful
                        • 9. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                          Vijay2027 Expert
                          vExpert

                          Please share below details if the issue still exists:

                           

                          ssh into vCSA and run the below commands:

                           

                          # uname -a;  vmware-toolbox-cmd -v;  vpxd -v

                           

                          # rpm -qa  > /tmp/packages.txt

                           

                          Use winscp and copy the pacakages.txt to your local machine and attach to the thread.

                           

                          VMware Knowledge Base

                          • 10. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                            dbuenoparedes Novice

                            Awesome finding Vijay2027, I am experiencing exactly the same issue. Where did you find those missing rpm's to be able to install them into the VCSA (PSC only in my case)? I was able to find the package release-notes-SLES-for-VMware-11.3.43-0.16.1 on the v6.0.0.30400 ISO image but not the other two.

                             

                            Great work, thanks!

                            • 11. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                              Vijay2027 Expert
                              vExpert

                              I used "rpm -e --repackage" command t generate rpm's from installed files.

                              Attached 3 missing rpm's from my vCSA upgrade issue.

                               

                              What is your existing vCSA build?

                              2 people found this helpful
                              • 12. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                                dbuenoparedes Novice

                                Great, thanks for the tip!

                                 

                                The VCSA (PSC) version I try to update from is 6.0.0.20000 Build Number 3634791. I'll try to follow your steps and will post back if I was successful or not.

                                6.0.0.20000 Build Number 3634791

                                • 13. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                                  dbuenoparedes Novice

                                  Forgot to ask, did you install those rpm's with the zypper SLES tool or with rpm itself?

                                   

                                  Edit: Sorry, bit of a noob in the Linux world, how did you get around the package dependencies when erasing the packages (-e) to repackage them? I get the following messages and tried using --force but that only works for install/upgrade:

                                   

                                  localhost:~ # rpm -e --repackage SLES-for-VMware-release-DVD-11.3-1.68
                                  error: Failed dependencies:
                                          product_flavor(SLES-for-VMware) is needed by (installed) SLES-for-VMware-release-11.3-1.68.x86_64
                                  localhost:~ # rpm -e --repackage SLES-for-VMware-release-11.3-1.68
                                  error: Failed dependencies:
                                          distribution-release is needed by (installed) aaa_base-11-6.99.100.1.x86_64
                                  localhost:~ # rpm -e --repackage --force SLES-for-VMware-release-11.3-1.68
                                  rpm: only installation, upgrading, rmsource and rmspec may be forced
                                  
                                  

                                   

                                  Edit2: nvm, I think I found it, use the switch: --nodeps

                                  • 14. Re: VCSA 6 | Upgrade from 6.0.0.5110 to 6.0.0.30400 fails
                                    Vijay2027 Expert
                                    vExpert

                                    This is the command to install rpm's..

                                     

                                    rpm -ivh <package-name>

                                    1 person found this helpful
                                    1 2 Previous Next