4 Replies Latest reply on Apr 26, 2018 7:33 AM by OsburnM

    Problem with Disabling Default Policy Alerts & Setting up New Cascading Policy & Alerts

    OsburnM Enthusiast

      I've setup a couple new policies and I'm not getting very far with the inheritance / priorities.  It's setup (as below) the way I thought it was supposed to work, yet my Alerts keep firing.

       

      My objective here is to turn off ALL Default Alerts, except one new User Defined Alert (Datastore Cluster Capacity Alert), and then block that new alert on a few specific objects defined in a custom group.  I'm attempting to leave the Alerts as defined in the "vSphere Solution's Default Policy" completely alone (ie, enabled/defaults).

       

      So I created a new "COMPANY - Default Policy with Custom Baseline Alerts" where that used the Solution's Default as its base.  I disabled all but this one alert (Datastore Cluster Capacity Alert) and applied this policy to the "Product Licensed" default group.

      From there I created another new "COMPANY - Default Policy Alert Override for X Datacenter" using the "COMPANY - Default Policy with Custom Baseline Alerts" as my base for this new Policy and I disabled the (Datastore Cluster Capacity Alert), and lastly applied this policy to a Custom Group that has the Datastore Clusters I wish to exclude from the alert.

       

      The Policy Priorities are:

      1 - COMPANY - Default Policy Alert Override for X Datacenter

      2 - COMPANY - Default Policy with Custom Baseline Alerts

      D - vSphere Solution's Default Policy

       

      I'm able to validate the various objects all now show defined by #2 above except for the Datastore Clusters I want excluded via my group.  Those properly show the #1 policy above.  So everything LOOKS right, YET I'm still getting all the alerts!  Very frustrating.

       

      Any ideas?

        • 1. Re: Problem with Disabling Default Policy Alerts & Setting up New Cascading Policy & Alerts
          dtaliafe Hot Shot

          Are you still getting alerts for both #1 and #2?  If only #2, I would try using another custom group instead of Product Licensed.  I assume Licensing groups should work since it will allow you to assign a policy to one, but I've always used custom groups.

           

          I also had a problem a while back where none of my changes to the policy were taking effect or it would take days for analytics to register the changes.  Even disabling alerts in the default policy didn't stop them.  Restarting the cluster fixed it.  That was in an older version of vROps (6.3 I believe), but if all else fails you could try restarting the cluster. From your description it sounds like everything is setup right.

          1 person found this helpful
          • 2. Re: Problem with Disabling Default Policy Alerts & Setting up New Cascading Policy & Alerts
            OsburnM Enthusiast

            Hey, thanks for the reply.  So I created a new Custom Group which is essentially All Decedents of vSphere World and then applied the #2 policy to that group instead of Product Licensed.  Same effect.  I can click on all the objects and see the #2 policy as the applicable policy; however, the objects are all still getting their default base alerts.

             

            To answer your first question, I'm not getting alerts for #1 so that part seems to be working.  I'm gonna let it rest overnight and if it's still not working tomorrow I'll reboot the cluster (this is vROps 6.6.1 btw).

            • 3. Re: Problem with Disabling Default Policy Alerts & Setting up New Cascading Policy & Alerts
              sxnxr Expert

              I dont know if this is the case with you but there is a known policy problem with sub policies of main policies not following the enabled or disabled setting. Apologizes GSS didn't explain exactly what the HF was for but we were having what looked like metrics that were disabled in the base policy still being collected when the object was a member of a sub policy and they recommended this HF

               

              you will need to log a case with GSS to get access to hot fix 9 if this is indeed the problem you are having. It is also fixed in 6.7 of vrops ( no release date yet but should be soon)

              1 person found this helpful
              • 4. Re: Problem with Disabling Default Policy Alerts & Setting up New Cascading Policy & Alerts
                OsburnM Enthusiast

                Just to followup with this-- we did end up getting a case opened and received the hotpatch that addressed the issue.  Thanks.