6 Replies Latest reply on Feb 28, 2018 12:35 AM by LucD

    New-CIVApp failed to create vApp from vAppTemplate in vCloud

    arccons Lurker

      Hello:

       

      I tried to create a vApp from a vAppTemplate using the command:

      New-CIVApp -Name $vAppName -Description "This vApp is created from PowerCLI" -OrgVdc $orgVDC -VAppTemplate $vAppTempl

       

      The problem is the New-CIVApp cmdlet returns a failure message saying:

      New-CIVApp : 2/28/2018 2:37:49 AM    New-CIVApp        Entity with id urn:vcloud:vapp:377a2c02-94cc-4c8c-918e-7f231bc3606e was not found.

      At C:\vCloud\vCloud.ps1:29 char:9

      +         New-CIVApp -Name $vAppName -Description "This vApp is created ...

      +         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

          + CategoryInfo          : ObjectNotFound: (urn:vcloud:vapp...8e-7f231bc3606e:String) [New-CIVApp], CIEntityNotFoundException

          + FullyQualifiedErrorId : Core_CloudImpl_EntityNotFound,VMware.VimAutomation.Cloud.Commands.Cmdlets.NewCIVApp

       

      But actually the vApp is created there in the vCloud when I log into from a browser.

       

      I also can get it with the cmdlet: $CIVApp = Get-CIVApp -name $vAppName

       

      And, $CIVApp.ExtensionData.id returns exactly the one (urn:vcloud:vapp:377a2c02-94cc-4c8c-918e-7f231bc3606e) that New-CIVApp could not find.

       

      My Environment:

      vCloud Director - 5.5.6

      PowerCli - 6.5.4.7155375

      Powershell -  5.1.14409.1012

      OS: Windows 7 SP1 (build 7601)

       

      I later checked the VMware Product Interoperability Matrices page and got to know that the newest version of PowerCLI that vCloud 5.5 supports is 6.3 so I tried it in another environment with PowerCLI 6.3, but got the same result still.

       

      Anyone can help me out of this, any helps appreciated.