6 Replies Latest reply on Jul 17, 2019 3:30 PM by Shreyskar Srivastava

    Visual Studio 2017 - UEM

    VDINinja311 Enthusiast

      Has anyone successfully ran Visual Studio 2017 through Application Profiler? Or have working UEM settings for Visual Studio 2017?

       

      Application Profiler for some reason isn't capturing anything when running VS 2017 and changing configurations settings. Every time you capture it comes back with nothing. So I am doing the configuration in UEM manually. I am having issues with VS 2017 consistently being able to bypass the first time launch configuration settings, when it asks for a theme and what kind of development configuration to use with VS. Sometimes you launch VS 2017 and it thinks everything is good and bypasses the first time launch configuration prompt, and sometimes it thinks this is the first time you have launched it.

       

      This is for Windows 10 1703, UEM 9.2, App Volumes 7.3.2. AppStack was provisioned with the Master Image and has only VS 2017 Enterprise and SQL Management Studio 2016 in it.

       

      Here is our current configuration for it.

       

      I generated the ini and such with the Profiler 9.2, but it wouldn't capture anything. I found all these manually.

        • 1. Re: Visual Studio 2017 - UEM
          Pim_van_de_Vis Expert
          vExpertVMware Employees

          All 'Microsoft' folders are excluded by default in the Application Profiler, that's why you don't see those locations.

          But you can either change those exclusions, or disabled them at all with the buttons in the Application Profiler. Very easy and straight forward.

           

          Also, have you seen and tried this?

          Microsoft Visual Studio.zip

          • 2. Re: Visual Studio 2017 - UEM
            techguy129 Expert
            vExpert

            Here is the configuration I use for VS 2017. It has been working for us.

             

             

             

            [IncludeRegistryTrees]

            HKCU\SOFTWARE\Microsoft\VisualStudio

            HKCU\SOFTWARE\Microsoft\VSCommon

            HKCU\SOFTWARE\Microsoft\VsHub

             

            [IncludeFolderTrees]

            <AppData>\Microsoft\VisualStudio

            <LocalAppData>\Microsoft\VisualStudio

            <LocalAppData>\Microsoft\VisualStudio Services

            <LocalAppData>\Microsoft\VSCommon

            <LocalAppData>\Microsoft\VSApplicationInsights

            <LocalAppData>\Microsoft\MSBuild

            <LocalAppData>\Microsoft\GameDVR

            • 3. Re: Visual Studio 2017 - UEM
              VDINinja311 Enthusiast

              Thank you for the responses. Helped get me there.

               

              I used a combo of both of those UEM settings. Ultimately what fixed it was to turn off DirectFlex so it will import at logon and export at logoff. Something must have been preventing DirectFlex from working 100% of the time. Unknown at this time, but we are good with this for now. We only have a few users that will be using VS 2017.

              • 4. Re: Visual Studio 2017 - UEM
                VDINinja311 Enthusiast

                I ended up with the following as well as DirectFlex disabled.

                 

                 

                 

                # Flex config file generated with VMware User Environment Manager Application Profiler version 9.2

                 

                [IncludeRegistryTrees]

                HKCU\SOFTWARE\Microsoft\VisualStudio

                HKCU\SOFTWARE\Microsoft\VsHub

                HKCU\SOFTWARE\Microsoft\CTF

                HKCU\SOFTWARE\Microsoft\VSCommon

                HKCU\SOFTWARE\Red Gate

                 

                [IncludeFolderTrees]

                <LocalAppData>\Microsoft\VisualStudio

                <LocalAppData>\Microsoft\VSCommon

                <LocalAppData>\Microsoft\VisualStudio Services

                <LocalAppData>\Microsoft\VSApplicationInsights

                <LocalAppData>\Microsoft\MSBuild

                <AppData>\Microsoft\VisualStudio

                • 5. Re: Visual Studio 2017 - UEM
                  robsisk1972 Enthusiast

                  Greetings all,

                  Curious if any of you still see "preparing for first time use" with the UEM settings marked as the correct answer.   I have captured Visual Studio 2019 and with the settings listed above logins take about 2 minutes because it always prepares for the first time use after a reboot. 

                  • 6. Re: Visual Studio 2017 - UEM
                    Shreyskar Srivastava Novice
                    VMware Employees

                    On running procmon we identified and added below entries in visual studio template and it resolved the issue:

                     

                    <LocalAppData>\Microsoft\VisualStudio

                    <LocalAppData>\.IdentityService

                    <LocalAppData>\Microsoft\Credentials

                     

                    Regards,

                    Shresykar