4 Replies Latest reply on Mar 28, 2018 12:47 PM by Ronaldorsan

    503 Service Unavailable (Failed to connect to endpoint:

    Crazy_David Lurker

      Hi guys,i have encountered this error after reboot the VC server.

      My platform type:vCenter Server with an embedded Platform Services Controller

      Version:VMware vCenter Server Appliance 6.0.0.20000

      When I open the web,it shows me:

      503 Service Unavailable (Failed to connect to endpoint:
      [N7Vmacore4Http20NamedPipeServiceSpecE:0x7fba64064840] _serverNamespace = /
      _isRedirect = false _pipeName =/var/run/vmware/vpxd-webserver-pipe)

       

      I checked the server,found those service was stopped which can't start manually:

      vmware-eam (VMware ESX Agent Manager)

      vmware-mbcs (VMware Message Bus Configuration Service)

      vmware-netdumper (VMware vSphere ESXi Dump Collector)

      vmware-perfcharts (VMware Performance Charts)

      vmware-rbd-watchdog (VMware vSphere Auto Deploy Waiter)

      vmware-sps (VMware vSphere Profile-Driven Storage Service)

      vmware-vdcs (VMware Content Library Service)

      vmware-vpostgres (VMware Postgres)

      vmware-vpx-workflow (VMware vCenter Workflow Manager)

      vmware-vpxd (VMware vCenter Server)

      vmware-vsan-health (VMware VSAN Health Service)

      vmware-vsm (VMware vService Manager)

      vsphere-client ()

       

      When I tried to start them,there shows me:

       

      vcsa-nj:~ # service-control --start vmware-eam
      INFO:root:Service: vmware-eam, Action: start
      Service: vmware-eam, Action: start
      2018-02-23T06:34:14.153Z   Running command: ['/sbin/chkconfig', u'vmware-eam']
      2018-02-23T06:34:14.214Z   Done running command
      2018-02-23T06:34:14.215Z   Running command: ['/sbin/service', u'vmware-eam', 'status']
      2018-02-23T06:34:14.282Z   Done running command
      2018-02-23T06:34:14.282Z   Running command: ['/sbin/chkconfig', '--force', u'vmware-eam', 'on']
      2018-02-23T06:34:14.343Z   Done running command
      2018-02-23T06:34:14.343Z   Running command: ['/sbin/service', u'vmware-eam', 'start']
      2018-02-23T06:34:19.157Z   Done running command
      2018-02-23T06:34:19.157Z   Invoked command: ['/sbin/service', u'vmware-eam', 'start']
      2018-02-23T06:34:19.157Z   RC = 1
      Stdout = Starting VMware ESX Agent Manager...
      Waiting for VMware ESX Agent Manager.......
      WARNING: VMware ESX Agent Manager may have failed to start.
      Last login: Fri Feb 23 06:27:08 UTC 2018 on console

      Stderr =
      2018-02-23T06:34:19.157Z   {
          "resolution": null,
          "detail": [
              {
                  "args": [
                      "Command: ['/sbin/service', u'vmware-eam', 'start']\nStderr: "
                  ],
                  "id": "install.ciscommon.command.errinvoke",
                  "localized": "An error occurred while invoking external command : 'Command: ['/sbin/service', u'vmware-eam', 'start']\nStderr: '",
                  "translatable": "An error occurred while invoking external command : '%(0)s'"
              }
          ],
          "componentKey": null,
          "problemId": null
      }
      ERROR:root:Unable to start service vmware-eam, Exception: {
          "resolution": null,
          "detail": [
              {
                  "args": [
                      "vmware-eam"
                  ],
                  "id": "install.ciscommon.service.failstart",
                  "localized": "An error occurred while starting service 'vmware-eam'",
                  "translatable": "An error occurred while starting service '%(0)s'"
              }
          ],
          "componentKey": null,
          "problemId": null
      }
      Unable to start service vmware-eam, Exception: {
          "resolution": null,
          "detail": [
              {
                  "args": [
                      "vmware-eam"
                  ],
                  "id": "install.ciscommon.service.failstart",
                  "localized": "An error occurred while starting service 'vmware-eam'",
                  "translatable": "An error occurred while starting service '%(0)s'"
              }
          ],
          "componentKey": null,
          "problemId": null
      }

       

       

      I tried a few times, and now ,there are also 5 service can't be start:

       

      vmware-eam (VMware ESX Agent Manager)

      vmware-invsvc (VMware Inventory Service)

      vmware-vdcs (VMware Content Library Service)

      vmware-vpostgres (VMware Postgres)

      vmware-vpx-workflow (VMware vCenter Workflow Manager)

       

      Their error info was similar to the info eam shows.

      Does anyone have any suggests?

        • 1. Re: 503 Service Unavailable (Failed to connect to endpoint:
          raghushetty Novice

          Hey,

           

          restart the Vcenter service from services and try..

          • 2. Re: 503 Service Unavailable (Failed to connect to endpoint:
            Crazy_David Lurker

            I have already restart the server and services many times, doesn't work...

            • 3. Re: 503 Service Unavailable (Failed to connect to endpoint:
              Crazy_David Lurker

              I tried to restart the service vmware-vpxd, it throws an err:

               

              vcsa-nj:~ # service-control --start vmware-vpxd

              INFO:root:Service: vmware-vpxd, Action: start

              Service: vmware-vpxd, Action: start

              2018-02-26T00:14:03.927Z   Running command: ['/sbin/chkconfig', u'vmware-vpxd']

              2018-02-26T00:14:04.038Z   Done running command

              2018-02-26T00:14:04.038Z   Running command: ['/sbin/service', u'vmware-vpxd', 'status']

              2018-02-26T00:14:04.797Z   Done running command

              2018-02-26T00:14:04.798Z   Running command: ['/sbin/chkconfig', '--force', u'vmware-vpxd', 'on']

              2018-02-26T00:14:04.910Z   Done running command

              2018-02-26T00:14:04.910Z   Running command: ['/sbin/service', u'vmware-vpxd', 'start']

              2018-02-26T00:24:13.755Z   Done running command

              2018-02-26T00:24:13.755Z   Invoked command: ['/sbin/service', u'vmware-vpxd', 'start']

              2018-02-26T00:24:13.755Z   RC = 1

              Stdout = /usr/sbin/vpxd_commonutils: line 197: /etc/vmware-vpx/embedded_db.cfg: No such file or directory

              vmware-vpxd: VC SSL Certificate does not exist, it will be generated by vpxd

              Executing pre-startup scripts...

              vmware-vpxd: Starting vpxd by administrative request.

              success

              vmware-vpxd: Waiting for vpxd to start listening for requests on 8089

              Waiting for vpxd to initialize: ..........................................................Mon Feb 26 00:23:51 UTC 2018 Captured live core: /var/core/live_core.vpxd.24179.02-26-2018-00-23-51

              [INFO] writing vpxd process dump retry:2 Time(Y-M-D H:M:S):2018-02-26 00:23:48

              .Mon Feb 26 00:24:03 UTC 2018 Captured live core: /var/core/live_core.vpxd.24179.02-26-2018-00-24-03

              [INFO] writing vpxd process dump retry:1 Time(Y-M-D H:M:S):2018-02-26 00:24:01

              .failed

              failed

              vmware-vpxd: vpxd failed to initialize in time.

              vpxd is already starting up. Aborting the request.

               

               

              Stderr = /usr/sbin/vpxd_commonutils: line 197: /etc/vmware-vpx/embedded_db.cfg: No such file or directory

               

               

              2018-02-26T00:24:13.756Z   {

                  "resolution": null,

                  "detail": [

                      {

                          "args": [

                              "Command: ['/sbin/service', u'vmware-vpxd', 'start']\nStderr: /usr/sbin/vpxd_commonutils: line 197: /etc/vmware-vpx/embedded_db.cfg: No such file or directory\n"

                          ],

                          "id": "install.ciscommon.command.errinvoke",

                          "localized": "An error occurred while invoking external command : 'Command: ['/sbin/service', u'vmware-vpxd', 'start']\nStderr: /usr/sbin/vpxd_commonutils: line 197: /etc/vmware-vpx/embedded_db.cfg: No such file or directory\n'",

                          "translatable": "An error occurred while invoking external command : '%(0)s'"

                      }

                  ],

                  "componentKey": null,

                  "problemId": null

              }

              ERROR:root:Unable to start service vmware-vpxd, Exception: {

                  "resolution": null,

                  "detail": [

                      {

                          "args": [

                              "vmware-vpxd"

                          ],

                          "id": "install.ciscommon.service.failstart",

                          "localized": "An error occurred while starting service 'vmware-vpxd'",

                          "translatable": "An error occurred while starting service '%(0)s'"

                      }

                  ],

                  "componentKey": null,

                  "problemId": null

              }

              Unable to start service vmware-vpxd, Exception: {

                  "resolution": null,

                  "detail": [

                      {

                          "args": [

                              "vmware-vpxd"

                          ],

                          "id": "install.ciscommon.service.failstart",

                          "localized": "An error occurred while starting service 'vmware-vpxd'",

                          "translatable": "An error occurred while starting service '%(0)s'"

                      }

                  ],

                  "componentKey": null,

                  "problemId": null

              }

               

              anyone some suggests?

              • 4. Re: 503 Service Unavailable (Failed to connect to endpoint:
                Ronaldorsan Lurker

                Hello everyone, I have here the same problem I guess.

                 

                    I have the same 503 service unavailable screen and once I try to start manually the server, it stops in the following step:

                 

                2018-03-20T19:17:56.062Z   Running command: ['/sbin/service', u'vmware-vpostgres', 'start']

                2018-03-20T19:22:58.868Z   Done running command

                2018-03-20T19:22:58.868Z   Invoked command: ['/sbin/service', u'vmware-vpostgres', 'start']

                2018-03-20T19:22:58.868Z   RC = 1

                Stdout = Starting VMware vPostgres:

                Stderr =

                2018-03-20T19:22:58.868Z   {

                    "resolution": null,

                    "detail": [

                        {

                            "args": [

                                "Command: ['/sbin/service', u'vmware-vpostgres', 'start']\nStderr: "

                            ],

                            "id": "install.ciscommon.command.errinvoke",

                            "localized": "An error occurred while invoking external command : 'Command: ['/sbin/service', u'vmware-vpostgres', 'start']\nStderr: '",

                            "translatable": "An error occurred while invoking external command : '%(0)s'"

                        }

                    ],

                    "componentKey": null,

                    "problemId": null

                }

                ERROR:root:Unable to start service vmware-vpostgres, Exception: {

                    "resolution": null,

                    "detail": [

                        {

                            "args": [

                                "vmware-vpostgres"

                            ],

                            "id": "install.ciscommon.service.failstart",

                            "localized": "An error occurred while starting service 'vmware-vpostgres'",

                            "translatable": "An error occurred while starting service '%(0)s'"

                        }

                    ],

                    "componentKey": null,

                    "problemId": null

                }

                Unable to start service vmware-vpostgres, Exception: {

                    "resolution": null,

                    "detail": [

                        {

                            "args": [

                                "vmware-vpostgres"

                            ],

                            "id": "install.ciscommon.service.failstart",

                            "localized": "An error occurred while starting service 'vmware-vpostgres'",

                            "translatable": "An error occurred while starting service '%(0)s'"

                        }

                    ],

                    "componentKey": null,

                    "problemId": null

                }

                 

                Any idea on what it is?

                 

                Thank you!