0 Replies Latest reply on Jan 12, 2018 4:58 PM by magmaiceman

    VMware Player 12.5.9 fails host-side driver compilation for Linux kernel 4.13

    magmaiceman Lurker

      I've been using VMware Player for many many years so am quite familiar with it as well as its installation process.

       

      However I have a new LinuxMint 18.3 host-side installation (latest and greatest, and based on kernel 4.13) and the VMware Player installation process fails when compiling the host-side drivers: "Failed to build vmnet".  I've tried both 12.5.8 and 12.5.9 with the same result.  I've also tried installing it on an earlier host-side kernel (4.10), which works, but when upgrading the host to kernel 4.13, and then re-running VMware Player, which automatically initiates a VMware Player rebuild of the host side drivers, I get the same thing.  In other words, the build failure (perhaps unsurprisingly) fails whether VMware Player (12.5.8/12.5.9) is fresh installed on the Linux 4.13 kernel system, or whether they are installed on an earlier host-side-kernel system and then the host-side kernel is upgraded.

       

      Do the host side VMware drivers not work nicely with the Linux 4.13 kernel headers?