1 Reply Latest reply on Jan 14, 2018 7:32 PM by nancyz

    Trouble connecting to the internet after updating vmware fusion to 8.5

    ayushgoel Lurker

      I just updated my vmware fusion to 8.5 and now I can't connect to the internet anymore.
      ifconfig:

      ens33     Link encap:Ethernet  HWaddr 00:0c:29:ed:eb:88 

                UP BROADCAST MULTICAST  MTU:1500  Metric:1

                RX packets:0 errors:0 dropped:0 overruns:0 frame:0

                TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

       

       

      lo        Link encap:Local Loopback 

                inet addr:127.0.0.1  Mask:255.0.0.0

                inet6 addr: ::1/128 Scope:Host

                UP LOOPBACK RUNNING  MTU:65536  Metric:1

                RX packets:6452 errors:0 dropped:0 overruns:0 frame:0

                TX packets:6452 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1

                RX bytes:478080 (478.0 KB)  TX bytes:478080 (478.0 KB)

       

      ethtool ens33

      Settings for ens33:

              Supported ports: [ TP ]

              Supported link modes:   10baseT/Half 10baseT/Full

                                      100baseT/Half 100baseT/Full

                                      1000baseT/Full

              Supported pause frame use: No

              Supports auto-negotiation: Yes

              Advertised link modes:  10baseT/Half 10baseT/Full

                                      100baseT/Half 100baseT/Full

                                      1000baseT/Full

              Advertised pause frame use: No

              Advertised auto-negotiation: Yes

              Speed: Unknown!

              Duplex: Unknown! (255)

              Port: Twisted Pair

              PHYAD: 0

              Transceiver: internal

              Auto-negotiation: on

              MDI-X: Unknown (auto)

              Supports Wake-on: d

              Wake-on: d

              Current message level: 0x00000007 (7)

                                     drv probe link

              Link detected: no

      cat /etc/network/interfaces

      # interfaces(5) file used by ifup(8) and ifdown(8)

      auto lo

      iface lo inet loopback

       

       

      auto eth0

      iface eth0 inet dhcp

      lshw -class network

        *-network              

             description: Ethernet interface

             product: 82545EM Gigabit Ethernet Controller (Copper)

             vendor: Intel Corporation

             physical id: 1

             bus info: pci@0000:02:01.0

             logical name: ens33

             version: 01

             serial: 00:0c:29:ed:eb:88

             capacity: 1Gbit/s

             width: 64 bits

             clock: 66MHz

             capabilities: pm pcix bus_master cap_list rom ethernet physical logical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation

             configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI latency=0 link=no mingnt=255 multicast=yes port=twisted pair

             resources: irq:19 memory:fd5c0000-fd5dffff memory:fdff0000-fdffffff ioport:2000(size=64) memory:fd500000-fd50ffff

      I tried renaming the interface to eth0 using ip link set and then restarting the networking service, but to no avail.
      dhclient isn't able to give a dynamic ip address. I gave it a static ip address still doesn't work!!!

      Note, that the internet was working perfectly fine before upgrading vmware version.

      Any help would be sincerely appreciated?