7 Replies Latest reply on Jan 5, 2018 12:57 AM by a.p.

    esxi host network configuration

    sibsbt Enthusiast

      Procedure

      1

      In the System Customization menu, select Configure Management Network by using the keyboard arrows and press Enter.

       

      2

      In the Configure Management Network menu, select VLAN (option) and press Enter.

       

      3

      In the VLAN ID input text box, type the VLAN ID of the virtual LAN that your ESXi should use, and press Enter.

       

       

      When configuring esxi host network , Do I need to specify a vlanID (Step 3)

      Whay is that ?. What iF i put 4095  ,what does it means 4095 .

       

       

       

      Thanks

        • 1. Re: esxi host network configuration
          a.p. Guru
          Community WarriorsvExpertUser Moderators

          Whether you need to set a VLAN ID depends on the physical network configuration. In case of untagged ports on the physical switch, no VLAN ID must be entered (EST). In case of tagged (802.1Q) ports, all network packets (except for the native/default VLAN) need to be tagged (VST), i.e. the virtual port group needs to have a VLAN ID configured.

          VLAN ID 4095 is a special use case, where the network traffic is tagged by the guest operating itself (VGT).

          For more details about EST, VST, and VGT see e.g. https://kb.vmware.com/s/article/1003806

           

          André

          1 person found this helpful
          • 2. Re: esxi host network configuration
            sibsbt Enthusiast

            Hi,

             

            CONFIGURATION -1

             

            switch

            ------------------------------

            vlan 6

            vlan5

             

             

             

            interface GigabitEthernet1/2

            switchport

            switchport trunk encapsulation dot1q

            switchport trunk native vlan 6

            switchport trunk allowed vlan 10-100

            switchport mode trunk

             

             

             

             

            GUEST VM ARE VLAN 5

            Created a portgroup  VLAN 5

            assigned  portgroup to guest vm

             

             

             

             

            esxihost configuration

            Configure Management Network menu, selected VLAN (option )

            In the VLAN ID input text box, type the VLAN ID (4095) of the virtual LAN

             

             

            The above configuration can we consider as VST ?

            The above configuration is valid ?

             

             

             

             

             

            CONFIGURATION -2

             

             

            switch

            -----------------

            vlan 6

            vlan5

             

             

             

            interface GigabitEthernet1/2

            switchport

            switchport trunk encapsulation dot1q

            switchport trunk allowed vlan 10-100

            switchport mode trunk

             

             

            GUEST VM ARE VLAN 5

            Created a portgroup  VLAN 5

            assigned  portgroup to guest vm

             

             

            esxihost configuration

            Configure Management Network menu, selected VLAN (option )

            In the VLAN ID input text box, type the VLAN ID (6) of the virtual LAN

             

            vmware automatically createed a portgroup called management with vlan ID 6

             

             

            What is the difference between both configuration ?

            Which one is preferred ?

             

            Thanks

            • 3. Re: esxi host network configuration
              a.p. Guru
              vExpertCommunity WarriorsUser Moderators

              Unless there's a need to change the default VLAN, leave it at default (usually VLAN 1),

              Configure the physical port similar to "Configuration-2", and allow the required VLANs.

              Create virtual port groups with the VLAN-IDs you need.

               

              Sample:

              interface GigabitEthernet1/2

              switchport

              switchport trunk encapsulation dot1q

              switchport trunk allowed vlan 5,6,10-100

              switchport mode trunk

              spanning-tree portfast trunk

               

              André

              1 person found this helpful
              • 4. Re: esxi host network configuration
                sibsbt Enthusiast

                Hi,

                 

                Thanks for the reply .  So you suggest configuration 2 ?

                 

                How the esxi host configuration look like ?

                 

                 

                esxihost host management network

                 

                Configure Management Network menu, selected VLAN (option )

                 

                In the VLAN ID input text box, type the VLAN ID (6) of the virtual LAN, this will be six in my case ?

                 

                .

                It would be great if  you explain  traffic from vlan 6 ( host management )  and vlan 5 (guest)

                 

                 

                Thanks

                • 5. Re: esxi host network configuration
                  a.p. Guru
                  User ModeratorsvExpertCommunity Warriors
                  So you suggest configuration 2 ?

                  Yes, configuration-2 with the modification I posted.

                  With the trunk configuration, your physical switch will forward all network packets (see allowed VLANs in the configuration) with their VLAN-IDs to the ESXi host's vSwitch. The vSwitch will then forward these packets to the port groups, depending on their VLAN-ID. The port group will then remove the VLAN tag from the packet, and send it to the virtual machine.

                  The other way works similar. The VM will send network traffic, and the port group will add the VLAN tag to the packet, ...

                  It's basically the same as in a physical network environment, where the switch port - to which a system is connected - will usually be configured as an Access port, which then is responsible for the VLAN tagging.

                   

                  André

                  1 person found this helpful
                  • 6. Re: esxi host network configuration
                    sibsbt Enthusiast

                    Hi,

                    This is to understand

                     

                    Let's assume if I have configuration like below

                    esxihost configuration

                    Configure Management Network menu, selected VLAN (option )

                    In the VLAN ID input text box, type the VLAN ID (4095) of the virtual LAN.

                     

                    And on the switch side 

                     

                    switch port mode trunk .

                     

                    What will happen ?

                     

                    Thanks

                    • 7. Re: esxi host network configuration
                      a.p. Guru
                      User ModeratorsCommunity WarriorsvExpert

                      VLAN-ID 4095 (VGT - Virtual Guest Tagging) is for special use cases, where all tagged network packages are forwarded to the target. A use case could be e.g. a virtual router, or some kind of network analysis VM.

                      The usual way to work with VLANs in the virtual environment, is to configure trunk (802.1q) ports on the physical switch, and create separate port groups, each with the required VLAN-ID (VST - Virtual Switch Tagging). In this case the port group is responsible for removing/adding the VLAN tag from/to the network packets.

                      As for your example, set the VLAN-ID for the Management Network port group to the one of the subnet that's needed (VLAN-ID 6 if I understood you correctly).

                       

                      André