0 Replies Latest reply on Dec 15, 2017 7:40 PM by CinciTech

    Restoring a VM, ERROR: "" input file does not exists

    CinciTech Enthusiast

      I have set up ghettoVCB (Last modified: 2015_04_04_1) to backup a list of VMs on an ESXi 6.0 host, and scheduled the cron job, and this seems to work just fine.  The last step to confirming it's working well is to restore a backup, (and preferably now while it's not critical if it doesn't work, as opposed to AFTER someone breaks something and we find out the restore didn't work!)

       

      So I've got a datastore named "datastore1" with the VMs, including a file server called "fs1".  I also have an NFS share mounted as datastore "vmbackup".  Not big on originality, but simple.  I created a file called "vms_to_restore" and placed it in the root of the "vmbackup" datastore.  I created a file called "vms_to_restore".  The contents of the file are this:

       

       

          "/vmfs/volumes/vmbackup/fs1/fs1-2017-12-15_01-00-01;/vmfs/volumes/datastore1;3;fs1-2"

       

      I run the following command from SSH in ESXI:

       

          /opt/ghettovcb/bin/ghettoVCB-restore.sh –c /vmfs/volumes/vmbackup/vms_to_restore -d 1

       

      And i get this response:

       

          ERROR: "" input file does not exists

       

      I have so far read through the restore script and it looks like it's not seeing the file parameter.  I've tried deleting and recreating the file in the SSH shell.  I've double-checked all my paths, hit tab to watch them autocomplete so I know I didn't mistype something.  Can anyone point out what I'm obviously doing wrong?