1 Reply Latest reply on Dec 19, 2017 6:40 AM by parmarr

    Installing View Planner Agent Server on Windows 2012 R2 failed

    cmon75 Lurker

      Hello,

       

      I'm trying to install the View agent on a Windows 2012 R2 Server, with Horizon 7.3.2.

      No way, still a service (View Planner Agent) doesn't start with the following error :

       

      The instance's SvcRun() method failed

      Traceback (most recent call last):

        File "c:\python26\lib\site-packages\win32\lib\win32serviceutil.py", line 806, in SvcRun

          self.SvcDoRun()

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\serviceagent.py", line 71, in SvcDoRun

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\twisted_interface.py", line 31, in <module>

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\listener.py", line 17, in <module>

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\viewadmin.py", line 9, in <module>

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\view-python-apis\PowershellServiceClient.py", line 19, in <module>

        File "d:\build\ob\bora-3657232\performance\viewplanner\ViewAgent\Package\C\view-python-apis\mfw\__init__.py", line 105, in <module>

      SystemExit: MessageFrameWork Dll not found, need to be on system path

      %2: %3

       

      No specific error in setup log (setup-golden-parentVM)

       

      Mon, 11 Dec 2017 14:57:07 INFO     Platform detected: Intel64

      Mon, 11 Dec 2017 14:57:07 INFO     capturing stdout for command - wmic service where name='VMTools' get state /value|findstr State

      Mon, 11 Dec 2017 14:57:08 INFO     VMware tools status - Running

      Mon, 11 Dec 2017 14:57:08 INFO     VMware Tools is installed and running

      Mon, 11 Dec 2017 14:57:08 INFO     Twisted package to be installed. No previous copy found

      Mon, 11 Dec 2017 14:57:08 INFO     PyWin32 package to be installed. No previous copy found

      Mon, 11 Dec 2017 14:57:08 INFO     Current user is administrator or has admin privileges

      Mon, 11 Dec 2017 14:57:08 INFO     Running pre-Install Checks specifically for View Planner Agent-View

      Mon, 11 Dec 2017 14:57:08 INFO     Zope package to be installed. No previous copy found.

      Mon, 11 Dec 2017 14:57:08 INFO     capturing stdout for command - wmic service where name='wsbroker' get state /value|findstr State

      Mon, 11 Dec 2017 14:57:08 INFO     View Connection Server is installed and running

      Mon, 11 Dec 2017 14:57:59 INFO     Twisted package is successfully installed

      Mon, 11 Dec 2017 14:57:59 INFO     PyWin32 package is successfully installed

      Mon, 11 Dec 2017 14:57:59 INFO     capturing stdout for command - wmic service where name='ViewPlannerAgent' get state /value|findstr State

      Mon, 11 Dec 2017 14:57:59 ERROR    View Planner Agent service is not running. Please check view planner logs or windows event viewer by running eventvwr command on command prompt

      Mon, 11 Dec 2017 14:57:59 INFO     IP.txt successfully detected

      Mon, 11 Dec 2017 14:57:59 INFO     Harness IP found is 10.33.204.254

      Mon, 11 Dec 2017 14:57:59 INFO     Connecting to the appliance 10.33.204.254

      Mon, 11 Dec 2017 14:57:59 INFO     Attempting to get root object from harness

      Mon, 11 Dec 2017 14:57:59 INFO     Successfully got the harness root object. Harness configuration in IP.txt is valid

      Mon, 11 Dec 2017 14:57:59 INFO     Zope package is successfully installed

       

      Did someone have a solution ?

      I've try on 2 different server with a fresh install, using local administrator account as specified.

      No way.

       

      Thank you for your help.

      Best regards

      Cedric