1 8 9 10 11 12 Previous Next 167 Replies Latest reply on Aug 9, 2019 5:58 AM by MarnixDecokere Go to original post
      • 135. Re: High Sierra and Fusion "stuck" keys
        Bradall Enthusiast

        Sadly, as this has been outstanding for over 6 months I think I am swapping to Bross0 solution permanently. I think its clear that after half a year that this is not going to be fixed and without that the VM's are unusable. Guess thats the end of Fusion, at least for myself. Just purchased the option after the trial worked well.

        • 136. Re: High Sierra and Fusion "stuck" keys
          nobodyname Lurker

          I've had the same issue on my mac (with touchbar) but, lately i realized that the tab/command key get stuck way more often if a mouse is attached to the mac. When i unplug the mouse, switch to the host and then re-switch to the guest, the problem is basically gone.


          Anybody can confirm it?

          • 137. Re: High Sierra and Fusion "stuck" keys
            Bradall Enthusiast

            Happens if i had no external mouse wired or otherwise. Happens with internal touch pad. The only way I found around it was to use an external ssh session for a terminal and forward X11 so that there was no direct interaction with the guest through fusion at all.

             

            Bross0 solution enables using the guest directly without needing external ssh clients and or rdp/x11 clients.

            • 138. Re: High Sierra and Fusion "stuck" keys
              ak68 Lurker

              [continuing from my earlier post]

               

              Even with the keyboard mappings in effect, the VM is hardly usable.

               

              Aside from the "stuck key" issue I also have related issues that kill my productivity.

              Since my original detailed error description did not lead to an action from VMware I won't bother to describe the related issues here, as it seems a waste of time.

               

              My setup uses Ubuntu Linux 16 as guest OS.

               

              I recently went so far to do a complete re-install of the guest OS from the ground up, just to make sure this is not an issue in the guest VM side.

              The issue persists in the newly installed guest OS as well.

               

              Out of need for a working environment I have also tested VirtualBox as well as Parallels.

              With the same guest VM, converted from the VMware .vdmk image file, both other products did not show the "stuck keys" behavior.

              • 139. Re: High Sierra and Fusion "stuck" keys
                FerdH Novice

                The product is clearly defective. Parallels and VirtualBox do not experience this issue.

                 

                I've logged a ticket about this twice with VMware, the first one they "closed" because there is already "problem report" and my ticket would be attached to that. It showed up as "resolved" in the ticket overview. So I had another one opened, but not set to "closed". This issue should remain open until it's fixed.

                 

                I suggest everybody experiencing this to do the same.Log a ticket but don't let them close it until it's resolved. This way it hopefully will show up on their management radar sooner or later and be processed with a higher priority. VMware fusion is basically unusable now, as I've lost quite some work due to sticking Delete key, and I regret ever putting down the money for the product.

                 

                Just for my interest, would you want your money back or would you want this fixed?

                • 140. Re: High Sierra and Fusion "stuck" keys
                  Bradall Enthusiast

                  After 6 months it obvious that VMware have no intent to fix this issue at all. Moved to parallels and no more frustrations regarding VMs that are almost completely unusable and no more wasted time. I've moved on. I doubt that VMWare will fix this inside a year or if this is the end of the road for the product. With the lack of response it would appear that maybe it is the later and that there will be no more fusion.

                  • 141. Re: High Sierra and Fusion "stuck" keys
                    GSerjo Lurker

                    I have the same issue, I've tried to change vmconfig, I've tried so many ways to find a workaround and unfortunately, the workaround is a move to parallels.  Thank you, VMWare for the perfect support

                    • 142. Re: High Sierra and Fusion "stuck" keys
                      spacewrench Novice

                      FWIW, I just installed a fresh (demo) copy of Parallels-13 and a fresh Debian Linux VM, and the keyboard is even worse than VMware/Fusion.  I suspect it's a problem with the interface to MacOS -- however a VM app gets user interface events, it must be missing some of them.  The fact that native Mac apps don't do this suggests that it's something in the "raw" event interface (most native apps would use a cooked interface, I think.)

                       

                      It's surprising that it doesn't affect VMware developers enough to bother to fix it.  Or perhaps it's simply unfixable, until Apple provides a better version of High Sierra?  But in that case, it would help to at least know it's a MacOS problem instead of a VMware problem.

                      • 143. Re: High Sierra and Fusion "stuck" keys
                        GSerjo Lurker

                        I've moved to Parallels on 13.3.2 (43368), imported vmware image (windows 10) and really happy. All works fine, the keyboard issue is gone. Before import, I just uninstalled VMWare tools.

                        • 144. Re: High Sierra and Fusion "stuck" keys
                          needtothinkofaname Novice

                          2013 rMBP

                          High Sierra 10.13.6

                          Fusion 10.1.2

                          Guest Windows 7 SP1 up to date

                          Internal keyboard, monitor etc.

                          Eng. language

                          Setting typematicMinDelay = 20000 makes no difference!

                           

                          Please VMware - this is destroying data (press 'a' when the Ctrl key gets stuck -> select all. next key deletes text, 's' key -> save the now empty document (!!!)!!!!)

                           

                           

                           

                           

                           

                          1 person found this helpful
                          • 145. Re: High Sierra and Fusion "stuck" keys
                            Bradall Enthusiast

                            Odd my move to parallels removed the keyboard issue for myself. In Fusion a linux VM was almost unusable when the Touch Bar was enabled. Key bounce happened every time that the bar either dimmed or turned off. Given the no acknowledgement of when the complete issue would be addressed i simply needed to move. Cost me some $$ but far less frustration of looking up to see the last 10 lines of code have duplicated letters everywhere.

                            1 person found this helpful
                            • 146. Re: High Sierra and Fusion "stuck" keys
                              xiangk Novice
                              VMware Employees

                              Hi OrsoGrigio

                              Can you help to have a try with the following settings?

                               

                              in vm settings->keyboard&mouse->Edit Profile->Mac Host Shortcuts-> uncheck "Enable Mac OS Host keyboard Shortcuts".

                               

                              Thanks.

                              • 147. Re: High Sierra and Fusion "stuck" keys
                                Mikero Master
                                VMware Employees

                                Hi folks,

                                 

                                I just wanted to give a quick update here.

                                This has been a tricky issue for us to reproduce internally.

                                However, thanks to the involvement of the community, we were able to narrow down a potential root cause of this issue and will include fixes in our next updates.

                                 

                                This will apply to the current shipping versions of Fusion, and will persist when we release new versions in the fall. (i.e. you won't need to buy an upgrade to get this fix...)

                                • 148. Re: High Sierra and Fusion "stuck" keys
                                  GSerjo Lurker

                                  Hi Mikero,

                                   

                                  Thanks for the feedback.

                                   

                                  Why I've moved to parallels and don't plan to go back. There's only one reason, VMWare didn't care about customers. Yes, each software have bugs, it's ok, the most important how a company handle it. I really hope in some day the company changes it's attitude to there customers.

                                  • 149. Re: High Sierra and Fusion "stuck" keys
                                    Postpar Lurker

                                    Just as a quick check-in, I have the same problem, cheesegrater Mac Pro without USB Overdrive. I have gone through all the steps described here. It still happens, even with repeat-key off in both Windows and the Mac. The shift key is the worst at the moment.

                                     

                                    I am looking forward to your fix and hope I can understand your message to mean that you will have a fix to 10 soon, and that fix will be applied to 11 which is coming in the Fall? Because (a) I moved from Parallels largely to avoid annual upgrade costs, and (b) I really need this fixed now-ish.