1 6 7 8 9 10 Previous Next 167 Replies Latest reply on Aug 9, 2019 5:58 AM by MarnixDecokere Go to original post
      • 105. Re: High Sierra and Fusion "stuck" keys
        AppiePau Lurker

        I'd also want to report this issue with my work installation. Past weekend I reinstalled MacOS 10.13.4 on my mid 2014 Macbook Pro. Then the current VMWare Pro 10 (10.1.2 (8502123)) trial version.

         

        It al runs smoothly except the key problem. Sticking keys every five minutes! It is unusable for programming. Mostly the Ctrl is stuck. I have activated filter keys to mitigate the problem, but it is still problematic. I did experience this problem with version 8.x but not as bad as this. Every five minutes some keys are stuck!

        I have both tested the legacy BIOS and UEFI boot system, but nothing successful.

         

        Please help VMWare team or at least the acknowledgement of the issues would be highly appreciated.

        • 106. Re: High Sierra and Fusion "stuck" keys
          not_the_admin Lurker

          Just curious, how are VMWare employees represented in this forum. I couldn't find any official response to this issue - or any evidence that VMWare even acknowledging the issue. A bit of transparency into this issue would be nice - I would like to know if a solution is in the works or if I should look into migrating away.

          • 107. Re: High Sierra and Fusion "stuck" keys
            wila Guru
            vExpertUser ModeratorsCommunity Warriors

            Hi,

             

            For an official response you probably have to open a ticket at this moment.

            Note that I know of at least one case where the user opened a ticket and support resolved the issue for them.

            https://communities.vmware.com/message/2768541#2768577

             

            You can recognize vmware employees by a little black badge under their name that has the letters "vm" in white in it.

            Like this:

             

            VMware employees have participated on this thread, see answers 36, 72, 76, 79, 83 and 89.

             

            --

            Wil

            | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
            | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
            | More info at https://www.vimalin.com
            | Twitter @wilva
            | VMware Wiki at http://www.vi-toolkit.com
            • 108. Re: High Sierra and Fusion "stuck" keys
              FerdH Novice

              Have the same issue here and it's driving me nuts. I have a 2017 macbook pro i7 13", with external screen and external keyboard, vmware fusion pro 10, high sierra.

              I've tried most supposed remedies here; changed settings to the vmx, disabled 3d, reinstalled vmware fusion pro, didn't go for the apple developers version of OSX, that goes a bit too far for a production system. Can't work with this. Any progress in reproducing this by apple?

              [edit]

               

              @all - I might have found something that seems to alleviate the issue considerably for me -

              Try disabling "synchronize time" in the "advanced options" for the VM

              Guest time won't sync with the host, just enable NTP on the guests. - I wonder if this makes a difference for anyone else

               

              [edit]

              Still have key repeats, even with time sync off. Looks like it didn't work

              • 109. Re: High Sierra and Fusion "stuck" keys
                AppiePau Lurker

                Very interesting, I will try that later.

                 

                So far 'renewing' the mouse and keyboard profile has resolved a lot of issues for me as well (see: VMware Knowledge Base ). I'm still tesing it out, but it works a lot better, not perfect, but it is workable. I guess upgrading the VM guest and host from Windows 10 OEM till now and VMWare 8 to 10 has some glitches. But this issue also occurred with a more recent installation of my Windows 10 machines, but was still migrated from VMWare 8.

                 

                Next I'll try to disable the time synchronization. Good luck all!

                • 110. Re: High Sierra and Fusion "stuck" keys
                  Bradall Enthusiast

                  I'm running fusion 10.1.2 on a 2017 MAC Pro and i can say that the issue of the repeating keys occur whenever the touch bar is anything but completely 'on'. if its dim or out then the next key touched will repeat. This is 100% repeatable. Keep the touch bar on and there is no key repeat.

                  1 person found this helpful
                  • 111. Re: High Sierra and Fusion "stuck" keys
                    FerdH Novice

                    That seems to work! My macbook also has a touch bar.

                    I've set the touch bar to show just the F1-F12 keys.

                    Disabled the keyboard brightness adjustment

                    Press Fn key to expand control strip.

                    • 112. Re: High Sierra and Fusion "stuck" keys
                      Bradall Enthusiast

                      Glad it worked for you as well. It appears to all be linked to the Touch Bar on later MACs. Whenever it gets activated vmware fusion seems to repeat the last key.....everytime. For those without a Touch Bar I have no solution.

                      • 113. Re: High Sierra and Fusion "stuck" keys
                        FerdH Novice

                        Just had a stuck ctrl key with the touch bar not changing.

                        Unfortunately, this seems a dead end too.

                        • 114. Re: High Sierra and Fusion "stuck" keys
                          Bradall Enthusiast

                          Sad to hear that. On my mac I've not seen that just yet. Assuming its lurking some where. However with the bar being enabled the repeating keys drive me insane because it makes a VM with linux almost impossible to use because you only need to stop typing for a short period of time before the next key press repeats. Its boring on unusable unfortunately.

                          • 115. Re: High Sierra and Fusion "stuck" keys
                            ak68 Lurker

                            vanRijn

                             

                            Thank you for pursuing this issue further. Regarding your questions:

                             

                            1) Do you have the VMware Fusion > Preferences > Keyboard & Mouse > Mac Host Shortcuts > Enable Mac OS Host Keyboard Shortcuts checkbox checked when you are hitting this problem?

                             

                            Yes I have the checkbox checked.

                             

                            2) If so, does unchecking this checkbox help?

                            3) If not, does checking this checkbox help?

                             

                            Don't know yet, will post update when I have tried the new setting for some days.

                            Update: No, unchecking this checkbox did not help. The issue persists even though the box has been unchecked.

                             

                            And, just to clarify... is this happening in combination with Cmd+Tabbing in and out of the VM, or ungrabbing or switching between applications in the macOS host at all? Or should I be able to reproduce this by just opening a Win10 VM in single window mode, say, open Notepad, and type, occasionally holding shift and control occasionally and pressing other normal keys, without losing focus from the Win10 VM?

                             

                            I am working with multiple monitors in fullscreen mode. Guest OS is Linux Ubuntu 16 LTS. I am constantly switching with the mouse between the monitors., i.e. the host and the guest. However, the issue is not appearing directly after I switch from host to guest, but rather while I have been typing in the guest OS for some time.

                            • 116. Re: High Sierra and Fusion "stuck" keys
                              ak68 Lurker

                              @not_the_admin

                               

                              Thank you very much for this tip. Disabling the key repeat does actually make things MUCH better.

                               

                              Here's a little .xinitrc script I wrote to disable the repeat function for the problem keys at startup:

                               

                              #!/bin/bash
                              
                              # Disbaling repeat for severaly keys
                              # See https://unix.stackexchange.com/questions/49650/how-to-get-keycodes-for-xmodmap
                              
                              # 22: Backspace
                              # 37: Control_L
                              # 53: x
                              # 54: c
                              # 55: v
                              
                              xset -r 22
                              xset -r 37
                              xset -r 53
                              xset -r 54
                              xset -r 55
                              
                              • 117. Re: High Sierra and Fusion "stuck" keys
                                Bradall Enthusiast

                                I've noticed that with an external keyboard connected via a dock I have no issues with my 2017 Mac Pro in regards to the keys sticking. Its only when trying to use the internal keyboard which is generally every time you not at a fixed desk. When using the internal keyboard it occurs on all keys. As I generally use server related images than desktops the set commands do not assist. I guess I just can not use any fusion related entity when not carting around an external keyboard. I'm also still on 10.13.3 dues to .4 breaking Display link capabilities.

                                • 118. Re: High Sierra and Fusion "stuck" keys
                                  FerdH Novice

                                  Which dock are you using? I'm using a Minix, still have the issue with external keyboard

                                  • 119. Re: High Sierra and Fusion "stuck" keys
                                    Bradall Enthusiast

                                    I'm using a Dell displaylink dock and still on 13.3 to make it work but don't rush out i just had a repeating rrrrrr key ;(

                                    1 6 7 8 9 10 Previous Next