1 2 3 Previous Next 87 Replies Latest reply on Oct 19, 2018 3:45 PM by f92809

    VMware workstation 14 Pro loses Mouse Focus

    xmick Novice

      Has any one found / have a solution for - Mouse repeatable loses focus after a short time. Focus restored by moving mouse to top of screen over Vmware menu bar.

      No problem on VMW 12.

        • 2. Re: VMware workstation 14 Pro loses Mouse Focus
          mparrott Novice

          I am having the same issue. I am running Windows 10 x64 1709. None of my virtual machines work correctly when I install Workstation 14.0. The mouse only seems to register once inside a virtual machine IF you first click on one of the VMware Workstation menus first. If I reinstall 12.5.x everything is back to normal. I tried all the steps documented in the two KB articles. At this point WS 14 is useless to me.

          • 3. Re: VMware workstation 14 Pro loses Mouse Focus
            altae Novice

            Exactly the same here. I can click exactly once before I have to move the mouse cursor out of the VM in order to be able to click once more... But strangely it does not lose focus completely as I'm still able to move the mouse cursor within the VM even if no more clicks are registered. And the keyboard is also not affected by this bug. It's only the mouse clicks that are not registered correctly (well the first click is but every successive click isn't). The problem is not present in Workstation Pro 12.5.8 and below, only in Workstation Pro 14.

             

            Host: Windows 10 version 1709, build 16299.98, 64 bit

            Guests: Linux Mint 18 64 bit and Fedora 27, 64 bit, it happens to both

             

            Please fix this, it's really annoying to have a valid Workstation Pro 14 license that I cannot use because of this bug.

            • 4. Re: VMware workstation 14 Pro loses Mouse Focus
              AppleBag Novice

              Same. I registered to the forum just to post this, and then I saw this thread. Glad it's not just me this is happening to.

               

              I was theorizing that possibly another hidden app was stealing focus, so I ran 2 different Foregroundwindow/Active Window trackers, and neither of them show anything is stealing focus.

               

              I really hope this gets fixed ASAFP, as I use one of my Vms for shareware development, and having this affect me seriously hampers productivity, let alone the frustration involved.

               

              My specs:

              Win 10 x64: OS Version 10.0.14393.1914 (Win10 RS1)

              Latest version of VMW, updated, and reinstalled VMTools a couple times to confirm it was installed properly.

              • 5. Re: VMware workstation 14 Pro loses Mouse Focus
                FlorianLedoux Lurker

                Similar problem here.

                 

                Except that I manage to click correctly for a while. After a few minutes of work (switching between VM and the Windows 10 host), the click does not work in the VM.

                 

                Hovering VMware menu bar restores correct behavior.

                • 6. Re: VMware workstation 14 Pro loses Mouse Focus
                  mparrott Novice

                  Has anyone here tried V14 on a Win7 host to see if the problem shows up there as well? I have a Win7 server, but hesitate to install V14 on it if the problem exists there as well.

                  • 7. Re: VMware workstation 14 Pro loses Mouse Focus
                    f2065 Novice

                    I have a similar problem.

                    Mouse buttons do not work in the guest OS.

                    After losing the focus and re-focusing the window - the click once works, and again does not work.

                    It is necessary before each click of the mouse - to press Ctrl+Alt.

                     

                    Versions of VMware - the problem started after the upgrade to 14.0. I thought that in 14.1 it will be fixed - but in 14.1 the problem is the same.

                    In 12.5.7 and previous versions, there has never been such a problem.

                     

                    I tried to change all the settings in the Preferences - Input (Grab ..., Cursor ..., Optimize mouse for games).

                    I tried to make a new virtual machine and reinstall the guest OS.

                    I tried CPU virtualization settings, tried to remove the USB interface in vmware completely.

                    All this did not help!

                     

                    The guest OS sees mouse movements (this is confirmed by the appearance of tooltips wherever they are), but mouse clicks do not.

                    Host OS - Windows 8.1 x64. Guest OS - Windows XP, Windows 7, Windows 8.1 x64, Ubuntu...

                     

                    And, I have exactly the same problem on the second computer - a laptop.

                     

                    I returned to the old VMware 12.5.7 - there are no problems with the mouse there.

                    • 8. Re: VMware workstation 14 Pro loses Mouse Focus
                      level420 Lurker

                      I have a similar problem here with a windows 7 multi monitor guest with VMware workstation 14.1.0 Pro

                       

                      If I have more than one monitor attached to the guest the mouse pointer disappears and I have to click again to make it visible or regain focus.

                       

                      If I only have one monitor the problem is not there.

                       

                      I've uninstalled the VMware tools shipped with 14.1.0 and re-installed the VMware tools from version 12.5.8 which solved the problem.

                       

                      The old VMware tools are available at http://softwareupdate.vmware.com/cds/vmw-desktop/ws/12.5.8/7098237/windows/packages/tools-windows.tar

                      • 9. Re: VMware workstation 14 Pro loses Mouse Focus
                        f2065 Novice

                        Using vmtools-12 in vmware-14 - the problem with the mouse does not solve:

                        I had a virtual OS from vmware 12 - they had vmtools v12.

                        And the mouse did not click (after installing vmware-14).

                        I then updated vmtools to version 14 - but the mouse still does not click.

                        • 10. Re: VMware workstation 14 Pro loses Mouse Focus
                          xmick Novice

                          Installing Vmware 12 tools doesn't solve the problem.

                          • 11. Re: VMware workstation 14 Pro loses Mouse Focus
                            altae Novice

                            Still the same issue after updating to 14.1. Updating the guest's Linux kernel to 4.14 has not fixed the issue neither. Sorry VMWare, version 14 is an epic fail

                            • 12. Re: VMware workstation 14 Pro loses Mouse Focus
                              Expert
                              vExpert

                                 The mouse driver installed by VMware Tools is called VMware Pointing Device. Windows Sysprep  or update may have been configured to modify the the mouse driver. If the VMware mouse driver has been replaced with another driver, the mouse position may no longer update correctly.

                               

                              o resolve this issue, ensure that the mouse driver is the VMware Pointing Device driver:

                              1. Log in to the virtual machine. 
                              2. Right-click My Computer and click Manage
                              3. Select Device Manager and expand Mice and other pointing devices
                              4. The VMware driver is named VMware Pointing Device. If another driver is present, update the driver: 
                                1. Right-click the mouse driver and click Update Driver Software
                                2. Browse to the C:\Program Files\VMware\VMware Tools\Drivers\mouse and click Next
                                3. Select VMware Pointing Device and click Next.

                              Note: The operating system may need to be rebooted for the change to take effect.

                               

                               

                              Did you try to uninsatll vmware tool and re install again .....

                              • 13. Re: VMware workstation 14 Pro loses Mouse Focus
                                xmick Novice

                                Thanks, but the solution doesn't work.

                                 

                                I think all the people in this thread who have the problem have reinstalled Vmware tools more than once.

                                 

                                One also has to consider that most of us have more than one VM and they all have this problem whatever the guest operating system - Linux or Windows.

                                 

                                All indications so far is that there is a problem with Vmware 14 or its tools as the problem goes away if we revert back to Vmware 12.

                                • 14. Re: VMware workstation 14 Pro loses Mouse Focus
                                  AppleBag Novice

                                  Does VMWare even look at these forums? I mean, Good God .......

                                   

                                  I can't get any developing done because of this. Writing software is hair-loss promoting enough as it is already, we don't need the addition of this stupid bug to add to it every 3 seconds. I think it's pretty clear it's a VMTools bug.

                                  1 2 3 Previous Next