9 Replies Latest reply on Nov 29, 2017 6:26 PM by Cosz3

    Can not create datastore with discovered iSCSI target.

    Cosz3 Novice

      hello,

       

      I am trying to test vsphere with iSCSI.

       

      I deployed a iSCSI target service on CentOS 7 with test steps:

       

      1. disable firewalld, disable Selinux

      2. yum -y install targetcli, and start up target service

      3. configure iSCSI target

           a. create block storage:

               QQ20171129-111620@2x.png

           b. create iqn:

                QQ20171129-111832@2x.png

           c. create LUN mapping to the block storage:

                QQ20171129-112051@2x.png

          d. I did not create ACL on iSCSI target, I just want to everyone have access to this iSCSI. I do not know if it correct or not to not configure ACL on iSCSI, hope someone could give me some hint here.

      4. I check the iSCSI server port 3260 is listennning.

       

      After I deploy an iSCSI server as above. I go to configure vsphere vcenter.

      I did these steps:

       

      1.  I created a new virtual standard switch vSwitch 1 with vmkernel, and uplink vmnic 5.

           QQ20171129-113129@2x.png

      2. I start a software iSCSI storage adapter

           QQ20171129-113249@2x.png

      4. I bind the vmnic 5 with iSCSI storage adapter vmhba64

           QQ20171129-113726@2x.png

      5. I use dynamic discover the iSCSI target,

           QQ20171129-113908@2x.png

      6. Then the vsphere find this

           QQ20171129-114015@2x.png

                 QQ20171129-114221@2x.pngQQ20171129-114208@2x.pngQQ20171129-114153@2x.png

          as you can see there, the devices tab, path tab, there is nothing there, I do not know if it is normal (but I created a LUN 0 on iSCSI target server before.)

            I have a question about the iSCSI name, is this iSCSI  name (on vsphere) should be the same name as iqn which I create on iSCSI target server ? 

       

       

      7. Finally I try to create a datastore with the iSCSI, I can not find the iSCSI corresponding disk device on vsphere

           QQ20171129-115044@2x.png

              QQ20171129-115210@2x.png

       

      questions:

      1.  On iSCSI server I did not configure ACL, I hope everyone can connected to the iSCSI server, does it affect something or leading some error?

      2.  Should the iSCSI Name on vsphere be the same as the iqn of iSCSI target server that I configured.

      3.  The vsphere find the iSCSI target server, but Why I can not find the corresponding disk devices LUN 0 on iSCSI target server?  

       

       

      I really need someone's helps, a million thanks to all of you.

       

      Best regards

      shengping