5 Replies Latest reply on Nov 29, 2017 3:22 PM by kaiuto23

    NSX Controller Failed to Deploy "waiting for controller ready"

    kaiuto23 Lurker

      First time using the community so please let me know if I'm breaking any rules.

       

      I have a lab running at home and I'm trying to deploy NSX so I can study with hands on experience. I'm struggling with deploying an NSX controller. I keep getting this error "waiting for NSX controller ready controller-14 failed in deployment- Timeout on waiting for controller ready" I know this is basically saying hey I never heard back from this guy so I'm canceling this deployment but I can't figure out why its failing. I know why it never hears back from the controller and that's because I can never ping it from any device. (NSX-Manager, ESXi host its on, and the SVI on the switch) I have a vDS with one port group on vlan 23 (SVI on a 3560 as the D.G.) where all my other VMs are and they work fine. I deployed a Win-7 VM in this Port group to make sure its not that and the VM worked perfectly with no networking problems. I have triple checked the IP pools and they have the correct subnet, DG, Domain, DNS, and IP info. The Controller is being deployed on the same network as the manager so there's no routing going on between the manger and controller. I have looked on Google and none of the solutions have helped me solve this. I searched on the forums here and didn't find anything. After checking the pools I made sure the port the controller is connected to is on vlan 23 and shows as up(green) but nothing can talk to it. I have tried deploying it on different hosts with no success. I have the host part setup but I cant get a controller to deploy. Also I can never login to the controller after its deployed if that helps at all. If anyone can throw some suggestions my way I would appreciate it.

       

      Side notes,

      NTP is setup and working with synced times, DNS is good to go, Everything can talk to each other besides the controller being deployed.

       

      Thanks for looking,

      K.