1 2 3 4 Previous Next 50 Replies Latest reply on Jul 15, 2020 12:55 PM by shkamath Go to original post
      • 45. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
        Mikero Master
        VMware Employees

        VMware Fusion 10.1.2 is available now with a fix for this particular caps lock issue.

         

        Release notes: bit.ly/2KLbxiD  Download: bit.ly/2xa49eP

        • 46. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
          HeiderSati Novice

          Hi VMWare Support,

           

          I'm on Fusion 8.x, no updates about this yet, is there?

           

          This problem is giving me the worst nightmare possible..

           

          I tried:

           

          1) Switching CAPS off and on from Host/Guest

          2) Sending "CAPS KEY" from the VM menu, solves it but then comes back 10 seconds later

          3) Suspend VM, Wake up, same problem.

           

          Why has this stopped working suddenly!?

           

          As a machine code developer, the VM should be reading from low-memory 0x0000:0x0417 and respect the status bits in there, this is not happening causing the CAPS lock to act all by itself using your own buffer. Please remove the buffer and only use the original 0x417 status bits.

           

          Regards

          Heider

          • 47. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
            wila Guru
            User ModeratorsvExpertCommunity Warriors

            Hi HeiderSati,

             

            The problem in this thread is about an early release of VMware Fusion 10.

            There's no logic in Fusion 8.x where it tries to sync inconsistent capslock states.

            If the behavior suddenly changed then look at what has changed on your host or VM.

             

            Also note that VMware Fusion 8.x has been EOL for quite a while.

            --

            Wil

            | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
            | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
            | More info at https://www.vimalin.com
            | Twitter @wilva
            | VMware Wiki at http://www.vi-toolkit.com
            • 48. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
              wila Guru
              vExpertCommunity WarriorsUser Moderators

              FYI, just bumped into this issue Fusion 11.0.3.

              Super annoying as I switch between guests and hosts continuously.

              I applied the workaround in the config file to regain my sanity.

               

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 49. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
                RGulde Lurker

                Editing the <VirtualMachineName>.vmx file and adding

                 

                mks.keyboard.setHostLEDs=FALSE

                 

                To the end of the file fixed my issue. Thank you so much!

                • 50. Re: Caps lock always turn on after switching from Windows 10 Virtual Machine to Host
                  shkamath Novice

                  Hahaha.  Nothing like having an issue, searching for it because you have vague recollections about the issue, and finding this thread and seeing in it someone thanking yourself for helping them fix it! :-)

                   

                  I note that the KB article that says how to fix this issue is no longer there (but Google cached it on July 11, 2020, so you can still find it if you google "vmware kb 52589" and select the cached version).

                   

                  This issue came back with Fusion Pro 11.5.5, running macos 10.15.5 on both the host and the guest, on a 2018 15" MBP.

                   

                  The original KB article said to create the file "~/Library/Preferences/VMware Fusion/config" with the one line:

                   

                  mks.keyboard.setHostLEDs="FALSE"

                   

                  As RGulde stated, you can add this to the individual VMX files for a VM.  I assume that putting it in the file called 'config' in the preferences folder enables the setting for all VMs, not just the one the VMX file controls.  On the otherhand, you don't have to create a new file, just edit an existing one (and you don't have to shut down VMware Fusion.

                   

                  Anyway, time will tell if this fixes the issue I'm having with 11.5.5.

                  1 2 3 4 Previous Next