0 Replies Latest reply on Oct 30, 2017 12:42 AM by jensjensen2

    MacOS 10.12 and 10.13: USB storage not recognized

    jensjensen2 Lurker

      Hi,

       

      i'm new to ESXi. I have installed ESXI 6.5U1 build 6765664 on a Macbook Pro Mid 2012 (i5 2,5GHz 2C/4T, 16 GB RAM, SSD). I currently have one VM running Ubuntu 16.04, one running MacOS Sierra 10.12, and another one running MacOS High Sierra 10.13. Since i want to use the server for (among other) NAS and backup purposes, i have bought two USB 3.0 4TB external hard drives, which i have attached to the USB 3.0 ports of the machine.

       

      The strange thing is that both versions of MacOS seem unable/-willing to properly recognize the external hard drives, although i have no trouble at all on the Ubuntu VM! I have tried using both USB 2.0 and 3.0 controller options in the VM hardware config, and neither work. In the Ubuntu VM, i have no trouble attaching the drives via the USB 3.0 controller and accessing the contents of the drives. In the MacOS VMs, the drives appear in the System Report as USB devices, but nothing beyond that. They don't appear in the Disk Utility GUI, and if i "diskutil list" in Terminal, they don't show up either.

       

      I've also tried Passthrough for the USB Host controllers directly, but the VMs won't start due to some error, so i haven't pursued that direction any further.

       

      Any ideas? Could anybody please verify if USB storage devices work in their MacOS VMs?

       

      Thanks a lot