1 2 Previous Next 16 Replies Latest reply on Nov 15, 2017 10:38 PM by Lenonking9

    VMWare Fusion 10.0.1 doesn't see USB devices anymore [SOLVED]

    Yvo999 Lurker

      My previous setup was:

       

      MacOS 10.12 Sierra

      VMWare Fusion 7.1, running

      - Windows 7

      - Windows 10

       

      All was fine until I upgraded to MacOS 10.13, High Sierra.

       

      Started VMWare Fusion, all well. Started the Windows 7 VM and my iMac crashed instantly. Split second.

       

      Upgraded to VMWareFusion 10.0.1.

       

      Got the "System Extension Blocked" message and allowed VMWare Fusion in the MacOS Security & Privacy settings.

       

      But both Windows 7 and Windows 10 VM's don't see USB devices anymore. No error message, no warning. They just don't see them.

       

      I Googled around, even saw the other post related the subject below, but no solution found.

       

      ???

       

      Edit: Completely removed VMWare Fusion and did a clean install. Still the same problem...

       

      Edit 2: Shouldn't there be an usbarbitrator service running in the VM's? I don't see any. Also /var/run/vmware doesn't show anything related.

       

      Edit 3: The service usbarbitration (on the host) doesn't run. /Library/Logs/VMware USB Arbitrator Service.log contents:

       

      2017-10-07T19:47:01.361| ServiceImpl_Daemon: PID 833

      2017-10-07T19:47:01.362| ServiceImplRef: Before start().

      2017-10-07T19:47:01.576| Warning: UsbarbServiceCommon: exit status 6912.

      2017-10-07T19:47:01.576| ServiceImplRef: After start().

      2017-10-07T19:47:01.576| ServiceImplDaemon: Exiting with code 0.

       

      Started VMWare Fusion and started usbarbitrator by hand: sudo /Applications/VMware\ Fusion.app/Contents/Library/vmware-usbarbitrator --kext /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmioplug.kext

       

      Same results, not working, not running. And log file shows the same.

       

      Beats me.

       

      Yvo

        1 2 Previous Next